aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2006-11-14 04:33:04 +0000
committerMax Khon <fjoe@FreeBSD.org>2006-11-14 04:33:04 +0000
commit521ebc7ce91e32221db9823870a87b850b38ca43 (patch)
tree4c9efc8dff0d7a63f8dad6184e717e0788d63e86
parent375ae2ae35fd96d54588b051ed83c10437a1cf79 (diff)
downloadports-521ebc7ce91e32221db9823870a87b850b38ca43.tar.gz
ports-521ebc7ce91e32221db9823870a87b850b38ca43.zip
Notes
-rw-r--r--emulators/dynamips-devel/Makefile4
-rw-r--r--emulators/dynamips-devel/files/patch-Makefile4
-rw-r--r--emulators/dynamips/Makefile4
-rw-r--r--emulators/dynamips/files/patch-Makefile4
4 files changed, 10 insertions, 6 deletions
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index 08561b3c1285..497591cc9e33 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -18,10 +18,12 @@ LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
USE_GMAKE= yes
USE_GCC= 3.2+
+USE_GETOPT_LONG=yes
ALL_TARGET= ${PORTNAME}
MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
- PTHREAD_LIBS=${PTHREAD_LIBS}
+ PTHREAD_LIBS=${PTHREAD_LIBS}\
+ LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/${PORTNAME}
.if !defined(NOPORTDOCS)
diff --git a/emulators/dynamips-devel/files/patch-Makefile b/emulators/dynamips-devel/files/patch-Makefile
index 088a8e3cced2..8f90939acbd7 100644
--- a/emulators/dynamips-devel/files/patch-Makefile
+++ b/emulators/dynamips-devel/files/patch-Makefile
@@ -1,5 +1,5 @@
--- Makefile.orig Thu Sep 14 17:59:13 2006
-+++ Makefile Wed Oct 18 22:38:24 2006
++++ Makefile Tue Nov 14 10:27:26 2006
@@ -12,6 +12,9 @@
# (WinPcap is used for Cygwin)
HAS_PCAP?=1
@@ -28,7 +28,7 @@
- LIBS=-L/usr/local/lib -L. -lelf $(PTHREAD_LIBS)
+ LOCALBASE?=/usr/local
+ CFLAGS+=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/libelf $(PTHREAD_CFLAGS)
-+ LIBS=-L$(LOCALBASE)/lib -L. -lelf $(PTHREAD_LIBS)
++ LIBS=-L$(LOCALBASE)/lib -L. -lelf $(PTHREAD_LIBS) $(LDFLAGS)
else
ifeq ($(shell uname -s), Darwin)
CFLAGS+=-I/usr/local/include -mdynamic-no-pic
diff --git a/emulators/dynamips/Makefile b/emulators/dynamips/Makefile
index 08561b3c1285..497591cc9e33 100644
--- a/emulators/dynamips/Makefile
+++ b/emulators/dynamips/Makefile
@@ -18,10 +18,12 @@ LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
USE_GMAKE= yes
USE_GCC= 3.2+
+USE_GETOPT_LONG=yes
ALL_TARGET= ${PORTNAME}
MAKE_ENV= DYNAMIPS_ARCH=${DYNAMIPS_ARCH}\
PTHREAD_CFLAGS=${PTHREAD_CFLAGS}\
- PTHREAD_LIBS=${PTHREAD_LIBS}
+ PTHREAD_LIBS=${PTHREAD_LIBS}\
+ LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/${PORTNAME}
.if !defined(NOPORTDOCS)
diff --git a/emulators/dynamips/files/patch-Makefile b/emulators/dynamips/files/patch-Makefile
index 088a8e3cced2..8f90939acbd7 100644
--- a/emulators/dynamips/files/patch-Makefile
+++ b/emulators/dynamips/files/patch-Makefile
@@ -1,5 +1,5 @@
--- Makefile.orig Thu Sep 14 17:59:13 2006
-+++ Makefile Wed Oct 18 22:38:24 2006
++++ Makefile Tue Nov 14 10:27:26 2006
@@ -12,6 +12,9 @@
# (WinPcap is used for Cygwin)
HAS_PCAP?=1
@@ -28,7 +28,7 @@
- LIBS=-L/usr/local/lib -L. -lelf $(PTHREAD_LIBS)
+ LOCALBASE?=/usr/local
+ CFLAGS+=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/libelf $(PTHREAD_CFLAGS)
-+ LIBS=-L$(LOCALBASE)/lib -L. -lelf $(PTHREAD_LIBS)
++ LIBS=-L$(LOCALBASE)/lib -L. -lelf $(PTHREAD_LIBS) $(LDFLAGS)
else
ifeq ($(shell uname -s), Darwin)
CFLAGS+=-I/usr/local/include -mdynamic-no-pic