aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2018-10-31 05:10:50 +0000
committerCy Schubert <cy@FreeBSD.org>2018-10-31 05:10:50 +0000
commit5df07e7f564fcf28cf124f4522571a8e84dd9a19 (patch)
treeca9ff61194941d48ab185ea5003de3b9ed6f4d48
parent66df9fc4affe922917d7a205ecce3185d0d07872 (diff)
downloadports-5df07e7f564fcf28cf124f4522571a8e84dd9a19.tar.gz
ports-5df07e7f564fcf28cf124f4522571a8e84dd9a19.zip
Rather than flag cfengine ports that do not support openssl111
unconditionally BROKEN under FreeBSD 12 & 13, only flag BROKEN when security/openssl is not installed on systems after openssl111 was committed to 12-CURRENT. PR: 232709 Reported by: linimon
Notes
Notes: svn path=/head/; revision=483549
-rw-r--r--sysutils/cfengine310/Makefile13
-rw-r--r--sysutils/cfengine311/Makefile13
-rw-r--r--sysutils/cfengine32/Makefile13
-rw-r--r--sysutils/cfengine33/Makefile13
-rw-r--r--sysutils/cfengine34/Makefile13
-rw-r--r--sysutils/cfengine35/Makefile13
-rw-r--r--sysutils/cfengine36/Makefile13
-rw-r--r--sysutils/cfengine37/Makefile13
-rw-r--r--sysutils/cfengine38/Makefile13
-rw-r--r--sysutils/cfengine39/Makefile20
10 files changed, 107 insertions, 30 deletions
diff --git a/sysutils/cfengine310/Makefile b/sysutils/cfengine310/Makefile
index f709d29e5fca..950f772c2d2c 100644
--- a/sysutils/cfengine310/Makefile
+++ b/sysutils/cfengine310/Makefile
@@ -17,8 +17,6 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-9]-* cfengine31[1-9]-*
.if !defined(MASTERDIR)
@@ -72,4 +70,13 @@ MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine311/Makefile b/sysutils/cfengine311/Makefile
index e7ff2aebb5b4..8dc40981979a 100644
--- a/sysutils/cfengine311/Makefile
+++ b/sysutils/cfengine311/Makefile
@@ -18,8 +18,6 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-9]-* cfengine31[02-9]-*
.if !defined(MASTERDIR)
@@ -75,4 +73,13 @@ MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine32/Makefile b/sysutils/cfengine32/Makefile
index 5a5bc24f845e..4703049984e6 100644
--- a/sysutils/cfengine32/Makefile
+++ b/sysutils/cfengine32/Makefile
@@ -17,8 +17,6 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
@@ -48,4 +46,13 @@ post-patch:
@${REINPLACE_CMD} -e '/^htmldir/s!=.*!= @htmldir@!'\
${WRKSRC}/docs/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine33/Makefile b/sysutils/cfengine33/Makefile
index 279ae2ff3053..cb4d1e995534 100644
--- a/sysutils/cfengine33/Makefile
+++ b/sysutils/cfengine33/Makefile
@@ -16,8 +16,6 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
@@ -85,4 +83,13 @@ CONFIGURE_ARGS+= --with-libvirt=${LOCALBASE}
LIB_DEPENDS+= libvirt.so:devel/libvirt
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine34/Makefile b/sysutils/cfengine34/Makefile
index b3330a5eefbe..799fd2119fe1 100644
--- a/sysutils/cfengine34/Makefile
+++ b/sysutils/cfengine34/Makefile
@@ -15,8 +15,6 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-35-9]-* cfengine31[0-9]-*
.if !defined(MASTERDIR)
@@ -93,4 +91,13 @@ post-patch:
@${REINPLACE_CMD} -e '/^htmldir/s!=.*!= @htmldir@!'\
${WRKSRC}/docs/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine35/Makefile b/sysutils/cfengine35/Makefile
index ece61cd9ec74..7375e296c50b 100644
--- a/sysutils/cfengine35/Makefile
+++ b/sysutils/cfengine35/Makefile
@@ -14,8 +14,6 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
@@ -90,4 +88,13 @@ CONFIGURE_ARGS+= --with-libvirt=${LOCALBASE}
LIB_DEPENDS+= libvirt.so:devel/libvirt
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine36/Makefile b/sysutils/cfengine36/Makefile
index d0eafeb362d7..94857632ad22 100644
--- a/sysutils/cfengine36/Makefile
+++ b/sysutils/cfengine36/Makefile
@@ -15,8 +15,6 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-57-9]-* cfengine31[0-9]-*
.if !defined(MASTERDIR)
@@ -71,4 +69,13 @@ MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine37/Makefile b/sysutils/cfengine37/Makefile
index 0e1522570153..cd596d4cfa61 100644
--- a/sysutils/cfengine37/Makefile
+++ b/sysutils/cfengine37/Makefile
@@ -13,8 +13,6 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
@@ -70,4 +68,13 @@ MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS= libvirt.so:devel/libvirt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine38/Makefile b/sysutils/cfengine38/Makefile
index 2801e978a32d..2602fea3b566 100644
--- a/sysutils/cfengine38/Makefile
+++ b/sysutils/cfengine38/Makefile
@@ -14,8 +14,6 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
@@ -72,4 +70,13 @@ MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS= libvirt.so:devel/libvirt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine39/Makefile b/sysutils/cfengine39/Makefile
index fd1e6e068781..1cb9bbb15f27 100644
--- a/sysutils/cfengine39/Makefile
+++ b/sysutils/cfengine39/Makefile
@@ -13,8 +13,6 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
-BROKEN_FreeBSD_12= openssl111 is not supported
-BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
@@ -74,4 +72,20 @@ MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1200085
+.if ${SSL_DEFAULT} != "openssl"
+BROKEN_FreeBSD_12= fails to build with openssl111, install security/openssl
+BROKEN_FreeBSD_13= fails to build with openssl111, install security/openssl
+.endif
+.endif
+
+.include <bsd.port.post.mk>