aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-05-07 15:32:07 +0000
committerChris Rees <crees@FreeBSD.org>2012-05-07 15:32:07 +0000
commit5f7b5ab11d8ed9fc943d53ca835cbd9b4ce08384 (patch)
tree97f5313e909983753e3383f9466d5aacd030f3db
parent0feeeca730fa85eced2f7aae13c181a741f4da7c (diff)
downloadports-5f7b5ab11d8ed9fc943d53ca835cbd9b4ce08384.tar.gz
ports-5f7b5ab11d8ed9fc943d53ca835cbd9b4ce08384.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/cutemaze/Makefile60
-rw-r--r--games/cutemaze/distinfo2
-rw-r--r--games/cutemaze/pkg-descr7
-rw-r--r--games/cutemaze/pkg-plist37
5 files changed, 107 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index de870f4e9fa7..e41019313933 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -158,6 +158,7 @@
SUBDIR += cube
SUBDIR += cultivation
SUBDIR += cursive
+ SUBDIR += cutemaze
SUBDIR += cuyo
SUBDIR += d2x
SUBDIR += d2x-xl
diff --git a/games/cutemaze/Makefile b/games/cutemaze/Makefile
new file mode 100644
index 000000000000..f2c787bb507f
--- /dev/null
+++ b/games/cutemaze/Makefile
@@ -0,0 +1,60 @@
+# Ports collection Makefile for: cutemaze
+# Date created: 20 April 2012
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= cutemaze
+PORTVERSION= 1.1.0
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Is a simple, top-down game in which mazes are randomly generated
+
+LICENSE= GPLv3
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+MAKE_JOBS_SAFE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build iconengines imageformats
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ENV+= UIC="${UIC}" QMAKE="${QMAKE}" QMAKESPEC="${QMAKESPEC}"
+MAKE_ENV+= QMAKESPEC="${QMAKESPEC}"
+
+PORTDATA= *
+PORTDOCS= ChangeLog README
+INSTALLS_ICONS= yes
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} PREFIX=${PREFIX} ${WRKSRC}/${PORTNAME}.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/icons/oxygen
+.for d in icons
+ (cd ${WRKSRC}/${d} && ${COPYTREE_SHARE} oxygen ${PREFIX}/share/icons/)
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.desktop \
+ ${PREFIX}/share/applications/
+.if !defined (NOPORTDATA)
+ ${MKDIR} ${DATADIR}
+. for d in preview themes
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+. endfor
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/cutemaze/distinfo b/games/cutemaze/distinfo
new file mode 100644
index 000000000000..aa0bcba95368
--- /dev/null
+++ b/games/cutemaze/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cutemaze-1.1.0-src.tar.bz2) = cc039faf452f8c30fb00a90ba7571d688559c0df822fc213f3e78451921f9bef
+SIZE (cutemaze-1.1.0-src.tar.bz2) = 249290
diff --git a/games/cutemaze/pkg-descr b/games/cutemaze/pkg-descr
new file mode 100644
index 000000000000..ee419869e0be
--- /dev/null
+++ b/games/cutemaze/pkg-descr
@@ -0,0 +1,7 @@
+CuteMaze is a simple, top-down game in which mazes are randomly generated using
+one of a choice of several different algorithms.
+You move the character through the maze while hunting for targets
+(cheese, by default)
+the game is won once all of these targets have been picked up.
+
+WWW: http://gottcode.org/cutemaze/
diff --git a/games/cutemaze/pkg-plist b/games/cutemaze/pkg-plist
new file mode 100644
index 000000000000..486cbafb1fdf
--- /dev/null
+++ b/games/cutemaze/pkg-plist
@@ -0,0 +1,37 @@
+bin/cutemaze
+share/applications/cutemaze.desktop
+share/icons/oxygen/16x16/application-exit.png
+share/icons/oxygen/16x16/document-new.png
+share/icons/oxygen/16x16/games-config-options.png
+share/icons/oxygen/16x16/games-highscores.png
+share/icons/oxygen/16x16/games-hint.png
+share/icons/oxygen/16x16/help-about.png
+share/icons/oxygen/16x16/media-playback-pause.png
+share/icons/oxygen/16x16/zoom-in.png
+share/icons/oxygen/16x16/zoom-out.png
+share/icons/oxygen/22x22/application-exit.png
+share/icons/oxygen/22x22/document-new.png
+share/icons/oxygen/22x22/games-config-options.png
+share/icons/oxygen/22x22/games-highscores.png
+share/icons/oxygen/22x22/games-hint.png
+share/icons/oxygen/22x22/help-about.png
+share/icons/oxygen/22x22/media-playback-pause.png
+share/icons/oxygen/22x22/zoom-in.png
+share/icons/oxygen/22x22/zoom-out.png
+share/icons/oxygen/LGPL
+share/icons/oxygen/scalable/application-exit.svgz
+share/icons/oxygen/scalable/document-new.svgz
+share/icons/oxygen/scalable/games-config-options.svgz
+share/icons/oxygen/scalable/games-highscores.svgz
+share/icons/oxygen/scalable/games-hint.svgz
+share/icons/oxygen/scalable/help-about.svgz
+share/icons/oxygen/scalable/media-playback-pause.svgz
+share/icons/oxygen/scalable/zoom-in.svgz
+share/icons/oxygen/scalable/zoom-out.svgz
+share/pixmaps/cutemaze.png
+@dirrm share/icons/oxygen/scalable
+@dirrm share/icons/oxygen/22x22
+@dirrm share/icons/oxygen/16x16
+@dirrm share/icons/oxygen
+@dirrmtry share/icons
+@dirrm share/applications