aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2010-11-18 00:17:40 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2010-11-18 00:17:40 +0000
commit6150a2b7ea590534f0cd872e4477992ebd861aed (patch)
tree8f38b5d67f54e3f7d85787d0f5de497a2f5f12aa
parent78a9720df17b6a273922b8c441e9c1cbbaee6bee (diff)
Notes
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Array-LineReader/Makefile30
-rw-r--r--misc/p5-Array-LineReader/distinfo2
-rw-r--r--misc/p5-Array-LineReader/pkg-descr8
4 files changed, 41 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a4cd91c9b645..eeb1e1b41324 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -389,6 +389,7 @@
SUBDIR += p5-Array-Compare
SUBDIR += p5-Array-Diff
SUBDIR += p5-Array-IntSpan
+ SUBDIR += p5-Array-LineReader
SUBDIR += p5-Array-PrintCols
SUBDIR += p5-Array-RefElem
SUBDIR += p5-Asterisk
diff --git a/misc/p5-Array-LineReader/Makefile b/misc/p5-Array-LineReader/Makefile
new file mode 100644
index 000000000000..8d33882ec160
--- /dev/null
+++ b/misc/p5-Array-LineReader/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Array-LineReader
+# Date created: 2010/11/09
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Array-LineReader
+PORTVERSION= 1.01
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Access lines of a file via an array
+
+BUILD_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Array::LineReader.3
+
+PLIST_FILES= %%SITE_PERL%%/Array/LineReader.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/LineReader/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/LineReader \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array \
+ %%SITE_PERL%%/Array
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Array-LineReader/distinfo b/misc/p5-Array-LineReader/distinfo
new file mode 100644
index 000000000000..a0bcba90d643
--- /dev/null
+++ b/misc/p5-Array-LineReader/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Array-LineReader-1.01.tar.gz) = 68fb03e7ee515afe0915d68ed8ea6b2b192326b80bb0f6189287a74569860562
+SIZE (Array-LineReader-1.01.tar.gz) = 6058
diff --git a/misc/p5-Array-LineReader/pkg-descr b/misc/p5-Array-LineReader/pkg-descr
new file mode 100644
index 000000000000..f76209d409e2
--- /dev/null
+++ b/misc/p5-Array-LineReader/pkg-descr
@@ -0,0 +1,8 @@
+Array::LineReader gives you the possibility to access lines of some file by
+the elements of an array. This modul inherites methods from Tie::Array (see
+Tie::Array). You save a lot of memory, because the file's content is read
+only on demand, i.e. in the case you access an element of the array. The
+offset and length of all the lines is hold in memory as long as you tie your
+array.
+
+WWW: http://search.cpan.org/dist/Array-LineReader/