aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2017-12-24 10:24:48 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2017-12-24 10:24:48 +0000
commit636ca0629ff6ff4328467e59e61f5ffc979a2a1b (patch)
tree66390ac1f176364cdb797a723199397beeecdfe1
parent9faadcd4fc78ac521dda27789c7366744ae27db8 (diff)
downloadports-636ca0629ff6ff4328467e59e61f5ffc979a2a1b.tar.gz
ports-636ca0629ff6ff4328467e59e61f5ffc979a2a1b.zip
Notes
-rw-r--r--devel/libvirt/Makefile22
-rw-r--r--devel/libvirt/distinfo6
-rw-r--r--devel/libvirt/pkg-plist1
3 files changed, 18 insertions, 11 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index d13b5b48a134..a87ae28bed03 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 3.9.0
+PORTVERSION= 3.10.0
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -14,14 +14,13 @@ LICENSE= LGPL3
LIB_DEPENDS= libcurl.so:ftp/curl \
libgcrypt.so:security/libgcrypt \
- libxml2.so:textproc/libxml2 \
- libssh2.so:security/libssh2
+ libxml2.so:textproc/libxml2
BUILD_DEPENDS= dnsmasq:dns/dnsmasq \
xsltproc:textproc/libxslt
RUN_DEPENDS= dnsmasq:dns/dnsmasq
-OPTIONS_DEFINE= DOCS GNUTLS NLS NSS QEMU READLINE SASL ZFS
-OPTIONS_DEFAULT= GNUTLS READLINE ZFS
+OPTIONS_DEFINE= DOCS GNUTLS NLS NSS QEMU READLINE SASL LIBSSH LIBSSH2 ZFS
+OPTIONS_DEFAULT= GNUTLS READLINE LIBSSH LIBSSH2 ZFS
OPTIONS_DEFINE_amd64= XEN
.if exists(/usr/sbin/bhyve)
OPTIONS_DEFINE_amd64+= BHYVE
@@ -35,6 +34,8 @@ QEMU_DESC= QEMU driver
BHYVE_DESC= bhyve driver
XEN_DESC= Xen support via libxl
NSS_DESC= Name Service Switch plugin
+LIBSSH_DESC= libssh remote transport
+LIBSSH2_DESC= libssh2 remote transport
ZFS_DESC= ZFS storage driver
OPTIONS_SUB= yes
@@ -65,6 +66,12 @@ XEN_CONFIGURE_WITH= libxl
XEN_CFLAGS= -I${LOCALBASE}/include
XEN_LIB_DEPENDS= libxenlight.so:sysutils/xen-tools
+LIBSSH_CONFIGURE_WITH= libssh
+LIBSSH_LIB_DEPENDS= libssh.so:security/libssh
+
+LIBSSH2_CONFIGURE_WITH= ssh2
+LIBSSH2_LIB_DEPENDS= libssh2.so:security/libssh2
+
ZFS_CONFIGURE_WITH= storage-zfs
VARDIR= /var
@@ -82,7 +89,6 @@ CONFIGURE_ARGS+= --without-avahi \
--without-xen \
--without-login-shell \
--without-wireshark-dissector \
- --with-ssh2 \
--localstatedir=${VARDIR}
# random_data fix can be removed when 8.x is eol
@@ -93,13 +99,13 @@ PORTSCOUT= limit:\d+\.\d+\.\d+$$
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
-USES= charsetfix cpe gmake libtool pathfix \
+USES= charsetfix cpe gettext-runtime gmake libtool pathfix \
perl5 python:2.7,build pkgconfig shebangfix tar:xz
CPE_VENDOR= redhat
USE_PERL5= build
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-SHLIB_VER= ${PORTVERSION:C/(^[0-9])\./0.\100/}
+SHLIB_VER= 0.3010.0
PLIST_SUB+= PORTVERSION="-${PORTVERSION}" \
SHLIB_VER=${SHLIB_VER}
PORTDOCS= *
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index 2d6fb3606edc..6a9346bd692b 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1509702959
-SHA256 (libvirt-3.9.0.tar.xz) = 89fc63213291d329d537ea96e363fd609160da080322973bd1126d431ff63424
-SIZE (libvirt-3.9.0.tar.xz) = 15010344
+TIMESTAMP = 1512565159
+SHA256 (libvirt-3.10.0.tar.xz) = dff109cae2cc915b3ed5ba7e460502b85eb9a5058cda4f356d7bb7b1e3196b0e
+SIZE (libvirt-3.10.0.tar.xz) = 14952220
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index 4d07270b4b5f..cc185402e1f4 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -244,6 +244,7 @@ share/augeas/lenses/tests/test_virtlogd.aug
%%DOCSDIR%%%%PORTVERSION%%/html/secureusage.html
%%DOCSDIR%%%%PORTVERSION%%/html/securityprocess.html
%%DOCSDIR%%%%PORTVERSION%%/html/storage.html
+%%DOCSDIR%%%%PORTVERSION%%/html/support.html
%%DOCSDIR%%%%PORTVERSION%%/html/testapi.html
%%DOCSDIR%%%%PORTVERSION%%/html/testsuites.html
%%DOCSDIR%%%%PORTVERSION%%/html/testtck.html