aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-07-03 13:56:15 +0000
committerChris Rees <crees@FreeBSD.org>2011-07-03 13:56:15 +0000
commit670b828e6b94f9023d88ccdfe0ecaab5b6c7a240 (patch)
tree37cf71dfd678e76bdfb3f06ad8334a597e2084b7
parentc5284f2b4e38ccfbd34fc626a0a5ad3467e1e9ad (diff)
downloadports-670b828e6b94f9023d88ccdfe0ecaab5b6c7a240.tar.gz
ports-670b828e6b94f9023d88ccdfe0ecaab5b6c7a240.zip
Notes
-rw-r--r--irc/ptlink-services/Makefile7
-rw-r--r--irc/ptlink-services/pkg-install28
2 files changed, 6 insertions, 29 deletions
diff --git a/irc/ptlink-services/Makefile b/irc/ptlink-services/Makefile
index d70ebb4cd59d..943902b048e7 100644
--- a/irc/ptlink-services/Makefile
+++ b/irc/ptlink-services/Makefile
@@ -16,11 +16,17 @@ DISTNAME= PTlinkIRC.${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= PTlink IRC services
+DEPRECATED= No upstream source, no distfile and no maintainer
+EXPIRATION_DATE=2011-09-03
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
USE_MYSQL= yes
+USERS= ircd
+GROUPS= ${USERS}
+
USE_RC_SUBR= ptlink-services.sh
SUB_FILES= pkg-message
@@ -30,7 +36,6 @@ CONFIGURE_ARGS= --sysconfdir=${SYSCONFDIR} --localstatedir=/var \
--with-pidfile=/var/run/ircsvs.pid
post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CHOWN} -R ircd:ircd ${SYSCONFDIR}
@${CAT} ${PKGMESSAGE}
diff --git a/irc/ptlink-services/pkg-install b/irc/ptlink-services/pkg-install
deleted file mode 100644
index d837e4e6e306..000000000000
--- a/irc/ptlink-services/pkg-install
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-case $2 in
-POST-INSTALL)
- USER=ircd
- GROUP=ircd
- UID=72
- GID=72
-
- if pw groupshow "${GROUP}" > /dev/null 2>&1; then
- echo "===> Using existing group ${GROUP}"
- else
- echo "===> Adding group ${GROUP}"
- pw groupadd ${GROUP} -g ${GID} || exit 1
- fi
-
- if pw usershow "${USER}" > /dev/null 2>&1; then
- echo "===> Using existing user ${USER}"
- else
- echo "===> Adding user ${USER}"
- pw adduser ${USER} -u ${UID} -g ${GROUP} -h - -d "/nonexistent" \
- -s "/nonexistent" -c "IRC daemon" || exit 1
- fi
- ;;
-esac