aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-14 22:26:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-14 22:26:04 +0000
commit718714fe82f36a271e6ba72f3b7b433c3f5b53d3 (patch)
treea1ed47bd1edc8d74a4c460c13783f737605435c2
parent87979bd04c6615db6576c531a13a7ab84981e6f2 (diff)
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-Htpasswd/Makefile26
-rw-r--r--www/p5-Apache-Htpasswd/distinfo3
-rw-r--r--www/p5-Apache-Htpasswd/pkg-descr9
-rw-r--r--www/p5-Apache-Htpasswd/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 12131ee4d6e8..637ccbebbcce 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -609,6 +609,7 @@
SUBDIR += p5-Apache-Filter
SUBDIR += p5-Apache-Gallery
SUBDIR += p5-Apache-GopherHandler
+ SUBDIR += p5-Apache-Htpasswd
SUBDIR += p5-Apache-Icon
SUBDIR += p5-Apache-Language
SUBDIR += p5-Apache-MP3
diff --git a/www/p5-Apache-Htpasswd/Makefile b/www/p5-Apache-Htpasswd/Makefile
new file mode 100644
index 000000000000..5c62b01c4768
--- /dev/null
+++ b/www/p5-Apache-Htpasswd/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Apache-Htpasswd
+# Date created: Jul 17, 2009
+# Whom: Masafumi NAKANE <max@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Htpasswd
+PORTVERSION= 1.8
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= max@FreeBSD.org
+COMMENT= A Perl module for managing Unix crypt-style password file
+
+BUILD_DEPENDS= p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Digest-SHA1>=2:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::Htpasswd.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Htpasswd/distinfo b/www/p5-Apache-Htpasswd/distinfo
new file mode 100644
index 000000000000..db52286d3f37
--- /dev/null
+++ b/www/p5-Apache-Htpasswd/distinfo
@@ -0,0 +1,3 @@
+MD5 (Apache-Htpasswd-1.8.tar.gz) = ee2048044096b4259e89c9ed1c88ed92
+SHA256 (Apache-Htpasswd-1.8.tar.gz) = 57709488c85555403fafcadf7e84d511630aa3f3c94750b59aa5bc1d3d75221c
+SIZE (Apache-Htpasswd-1.8.tar.gz) = 8397
diff --git a/www/p5-Apache-Htpasswd/pkg-descr b/www/p5-Apache-Htpasswd/pkg-descr
new file mode 100644
index 000000000000..bd7007dd86ea
--- /dev/null
+++ b/www/p5-Apache-Htpasswd/pkg-descr
@@ -0,0 +1,9 @@
+This module comes with a set of methods to use with htaccess password
+files. These files (and htaccess) are used to do Basic Authentication
+on a web server.
+
+The passwords file is a flat-file with login name and their associated
+crypted password. You can use this for non-Apache files if you wish,
+but it was written specifically for .htaccess style files.
+
+WWW: http://search.cpan.org/dist/Apache-Htpasswd/
diff --git a/www/p5-Apache-Htpasswd/pkg-plist b/www/p5-Apache-Htpasswd/pkg-plist
new file mode 100644
index 000000000000..66664058d994
--- /dev/null
+++ b/www/p5-Apache-Htpasswd/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Apache/Htpasswd.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Htpasswd/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Htpasswd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache
+@dirrmtry %%SITE_PERL%%/Apache