aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-25 16:21:27 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-25 16:21:27 +0000
commit80d4c8c672b83dd4b8489528c98314042606da72 (patch)
treef83096e9ee43b5f278f58a226267b6f5daa99241
parentb84d4bb7886abd1fc7bf95214b627e1d4c6bdf65 (diff)
downloadports-80d4c8c672b83dd4b8489528c98314042606da72.tar.gz
ports-80d4c8c672b83dd4b8489528c98314042606da72.zip
Notes
-rw-r--r--x11/Makefile1
-rw-r--r--x11/trayer/Makefile38
-rw-r--r--x11/trayer/distinfo3
-rw-r--r--x11/trayer/pkg-descr9
4 files changed, 51 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index de4b00dcfe58..e4a91e7b1298 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -208,6 +208,7 @@
SUBDIR += tilda
SUBDIR += tkXwin
SUBDIR += tkgoodstuff
+ SUBDIR += trayer
SUBDIR += tycoon
SUBDIR += vdesk
SUBDIR += wdm
diff --git a/x11/trayer/Makefile b/x11/trayer/Makefile
new file mode 100644
index 000000000000..a00c33101fd9
--- /dev/null
+++ b/x11/trayer/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: trayer
+# Date created: Aug 21, 2006
+# Whom: Alexey Mikhailov <karma@ez.pereslavl.ru>
+#
+# $FreeBSD$
+
+PORTNAME= trayer
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/t/trayer
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= karma@ez.pereslavl.ru
+COMMENT= Lightweight GTK2-based systray for UNIX desktop
+
+USE_GNOME= gtk20 glib20 pango atk
+USE_ICONV= yes
+USE_X_PREFIX= yes
+
+USE_GMAKE= yes
+MAKE_ARGS= "PREFIX=${X11BASE}"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README CREDITS CHANGELOG
+.endif
+
+PLIST_FILES= bin/trayer
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+.include <bsd.port.mk>
diff --git a/x11/trayer/distinfo b/x11/trayer/distinfo
new file mode 100644
index 000000000000..d910badd2c7d
--- /dev/null
+++ b/x11/trayer/distinfo
@@ -0,0 +1,3 @@
+SIZE (trayer_1.0.orig.tar.gz) = 29713
+MD5 (trayer_1.0.orig.tar.gz) = e1b0b6464f991f2c296561e377585867
+SHA256 (trayer_1.0.orig.tar.gz) = 64f3b7040a7a563ca4b6924efd950f10c928af7f3535b6f4a00f8bbe0b19484d
diff --git a/x11/trayer/pkg-descr b/x11/trayer/pkg-descr
new file mode 100644
index 000000000000..efcaa7660601
--- /dev/null
+++ b/x11/trayer/pkg-descr
@@ -0,0 +1,9 @@
+trayer is small program designed to provide systray functionality
+present in GNOME/KDE desktop enviroments for window managers
+which doesn't support that function. It's similar to other
+applications such as 'peksystray' and 'docker'.
+
+trayer code was extracted from fbpanel application, you can find more
+about it on it's homepage
+
+WWW: http://fbpanel.sourceforge.net/