aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-29 18:07:09 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-29 18:07:09 +0000
commit82e4dcc470cfc6e07b2a182ee315989d1adda4dc (patch)
treed69cdfbe94c6ea41ab87f1b5f256cde645524d92
parente6353d0b3db307b860585f8ab426823ebe603cb0 (diff)
downloadports-82e4dcc470cfc6e07b2a182ee315989d1adda4dc.tar.gz
ports-82e4dcc470cfc6e07b2a182ee315989d1adda4dc.zip
Notes
-rw-r--r--devel/cvschangelogbuilder/Makefile2
-rw-r--r--devel/p5-SVN-Access/Makefile4
-rw-r--r--devel/p5-SVN-Hook/Makefile8
-rw-r--r--devel/p5-SVN-Hooks/Makefile2
-rw-r--r--devel/p5-SVN-Notify-Snapshot/Makefile2
-rw-r--r--net/p5-Amazon-SQS-Simple/Makefile6
-rw-r--r--net/p5-Net-Amazon-EC2/Makefile2
-rw-r--r--net/p5-Net-Amazon-MechanicalTurk/Makefile8
-rw-r--r--net/p5-Net-Amazon-Thumbnail/Makefile10
-rw-r--r--www/p5-Template-GD/Makefile2
10 files changed, 23 insertions, 23 deletions
diff --git a/devel/cvschangelogbuilder/Makefile b/devel/cvschangelogbuilder/Makefile
index 1446d9bf9cec..3c7cdaba661d 100644
--- a/devel/cvschangelogbuilder/Makefile
+++ b/devel/cvschangelogbuilder/Makefile
@@ -15,7 +15,7 @@ COMMENT= Utility to generate changelogs and reports from a CVS repository
LICENSE= GPLv2
-RUN_DEPENDS= ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
+RUN_DEPENDS= p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph
NO_BUILD= yes
USE_PERL5= yes
diff --git a/devel/p5-SVN-Access/Makefile b/devel/p5-SVN-Access/Makefile
index 84653601372d..e8e3246d439d 100644
--- a/devel/p5-SVN-Access/Makefile
+++ b/devel/p5-SVN-Access/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl extension to manipulate SVN Access files
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Base.pm:${PORTSDIR}/devel/p5-subversion \
+BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-Tie-IxHash>=1.21:${PORTSDIR}/devel/p5-Tie-IxHash
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Base.pm:${PORTSDIR}/devel/p5-subversion \
+RUN_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-Tie-IxHash>=1.21:${PORTSDIR}/devel/p5-Tie-IxHash
PERL_CONFIGURE= yes
diff --git a/devel/p5-SVN-Hook/Makefile b/devel/p5-SVN-Hook/Makefile
index 37fedd761a1e..6114898ebb96 100644
--- a/devel/p5-SVN-Hook/Makefile
+++ b/devel/p5-SVN-Hook/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl module for managing Subversion hook scripts
-RUN_DEPENDS= ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
-BUILD_DEPENDS= ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+BUILD_DEPENDS= p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
PERL_CONFIGURE= yes
diff --git a/devel/p5-SVN-Hooks/Makefile b/devel/p5-SVN-Hooks/Makefile
index dbb370e0d44e..f8504933859e 100644
--- a/devel/p5-SVN-Hooks/Makefile
+++ b/devel/p5-SVN-Hooks/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= p5-Data-Util>=0:${PORTSDIR}/devel/p5-Data-Util \
p5-SVN-Look>=0:${PORTSDIR}/devel/p5-SVN-Look \
p5-SVN-Notify>=0:${PORTSDIR}/devel/p5-SVN-Notify \
p5-JIRA-Client>=0:${PORTSDIR}/devel/p5-JIRA-Client \
- ${SITE_PERL}/XMLRPC/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite \
+ p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite \
subversion>=1.4.0:${PORTSDIR}/devel/subversion
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/p5-SVN-Notify-Snapshot/Makefile b/devel/p5-SVN-Notify-Snapshot/Makefile
index 14eaeaa540b5..226eed8db27b 100644
--- a/devel/p5-SVN-Notify-Snapshot/Makefile
+++ b/devel/p5-SVN-Notify-Snapshot/Makefile
@@ -24,7 +24,7 @@ PERL_MODBUILD= yes
.include <bsd.port.pre.mk>
.if defined(WITH_CONFIG)
-BUILD_DEPENDS+= ${SITE_PERL}/SVN/Notify/Config.pm:${PORTSDIR}/devel/p5-SVN-Notify-Config
+BUILD_DEPENDS+= p5-SVN-Notify-Config>=0:${PORTSDIR}/devel/p5-SVN-Notify-Config
.endif
MAN3= SVN::Notify::Snapshot.3 SVN::Notify::Snapshot::ConfigData.3
diff --git a/net/p5-Amazon-SQS-Simple/Makefile b/net/p5-Amazon-SQS-Simple/Makefile
index 1b948dbc3e4b..abc434884f6f 100644
--- a/net/p5-Amazon-SQS-Simple/Makefile
+++ b/net/p5-Amazon-SQS-Simple/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= OO API for accessing the Amazon Simple Queue Service
-BUILD_DEPENDS= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+BUILD_DEPENDS= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/net/p5-Net-Amazon-EC2/Makefile b/net/p5-Net-Amazon-EC2/Makefile
index e3d17fb124cc..cd2a0891b218 100644
--- a/net/p5-Net-Amazon-EC2/Makefile
+++ b/net/p5-Net-Amazon-EC2/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl interface to the Amazon Elastic Compute Cloud
RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-Digest-HMAC>=1.01:${PORTSDIR}/security/p5-Digest-HMAC \
p5-Moose>=0.38:${PORTSDIR}/devel/p5-Moose \
p5-XML-Simple>=2.18:${PORTSDIR}/textproc/p5-XML-Simple \
diff --git a/net/p5-Net-Amazon-MechanicalTurk/Makefile b/net/p5-Net-Amazon-MechanicalTurk/Makefile
index bf15257b2b99..11fcf664f779 100644
--- a/net/p5-Net-Amazon-MechanicalTurk/Makefile
+++ b/net/p5-Net-Amazon-MechanicalTurk/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl interface to the Amazon Mechanical Turk
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+RUN_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Module-Build>=0:${PORTSDIR}/devel/p5-Module-Build \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
diff --git a/net/p5-Net-Amazon-Thumbnail/Makefile b/net/p5-Net-Amazon-Thumbnail/Makefile
index 393d97f10763..e15f82ec8220 100644
--- a/net/p5-Net-Amazon-Thumbnail/Makefile
+++ b/net/p5-Net-Amazon-Thumbnail/Makefile
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl interface to Amazon Alexa Site Thumbnail web service
-RUN_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/URI/QueryParam.pm:${PORTSDIR}/net/p5-URI \
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/www/p5-Template-GD/Makefile b/www/p5-Template-GD/Makefile
index eaa4a50e6b91..f6d30963bda6 100644
--- a/www/p5-Template-GD/Makefile
+++ b/www/p5-Template-GD/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Template Toolkit plugin to interface with GD modules
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes