aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2005-10-25 18:09:10 +0000
committerBill Fenner <fenner@FreeBSD.org>2005-10-25 18:09:10 +0000
commit8a1ab6255da2dbc226755f54208f023748f3d3bc (patch)
tree72ab03859dd669510cc03ef0a27da998ee14bb07
parentf78368efbf5ef9c7c7cc4b71a2b2d5bd8457aafb (diff)
Notes
-rw-r--r--benchmarks/lmbench/Makefile54
-rw-r--r--benchmarks/lmbench/distinfo4
-rw-r--r--benchmarks/lmbench/files/Makefile5
-rw-r--r--benchmarks/lmbench/files/patch-aa38
-rw-r--r--benchmarks/lmbench/files/patch-config-run37
-rw-r--r--benchmarks/lmbench/files/patch-getbg214
-rw-r--r--benchmarks/lmbench/pkg-plist216
7 files changed, 128 insertions, 440 deletions
diff --git a/benchmarks/lmbench/Makefile b/benchmarks/lmbench/Makefile
index b41f059e5797..b85e969fa81a 100644
--- a/benchmarks/lmbench/Makefile
+++ b/benchmarks/lmbench/Makefile
@@ -6,24 +6,33 @@
#
PORTNAME= lmbench
-PORTVERSION= 1.1
+PORTVERSION= 3a4
CATEGORIES= benchmarks
-MASTER_SITES= ftp://ftp.deva.net/pub/sources/system/benchmarks/ \
- ftp://ftp.netlab.is.tsukuba.ac.jp/pub/utils/benchmark/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= http://www.bitmover.com/lmbench/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/a4//}
MAINTAINER= fenner@FreeBSD.org
COMMENT= A system performance measurement tool
ALL_TARGET= build
MAKE_ENV= PATH=${PATH}:${WRKSRC}/scripts
-MAN1= bargraph.1 graph.1
-MAN8= bw_file_rd.8 bw_mem_cp.8 bw_mem_rd.8 bw_mem_wr.8 \
- bw_mmap_rd.8 bw_pipe.8 bw_tcp.8 lat_connect.8 lat_ctx.8 \
- lat_fs.8 lat_mem_rd.8 lat_mmap.8 lat_pagefault.8 lat_pipe.8 \
- lat_proc.8 lat_rpc.8 lat_syscall.8 lat_tcp.8 lat_udp.8 \
- lmbench.8 lmdd.8 mhz.8
+MAN1= bargraph.1 graph.1 pgraph.1 rccs.1
+MAN3= lmbench.3 reporting.3 results.3 timing.3
+MAN8= bw_file_rd.8 bw_mem.8 bw_mem_rd.8 bw_mmap_rd.8 \
+ bw_pipe.8 bw_tcp.8 bw_unix.8 cache.8 lat_connect.8 \
+ lat_ctx.8 lat_fcntl.8 lat_fifo.8 lat_fs.8 lat_http.8 \
+ lat_mem_rd.8 lat_mmap.8 lat_ops.8 lat_pagefault.8 \
+ lat_pipe.8 lat_proc.8 lat_rpc.8 lat_select.8 lat_sig.8 \
+ lat_syscall.8 lat_tcp.8 lat_udp.8 lat_unix.8 \
+ lat_unix_connect.8 line.8 lmbench.8 lmdd.8 mhz.8 \
+ par_mem.8 par_ops.8 stream.8 tlb.8
+
+# the bindir for the PLIST is:
+# (note that ./os needs to be run inside the work dir, running it
+# outside will give a different result.)
+#LMBENCH_OS!= cd ${WRKSRC}/scripts && ./os
+#PLIST_SUB= LMBENCH_OS=${LMBENCH_OS}
+PLIST_SUB= "LMBENCH_OS=$$(cd ${WRKSRC}/scripts && ./os)"
test: build
@(cd ${WRKSRC}; make results)
@@ -31,27 +40,28 @@ test: build
retest: build
@(cd ${WRKSRC}; make rerun)
-# The distribution comes with unwritable files; patch's magic RCS behavior
-# causes files to be checked out of RCS before being patched. If an $Id$
-# string is in the patch, this behavior causes the string to change to
-# reflect the locker, meaning that the patch will probably fail. Instead,
-# just chmod +w the files.
-PATCHEDFILES= src/Makefile scripts/config-run scripts/getbg
-pre-patch:
-.for f in ${PATCHEDFILES}
- @${CHMOD} +w ${WRKSRC}/${f}
-.endfor
+# This version seems to think that it's checked out directly from
+# bitkeeper. It wants to look in ../SCCS/s.ChangeSet to find
+# its version. Instead, make ../SCCS/s.ChangeSet old enough that
+# make won't care, and create a bk.ver file with the distname in it.
+post-extract:
+ ${MKDIR} ${WRKSRC}/SCCS
+ ${TOUCH} -t 199901010000 ${WRKSRC}/SCCS/s.ChangeSet
+ ${ECHO_CMD} ${DISTNAME} > ${WRKSRC}/src/bk.ver
pre-install:
[ -d ${PREFIX}/lib/lmbench ] || ${MKDIR} ${PREFIX}/lib/lmbench
do-install:
${CP} ${FILESDIR}/Makefile ${PREFIX}/lib/lmbench
- tar --exclude \*.orig -C ${WRKSRC} -cf - Results bin scripts | \
+ tar --exclude \*.orig -C ${WRKSRC} -cf - bin scripts results | \
tar -C ${PREFIX}/lib/lmbench -xf -
.for man in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/doc/${man} ${PREFIX}/man/man1
.endfor
+.for man in ${MAN3}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${man} ${PREFIX}/man/man3
+.endfor
.for man in ${MAN8}
${INSTALL_MAN} ${WRKSRC}/doc/${man} ${PREFIX}/man/man8
.endfor
diff --git a/benchmarks/lmbench/distinfo b/benchmarks/lmbench/distinfo
index 2256e7488160..1aaa3821341e 100644
--- a/benchmarks/lmbench/distinfo
+++ b/benchmarks/lmbench/distinfo
@@ -1,2 +1,2 @@
-MD5 (lmbench.tar.Z) = 3b81daa054e9999b6efb2b225468087c
-SIZE (lmbench.tar.Z) = 960591
+MD5 (lmbench3.tar.gz) = 79f1861dfdd0110c6dd9d24d1d5473e7
+SIZE (lmbench3.tar.gz) = 411874
diff --git a/benchmarks/lmbench/files/Makefile b/benchmarks/lmbench/files/Makefile
index 67c47d13612d..c53ebb466bc8 100644
--- a/benchmarks/lmbench/files/Makefile
+++ b/benchmarks/lmbench/files/Makefile
@@ -1,5 +1,8 @@
# A Makefile for the installed lmbench
-BINDIR = ./bin/bsd
+# $FreeBSD$
+#
+OS != scripts/os
+BINDIR = bin/${OS}
results:
@(cd scripts; ./config-run ../${BINDIR}/CONFIG)
diff --git a/benchmarks/lmbench/files/patch-aa b/benchmarks/lmbench/files/patch-aa
deleted file mode 100644
index ab8a4793ecd1..000000000000
--- a/benchmarks/lmbench/files/patch-aa
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/Makefile.orig Sat Nov 11 18:42:41 1995
-+++ src/Makefile Thu Apr 4 05:19:26 2002
-@@ -27,7 +27,7 @@
- # I finally know why Larry Wall's Makefile says "Grrrr".
- SHELL=/bin/sh
-
--CC = gcc
-+CC ?= gcc
- O= ../bin/unknown
- OS=`../scripts/os`
- BINDIR=../bin/$(OS)
-@@ -37,7 +37,7 @@
- lmbench/Results/osf1/alpha lmbench/Results/solaris/ss20*
-
- SYS5=
--CFLAGS = -O $(SYS5)
-+CFLAGS += $(SYS5)
-
- COMPILE=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
-
-@@ -93,7 +93,7 @@
- $(MAKE) O=$O CC=cc CFLAGS="$(CFLAGS)" all
-
- bsd:
-- $(MAKE) O=$O CC=$(CC) CFLAGS="$(CFLAGS) -Duint='unsigned int'" all
-+ $(MAKE) O=$O CC=$(CC) CFLAGS="$(CFLAGS)" all
-
- Wall:
- @$(MAKE) clean
-@@ -131,7 +131,7 @@
-
- $O/lat_pagefault: lat_pagefault.c timing.c bench.h
- if [ $O = ../bin/linux -o $O = ../bin/bsd ]; \
-- then cp /bin/true $O/lat_pagefault; \
-+ then cp /usr/bin/true $O/lat_pagefault; \
- else $(COMPILE) -o $O/lat_pagefault lat_pagefault.c $(LDLIBS); \
- fi
-
diff --git a/benchmarks/lmbench/files/patch-config-run b/benchmarks/lmbench/files/patch-config-run
deleted file mode 100644
index d8b320f1c1de..000000000000
--- a/benchmarks/lmbench/files/patch-config-run
+++ /dev/null
@@ -1,37 +0,0 @@
---- scripts/config-run.orig Sun May 6 16:04:39 2001
-+++ scripts/config-run Sun May 6 16:06:10 2001
-@@ -32,12 +32,12 @@
- drive. The simplest way to do this is to run the benchmark as root.
- If you are paranoid about running code as root, good for you, you should
- be. The paranoid solution is to grab another window, pick the disk
--drive, make it world readable ( chmod a+r /dev/rsd0a ), and then specify
-+drive, make it world readable ( chmod a+r /dev/da0s1a ), and then specify
- that drive below. Remember to change the permissions back after running
- the benchmark if you took the paranoid route.
-
- If you want to get disk latency results, please specify the disk device
--to use, such as /dev/rsd0a.
-+to use, such as /dev/da0s1a.
-
- EOF
- echo $ECHON "DISK [default none] $ECHOC"
-@@ -85,16 +85,16 @@
- cat<<EOF;
-
- We need a place to store a $MB Mbyte file as well as create and delete a
--large number of small files. We default to /usr/tmp. If /usr/tmp is a
-+large number of small files. We default to /tmp. If /tmp is a
- memory resident file system (i.e., tmpfs), pick a different place.
- Please specify a directory that has enough space and is a local file
- system.
-
- EOF
-- echo $ECHON "FSDIR [default /usr/tmp] $ECHOC"
-+ echo $ECHON "FSDIR [default /tmp] $ECHOC"
- read FSDIR
- if [ X$FSDIR = X ]
-- then FSDIR=/usr/tmp
-+ then FSDIR=/tmp
- else mkdir -p $FSDIR 2>/dev/null
- fi
- if [ -d $FSDIR -a -w $FSDIR ]
diff --git a/benchmarks/lmbench/files/patch-getbg b/benchmarks/lmbench/files/patch-getbg
deleted file mode 100644
index 97c8f64a257a..000000000000
--- a/benchmarks/lmbench/files/patch-getbg
+++ /dev/null
@@ -1,214 +0,0 @@
---- scripts/getbg.orig Mon May 7 06:28:25 2001
-+++ scripts/getbg Mon May 7 07:07:10 2001
-@@ -1,12 +1,10 @@
--
-+#!/usr/bin/perl
- # Extract bargraph data from lmbench results.
- # Usage: getbg file file file....
- #
- # Hacked into existence by Larry McVoy (lm@sun.com now lm@sgi.com).
- # Copyright (c) 1994 Larry McVoy. GPLed software.
- # $Id: getbg,v 1.14 1995/11/11 04:15:18 lm Exp $
--eval "exec perl -Sws $0 $*"
-- if 0;
-
- @bw_file = @files = @lat_ctx32_8 = @lat_ctx32 = @lat_ctx8 = @lat_ctx =
- @lat_shproc = @lat_simpleproc = @lat_nullproc =
-@@ -24,66 +22,66 @@
- while (<FD>) {
- chop;
- if (/^\[lmbench/) {
-- split;
-+ @_ = split;
- if ($_[3] eq "SunOS") {
- $_[3] .= "-$_[5]";
- }
- push(@uname, "@_");
- }
- if (/Mhz/) {
-- split;
-+ @_ = split;
- push(@misc_mhz, $_[0]);
- }
- if (/^Null syscall:/) {
-- split;
-+ @_ = split;
- push(@lat_nullsys, $_[2]);
- }
- if (/^Signal handler installation:/) {
-- split;
-+ @_ = split;
- push(@lat_sigaction, $_[3]);
- }
- if (/^Signal handler overhead:/) {
-- split;
-+ @_ = split;
- push(@lat_signal, $_[3]);
- }
- if (/^Pipe latency:/) {
-- split;
-+ @_ = split;
- push(@lat_pipe, $_[2]);
- }
- if (/UDP latency using localhost:/) {
-- split;
-+ @_ = split;
- push(@lat_udp_local, $_[4]);
- }
- if (/TCP latency using localhost/) {
-- split;
-+ @_ = split;
- push(@lat_tcp_local, $_[4]);
- }
- if (/RPC.udp latency using localhost/) {
-- split;
-+ @_ = split;
- push(@lat_rpc_udp_local, $_[4]);
- }
- if (/RPC.tcp latency using localhost/) {
-- split;
-+ @_ = split;
- push(@lat_rpc_tcp_local, $_[4]);
- }
- if (/TCP\/IP connection cost to localhost/) {
-- split;
-+ @_ = split;
- push(@lat_connect, $_[5]);
- }
- if (/^Process fork.exit/) {
-- split;
-+ @_ = split;
- push(@lat_nullproc, $_[2]);
- }
- if (/^Process fork.execve:/) {
-- split;
-+ @_ = split;
- push(@lat_simpleproc, $_[2]);
- }
- if (/^Process fork..bin.sh/) {
-- split;
-+ @_ = split;
- push(@lat_shproc, $_[3]);
- }
- if (/^Pagefaults on/) {
-- split;
-+ @_ = split;
- push(@lat_pagefault, $_[3]);
- }
- if (/size=0 ovr=/) {
-@@ -94,7 +92,7 @@
- push(@lat_ctx, -1);
- }
- next unless /^2/;
-- split;
-+ @_ = split;
- push(@lat_ctx, $_[1]);
- last;
- }
-@@ -105,7 +103,7 @@
- push(@lat_ctx, -1);
- }
- next unless /^8/;
-- split;
-+ @_ = split;
- push(@lat_ctx8, $_[1]);
- last;
- }
-@@ -118,7 +116,7 @@
- push(@lat_ctx32, -1);
- }
- next unless /^2/;
-- split;
-+ @_ = split;
- push(@lat_ctx32, $_[1]);
- last;
- }
-@@ -129,25 +127,25 @@
- push(@lat_ctx32_8, -1);
- }
- next unless /^8/;
-- split;
-+ @_ = split;
- push(@lat_ctx32_8, $_[1]);
- last;
- }
- }
- if (/^Pipe bandwidth/) {
-- split;
-+ @_ = split;
- push(@bw_pipe, $_[2]);
- }
- if (/^Socket bandwidth using localhost/) {
-- split;
-+ @_ = split;
- push(@bw_tcp_local, $_[4]);
- }
- if (/^Disk .* latency:/) {
-- split;
-+ @_ = split;
- push(@lat_disk, $_[3]);
- }
- if (/^File .* write bandwidth/) {
-- split;
-+ @_ = split;
- $bw = sprintf("%.2f", $_[4] / 1024.);
- push(@bw_file, $bw);
- }
-@@ -180,7 +178,7 @@
- push(@bw_mem_wr, $value);
- }
- if (/^0k\s/) {
-- split;
-+ @_ = split;
- push(@lat_fs_create, int(1000000/$_[2]));
- push(@lat_fs_delete, int(1000000/$_[3]));
- }
-@@ -188,13 +186,13 @@
- $save = -1;
- while (<FD>) {
- if (/^0.00098\s/) {
-- split;
-+ @_ = split;
- push(@lat_l1, $_[1]);
- } elsif (/^0.12500\s/) {
-- split;
-+ @_ = split;
- push(@lat_l2, $_[1]);
- } elsif (/^[45678].00000\s/) {
-- split;
-+ @_ = split;
- $size = $_[0];
- $save = $_[1];
- last if /^8.00000\s/;
-@@ -661,18 +659,18 @@
-
- sub papernames
- {
-- $_ = "IBM PowerPC" if /AIX powerpc@134/;
-- $_ = "IBM Power2" if /AIX rs6000-990@71/;
-- $_ = "FreeBSD/i586" if /FreeBSD i586@133/;
-- $_ = "HP 9000/819" if /HP-UX 9000.819@/;
-- $_ = "SGI Challenge" if /IRIX.* IP19@/;
-- $_ = "SGI Indigo2" if /IRIX.* IP22@/;
-- $_ = "Linux/Alpha" if /Linux alpha@/;
-- $_ = "Linux/i686" if /Linux i686@/;
-- $_ = "Linux/i586" if /Linux i586@/;
-- $_ = "DEC Alpha@150" if /OSF1 alpha@147/;
-- $_ = "DEC Alpha@300" if /OSF1 alpha@303/;
-- $_ = "Sun SC1000" if /SunOS-5.5 sun4d@5/;
-+ $_ = "IBM PowerPC" if /AIX powerpc\@134/;
-+ $_ = "IBM Power2" if /AIX rs6000-990\@71/;
-+ $_ = "FreeBSD/i586" if /FreeBSD i586\@133/;
-+ $_ = "HP 9000/819" if /HP-UX 9000.819\@/;
-+ $_ = "SGI Challenge" if /IRIX.* IP19\@/;
-+ $_ = "SGI Indigo2" if /IRIX.* IP22\@/;
-+ $_ = "Linux/Alpha" if /Linux alpha\@/;
-+ $_ = "Linux/i686" if /Linux i686\@/;
-+ $_ = "Linux/i586" if /Linux i586\@/;
-+ $_ = "DEC Alpha\@150" if /OSF1 alpha\@147/;
-+ $_ = "DEC Alpha\@300" if /OSF1 alpha\@303/;
-+ $_ = "Sun SC1000" if /SunOS-5.5 sun4d\@5/;
- $_ = "Sun Ultra1" if /SunOS-5.5 sun4u/;
- $_ = "Unixware/i686" if /UNIX_SV x86at/;
- }
-
diff --git a/benchmarks/lmbench/pkg-plist b/benchmarks/lmbench/pkg-plist
index 3d1d7d078203..ab656e835c22 100644
--- a/benchmarks/lmbench/pkg-plist
+++ b/benchmarks/lmbench/pkg-plist
@@ -1,153 +1,117 @@
lib/lmbench/Makefile
-lib/lmbench/Results/EXAMPLE
-lib/lmbench/Results/EXAMPLE2
-lib/lmbench/Results/FreeBSD/i586
-lib/lmbench/Results/FreeBSD/i586.1
-lib/lmbench/Results/FreeBSD/i586.2
-lib/lmbench/Results/FreeBSD/i586.3
-lib/lmbench/Results/FreeBSD/i586.4
-lib/lmbench/Results/GS/gs_init.ps
-lib/lmbench/Results/GS/gs_statd.ps
-lib/lmbench/Results/LIST-
-lib/lmbench/Results/Makefile
-lib/lmbench/Results/OUT
-lib/lmbench/Results/PAPER
-lib/lmbench/Results/RCS/Makefile,v
-lib/lmbench/Results/aix/6000-990
-lib/lmbench/Results/aix/powerpc.2
-lib/lmbench/Results/dgux/AViiON
-lib/lmbench/Results/hpux/735
-lib/lmbench/Results/hpux/cello
-lib/lmbench/Results/hpux/hamsky2
-lib/lmbench/Results/hpux/k200
-lib/lmbench/Results/hpux/snake
-lib/lmbench/Results/hpux/wk4
-lib/lmbench/Results/hpux/wk4.4
-lib/lmbench/Results/hpux/wk4.5
-lib/lmbench/Results/i686.predicted
-lib/lmbench/Results/irix/IP19
-lib/lmbench/Results/irix/IP19+
-lib/lmbench/Results/irix/IP19-5.3
-lib/lmbench/Results/irix/IP19-newsched
-lib/lmbench/Results/irix/IP21
-lib/lmbench/Results/irix/IP22
-lib/lmbench/Results/irix/IP22+
-lib/lmbench/Results/irix/IP26
-lib/lmbench/Results/irix/cedar3
-lib/lmbench/Results/linux/aurora.4
-lib/lmbench/Results/linux/i586
-lib/lmbench/Results/linux/i586.1
-lib/lmbench/Results/linux/i586.120
-lib/lmbench/Results/linux/i586.2
-lib/lmbench/Results/linux/i586.3
-lib/lmbench/Results/linux/i586.4
-lib/lmbench/Results/linux/linux
-lib/lmbench/Results/linux/linux.1
-lib/lmbench/Results/linux/pc64
-lib/lmbench/Results/linux/pc64.1
-lib/lmbench/Results/osf1/8400-32.psc.edu
-lib/lmbench/Results/osf1/alpha
-lib/lmbench/Results/osf1/alpha.1
-lib/lmbench/Results/osf1/alpha.2
-lib/lmbench/Results/osf1/alpha.3
-lib/lmbench/Results/osf1/alpha.4
-lib/lmbench/Results/osf1/gauss
-lib/lmbench/Results/osf1/nobozo
-lib/lmbench/Results/solaris/sc1000
-lib/lmbench/Results/solaris/sc2000
-lib/lmbench/Results/solaris/sc2000.1
-lib/lmbench/Results/solaris/ss20.50
-lib/lmbench/Results/solaris/ss20.61
-lib/lmbench/Results/solaris/sun4m
-lib/lmbench/Results/solaris/ultrasparc.10
-lib/lmbench/Results/unixware/alder.2
-lib/lmbench/bin/bsd/bw_file_rd
-lib/lmbench/bin/bsd/bw_mem_cp
-lib/lmbench/bin/bsd/bw_mem_rd
-lib/lmbench/bin/bsd/bw_mem_wr
-lib/lmbench/bin/bsd/bw_mmap_rd
-lib/lmbench/bin/bsd/bw_pipe
-lib/lmbench/bin/bsd/bw_tcp
-lib/lmbench/bin/bsd/hello
-lib/lmbench/bin/bsd/lat_connect
-lib/lmbench/bin/bsd/lat_ctx
-lib/lmbench/bin/bsd/lat_fs
-lib/lmbench/bin/bsd/lat_mem_rd
-lib/lmbench/bin/bsd/lat_mmap
-lib/lmbench/bin/bsd/lat_pagefault
-lib/lmbench/bin/bsd/lat_pipe
-lib/lmbench/bin/bsd/lat_proc
-lib/lmbench/bin/bsd/lat_rpc
-lib/lmbench/bin/bsd/lat_sig
-lib/lmbench/bin/bsd/lat_syscall
-lib/lmbench/bin/bsd/lat_tcp
-lib/lmbench/bin/bsd/lat_udp
-lib/lmbench/bin/bsd/lmdd
-lib/lmbench/bin/bsd/memsize
-lib/lmbench/bin/bsd/mhz
-lib/lmbench/scripts/Makefile
-lib/lmbench/scripts/README
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_tcp.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_udp.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_unix.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_timing.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_mem.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_stats.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_debug.o
+lib/lmbench/bin/%%LMBENCH_OS%%/getopt.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lib_sched.o
+lib/lmbench/bin/%%LMBENCH_OS%%/lmbench.a
+lib/lmbench/bin/%%LMBENCH_OS%%/bw_file_rd
+lib/lmbench/bin/%%LMBENCH_OS%%/bw_mem
+lib/lmbench/bin/%%LMBENCH_OS%%/bw_mmap_rd
+lib/lmbench/bin/%%LMBENCH_OS%%/bw_pipe
+lib/lmbench/bin/%%LMBENCH_OS%%/bw_tcp
+lib/lmbench/bin/%%LMBENCH_OS%%/bw_unix
+lib/lmbench/bin/%%LMBENCH_OS%%/hello
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_select
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_pipe
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_rpc
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_syscall
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_tcp
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_udp
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_mmap
+lib/lmbench/bin/%%LMBENCH_OS%%/mhz
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_proc
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_pagefault
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_connect
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_fs
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_sig
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_mem_rd
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_ctx
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_sem
+lib/lmbench/bin/%%LMBENCH_OS%%/memsize
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_unix
+lib/lmbench/bin/%%LMBENCH_OS%%/lmdd
+lib/lmbench/bin/%%LMBENCH_OS%%/timing_o
+lib/lmbench/bin/%%LMBENCH_OS%%/enough
+lib/lmbench/bin/%%LMBENCH_OS%%/msleep
+lib/lmbench/bin/%%LMBENCH_OS%%/loop_o
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_fifo
+lib/lmbench/bin/%%LMBENCH_OS%%/lmhttp
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_http
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_fcntl
+lib/lmbench/bin/%%LMBENCH_OS%%/disk
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_unix_connect
+lib/lmbench/bin/%%LMBENCH_OS%%/flushdisk
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_ops
+lib/lmbench/bin/%%LMBENCH_OS%%/line
+lib/lmbench/bin/%%LMBENCH_OS%%/tlb
+lib/lmbench/bin/%%LMBENCH_OS%%/par_mem
+lib/lmbench/bin/%%LMBENCH_OS%%/par_ops
+lib/lmbench/bin/%%LMBENCH_OS%%/stream
+lib/lmbench/bin/%%LMBENCH_OS%%/lmbench
+lib/lmbench/bin/%%LMBENCH_OS%%/cache
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_dram_page
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_pmake
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_rand
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_usleep
+lib/lmbench/bin/%%LMBENCH_OS%%/lat_cmd
lib/lmbench/scripts/allctx
lib/lmbench/scripts/allmem
lib/lmbench/scripts/bargraph
lib/lmbench/scripts/bghtml
+lib/lmbench/scripts/build
+lib/lmbench/scripts/compiler
+lib/lmbench/scripts/config
lib/lmbench/scripts/config-run
+lib/lmbench/scripts/config-scaling
lib/lmbench/scripts/depend
+lib/lmbench/scripts/do_ctx
lib/lmbench/scripts/getbg
+lib/lmbench/scripts/getbw
lib/lmbench/scripts/getctx
+lib/lmbench/scripts/getdisk
lib/lmbench/scripts/getlist
lib/lmbench/scripts/getmax
lib/lmbench/scripts/getmem
lib/lmbench/scripts/getpercent
+lib/lmbench/scripts/getresults
lib/lmbench/scripts/getsummary
lib/lmbench/scripts/gifs
+lib/lmbench/scripts/gnu-os
lib/lmbench/scripts/graph
lib/lmbench/scripts/html-list
lib/lmbench/scripts/html-man
+lib/lmbench/scripts/info
lib/lmbench/scripts/lmbench
+lib/lmbench/scripts/info-template
+lib/lmbench/scripts/make
+lib/lmbench/scripts/Makefile
lib/lmbench/scripts/man2html
+lib/lmbench/scripts/mkrelease
+lib/lmbench/scripts/new2oldctx
+lib/lmbench/scripts/opercent
lib/lmbench/scripts/os
+lib/lmbench/scripts/output
+lib/lmbench/scripts/percent
lib/lmbench/scripts/rccs
+lib/lmbench/scripts/README
lib/lmbench/scripts/results
lib/lmbench/scripts/save
+lib/lmbench/scripts/SHIT
+lib/lmbench/scripts/stats
+lib/lmbench/scripts/statsummary
+lib/lmbench/scripts/synchronize
+lib/lmbench/scripts/target
+lib/lmbench/scripts/TODO
+lib/lmbench/scripts/version
lib/lmbench/scripts/xroff
-lib/lmbench/scripts/RCS/rccs,v
-lib/lmbench/scripts/RCS/bargraph,v
-lib/lmbench/scripts/RCS/depend,v
-lib/lmbench/scripts/RCS/getbg,v
-lib/lmbench/scripts/RCS/getctx,v
-lib/lmbench/scripts/RCS/getlist,v
-lib/lmbench/scripts/RCS/getmax,v
-lib/lmbench/scripts/RCS/getmem,v
-lib/lmbench/scripts/RCS/graph,v
-lib/lmbench/scripts/RCS/getpercent,v
-lib/lmbench/scripts/RCS/getsummary,v
-lib/lmbench/scripts/RCS/lmbench,v
-lib/lmbench/scripts/RCS/os,v
-lib/lmbench/scripts/RCS/save,v
-lib/lmbench/scripts/RCS/xroff,v
-lib/lmbench/scripts/RCS/README,v
-lib/lmbench/scripts/RCS/Makefile,v
-lib/lmbench/scripts/RCS/results,v
-lib/lmbench/scripts/RCS/config-run,v
-lib/lmbench/scripts/RCS/allmem,v
-lib/lmbench/scripts/RCS/allctx,v
-@dirrm lib/lmbench/Results/FreeBSD
-@dirrm lib/lmbench/Results/GS
-@dirrm lib/lmbench/Results/PS
-@dirrm lib/lmbench/Results/RCS
-@dirrm lib/lmbench/Results/aix
-@dirrm lib/lmbench/Results/dgux
-@dirrm lib/lmbench/Results/hpux
-@dirrm lib/lmbench/Results/irix
-@dirrm lib/lmbench/Results/linux
-@dirrm lib/lmbench/Results/osf1
-@dirrm lib/lmbench/Results/solaris
-@dirrm lib/lmbench/Results/tmp
-@dirrm lib/lmbench/Results/unixware
-@dirrm lib/lmbench/Results
-@dirrm lib/lmbench/bin/bsd
-@dirrm lib/lmbench/bin
-@dirrm lib/lmbench/scripts/RCS
+lib/lmbench/results/Makefile
+@dirrm lib/lmbench/results
@dirrm lib/lmbench/scripts
+@dirrm lib/lmbench/bin/%%LMBENCH_OS%%
+@dirrm lib/lmbench/bin
@dirrm lib/lmbench