aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:24:48 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:24:48 +0000
commit8ea13c5d5fd88cfd1556b7f99ba82edabcb839b6 (patch)
tree38d37906c2633b0ef3c3793f83f192119e36898a
parent6955442f911e6c833af88ebf30df0a69ce45dfff (diff)
downloadports-8ea13c5d5fd88cfd1556b7f99ba82edabcb839b6.tar.gz
ports-8ea13c5d5fd88cfd1556b7f99ba82edabcb839b6.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Cache/Makefile27
-rw-r--r--www/p5-CGI-Cache/distinfo1
-rw-r--r--www/p5-CGI-Cache/pkg-comment1
-rw-r--r--www/p5-CGI-Cache/pkg-descr5
-rw-r--r--www/p5-CGI-Cache/pkg-plist3
6 files changed, 38 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 80d03bdff3d5..e71b540468ba 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -148,6 +148,7 @@
SUBDIR += p5-CGI_Lite
SUBDIR += p5-CGI-Application
SUBDIR += p5-CGI-ArgChecker
+ SUBDIR += p5-CGI-Cache
SUBDIR += p5-CGI-FastTemplate
SUBDIR += p5-CGI-Minimal
SUBDIR += p5-FastCGI
diff --git a/www/p5-CGI-Cache/Makefile b/www/p5-CGI-Cache/Makefile
new file mode 100644
index 000000000000..99fb2f19ad47
--- /dev/null
+++ b/www/p5-CGI-Cache/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: CGI-Cache
+# Date created: Mon Jan 1 11:26:17 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Cache
+PORTVERSION= 1.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Cache.pm:${PORTSDIR}/devel/p5-File-Cache
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= CGI::Cache.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Cache/distinfo b/www/p5-CGI-Cache/distinfo
new file mode 100644
index 000000000000..70174135cd4b
--- /dev/null
+++ b/www/p5-CGI-Cache/distinfo
@@ -0,0 +1 @@
+MD5 (CGI-Cache-1.02.tar.gz) = 77d43149b8063a223accf85ac34b48f1
diff --git a/www/p5-CGI-Cache/pkg-comment b/www/p5-CGI-Cache/pkg-comment
new file mode 100644
index 000000000000..c3ceae81de05
--- /dev/null
+++ b/www/p5-CGI-Cache/pkg-comment
@@ -0,0 +1 @@
+Perl extension to cache output of time-intensive CGI scripts
diff --git a/www/p5-CGI-Cache/pkg-descr b/www/p5-CGI-Cache/pkg-descr
new file mode 100644
index 000000000000..df9e742c80e8
--- /dev/null
+++ b/www/p5-CGI-Cache/pkg-descr
@@ -0,0 +1,5 @@
+CGI::Cache is a perl extension to help cache output of time-intensive
+CGI scripts so that subsequent visists to such scripts will not cost
+as much time.
+
+--will
diff --git a/www/p5-CGI-Cache/pkg-plist b/www/p5-CGI-Cache/pkg-plist
new file mode 100644
index 000000000000..fbe8bfeff50d
--- /dev/null
+++ b/www/p5-CGI-Cache/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Cache.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CGI/Cache/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CGI/Cache