aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:30:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:30:56 +0000
commit941c31ac7a3207a98179dd300f278e403bbb7429 (patch)
treea6146451714d833c93796dc754a7f017110bbcc5
parente836ab008ac38916a93472f2840e03e2e8470ef5 (diff)
Notes
-rw-r--r--editors/texworks/Makefile2
-rw-r--r--games/ember/Makefile7
-rw-r--r--www/trafficserver/Makefile4
3 files changed, 4 insertions, 9 deletions
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 89ef4ba3e547..3d13b1c64a71 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -51,7 +51,7 @@ PORTDOCS= *
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLUA}
-USE_LUA= 5.1
+USES+= lua:51
PLIST_FILES+= lib/texworks/libTWLuaPlugin.so
.endif
diff --git a/games/ember/Makefile b/games/ember/Makefile
index fb47d8f31f23..df2442e2be43 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -27,17 +27,14 @@ LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc \
--program-transform-name= --disable-cppunit --disable-debug \
--with-toluaxx=${TOLUAXX_CMD}
-CONFIGURE_ENV+= LUA_LIBS="-L${LUA_LIBDIR} -llua" \
+CONFIGURE_ENV+= LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER}" \
LUA_CFLAGS="-I${LUA_INCDIR}" \
TOLUAXX="${TOLUAXX_CMD}"
USE_SDL= sdl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_LUA= 5.1
-LUA_COMPS= toluaxx
-USES= openal:al,alut pathfix pkgconfig compiler:c++11-lib
-USE_BZIP2= YES
+USES= openal:al,alut pathfix pkgconfig compiler:c++11-lib tar:bzip2
OPTIONS_DEFINE= DOCS
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index 4089d1ecf629..c0853654f849 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -22,12 +22,10 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
USE_AUTOTOOLS= autoconf automake libtool aclocal
GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USES= pkgconfig tcl gmake perl5
+USES= pkgconfig tcl gmake perl5 tar:bzip2 lua:51
USE_OPENSSL= yes
USE_SQLITE= yes
USE_RC_SUBR= ${PORTNAME}
-USE_LUA= 5.1+
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
USERS= www