aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 00:57:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 00:57:08 +0000
commita66859e3fbe7c636031888cb5d9619ba4ac5ba5e (patch)
tree16fea2828aa5c44c6c6aadc965b1d00175293657
parent16a924bc3c7d04553f3d8a421c9ad14dafa6a5f6 (diff)
downloadports-a66859e3fbe7c636031888cb5d9619ba4ac5ba5e.tar.gz
ports-a66859e3fbe7c636031888cb5d9619ba4ac5ba5e.zip
Notes
-rw-r--r--archivers/ha/Makefile3
-rw-r--r--archivers/hpack.non-usa.only/Makefile3
-rw-r--r--mail/procmail/Makefile4
3 files changed, 7 insertions, 3 deletions
diff --git a/archivers/ha/Makefile b/archivers/ha/Makefile
index 4efa687286a5..982c3e6ca4c2 100644
--- a/archivers/ha/Makefile
+++ b/archivers/ha/Makefile
@@ -18,9 +18,10 @@ NO_WRKSUBDIR= yes
MAKEFILE= makefile.nix
ALL_TARGET= ha
USE_GMAKE= yes
+USE_REINPLACE= yes
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/c/hsc.c ${WRKSRC}/c/cpy.c \
${WRKSRC}/c/asc.c
diff --git a/archivers/hpack.non-usa.only/Makefile b/archivers/hpack.non-usa.only/Makefile
index 39407ff2ca57..02ff2eb232ff 100644
--- a/archivers/hpack.non-usa.only/Makefile
+++ b/archivers/hpack.non-usa.only/Makefile
@@ -18,10 +18,11 @@ MAKEFILE= makefile
ALL_TARGET= freebsd
INSTALL_TARGET= freebsd.install
MAN1= hpack.1
+USE_REINPLACE= yes
post-patch:
.for f in language/language.c cli.c
- @${PERL} -pi -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/${f}
.endfor
post-install:
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index 821fe0b4cc49..05246ce9ca82 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -34,6 +34,8 @@ MAINTAINER= ache@FreeBSD.org
# Global variables
#
+USE_REINPLACE= yes
+
# It asks for list of directories to do test for file locking
# (defaults to /tmp and ".", so return should suffice in most cases).
.if !defined(BATCH) # handled in patch-aa
@@ -60,7 +62,7 @@ SAMPLE_FILES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
post-configure: patch-config
patch-config:
- @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
# Post-install
#