aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-09 19:53:48 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-09 19:53:48 +0000
commita7f8867bcc5c089ab0d0414da2fd7875f3f25564 (patch)
treeef2ad71519ff862728c74c2871b9a4e47e629f7d
parentbf33d209c69660bac5307832cb2db02070bfb419 (diff)
downloadports-a7f8867bcc5c089ab0d0414da2fd7875f3f25564.tar.gz
ports-a7f8867bcc5c089ab0d0414da2fd7875f3f25564.zip
Notes
-rw-r--r--www/cherokee/Makefile12
-rw-r--r--www/cherokee/files/patch-configure42
2 files changed, 47 insertions, 7 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 82f3904b4a35..519245465ad7 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -11,8 +11,6 @@ MASTER_SITE_SUBDIR=cherokee/1.2/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast and flexible web server
-BROKEN= Does not configure
-
USES= gettext gmake pathfix pkgconfig
USE_OPENSSL= yes
USE_LDCONFIG= yes
@@ -92,7 +90,7 @@ PLIST_SUB+= LDAP="@comment "
.endif
.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+=--with-geoip=yes
PLIST_SUB+= GEOIP=""
.else
@@ -101,9 +99,9 @@ PLIST_SUB+= GEOIP="@comment "
.endif
.if ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg \
- avcodec:${PORTSDIR}/multimedia/ffmpeg \
- avutil:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg \
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
+ libavutil.so:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+=--with-ffmpeg=yes
.else
CONFIGURE_ARGS+=--with-ffmpeg=no
@@ -119,7 +117,7 @@ PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MINTPCRE}
CONFIGURE_ARGS+=--enable-internal-pcre
.else
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
.endif
.if ${PORT_OPTIONS:MRRDTOOL}
diff --git a/www/cherokee/files/patch-configure b/www/cherokee/files/patch-configure
new file mode 100644
index 000000000000..3ef6e1370045
--- /dev/null
+++ b/www/cherokee/files/patch-configure
@@ -0,0 +1,42 @@
+--- configure.orig 2014-01-09 21:48:12.000000000 +0200
++++ configure 2014-01-09 21:48:32.000000000 +0200
+@@ -15471,39 +15471,6 @@
+ # version HP92453-01 B.11.11.23709.GP, which incorrectly rejects
+ # declarations like `int a3[[(sizeof (unsigned char)) >= 0]];'.
+ # This bug is HP SR number 8606223364.
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking size of sig_atomic_t" >&5
+-$as_echo_n "checking size of sig_atomic_t... " >&6; }
+-if ${ac_cv_sizeof_sig_atomic_t+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if ac_fn_c_compute_int "$LINENO" "(long int) (sizeof (sig_atomic_t))" "ac_cv_sizeof_sig_atomic_t" "$ac_includes_default"; then :
+-
+-else
+- if test "$ac_cv_type_sig_atomic_t" = yes; then
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error 77 "cannot compute sizeof (sig_atomic_t)
+-See \`config.log' for more details" "$LINENO" 5; }
+- else
+- ac_cv_sizeof_sig_atomic_t=0
+- fi
+-fi
+-
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sizeof_sig_atomic_t" >&5
+-$as_echo "$ac_cv_sizeof_sig_atomic_t" >&6; }
+-
+-
+-
+-cat >>confdefs.h <<_ACEOF
+-#define SIZEOF_SIG_ATOMIC_T $ac_cv_sizeof_sig_atomic_t
+-_ACEOF
+-
+-
+-# The cast to long int works around a bug in the HP C Compiler
+-# version HP92453-01 B.11.11.23709.GP, which incorrectly rejects
+-# declarations like `int a3[[(sizeof (unsigned char)) >= 0]];'.
+-# This bug is HP SR number 8606223364.
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking size of time_t" >&5
+ $as_echo_n "checking size of time_t... " >&6; }
+ if ${ac_cv_sizeof_time_t+:} false; then :