aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-22 07:20:08 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-22 07:20:08 +0000
commitaa06b36b84856204364f64a80b56635469f431ac (patch)
tree62511aa542b48cdbd8f9f875e7408a0923095b5f
parent999548ae95ca0949e94322b2b0109d5a2d40fea2 (diff)
downloadports-aa06b36b84856204364f64a80b56635469f431ac.tar.gz
ports-aa06b36b84856204364f64a80b56635469f431ac.zip
Notes
-rw-r--r--ports-mgmt/pkg/Makefile3
-rw-r--r--ports-mgmt/pkg/distinfo4
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__Makefile13
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__backup.c10
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c13
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c11
-rw-r--r--ports-mgmt/pkg/files/patch-newvers.sh19
-rw-r--r--ports-mgmt/pkg/files/patch-pkg__Makefile12
-rw-r--r--ports-mgmt/pkg/files/patch-pkg__create.c11
-rw-r--r--ports-mgmt/pkg/files/patch-pkg__update.c11
10 files changed, 3 insertions, 104 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 718eefbc5ced..0fb0caa5f3ef 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.0.4
-PORTREVISION= 1
+DISTVERSION= 1.0.5
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index a9ad91d73aad..dead80d35f3b 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.0.4.tar.xz) = 7a85792f2758d989a491d3a20a00e5c09e3b679730657a001792f31dea25e607
-SIZE (pkg-1.0.4.tar.xz) = 1446804
+SHA256 (pkg-1.0.5.tar.xz) = e1750ee0edc142a2376f4510720fb074aca964e9922edb20a7924d347638b1f8
+SIZE (pkg-1.0.5.tar.xz) = 1447736
diff --git a/ports-mgmt/pkg/files/patch-libpkg__Makefile b/ports-mgmt/pkg/files/patch-libpkg__Makefile
deleted file mode 100644
index dcf2767fdbe7..000000000000
--- a/ports-mgmt/pkg/files/patch-libpkg__Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./libpkg/Makefile.orig 2012-12-21 12:57:15.000000000 +0100
-+++ ./libpkg/Makefile 2013-01-12 23:26:55.723640000 +0100
-@@ -94,8 +94,10 @@
-
- CFLAGS+= -DPREFIX=\"${PREFIX}\"
-
-+.if defined(DEBUG_FLAGS)
- DEBUG_FLAGS+= -g -O0
- STRIP=
-+.endif
- .if defined(PROFILE_BUILD)
- DEBUG_FLAGS+= -pg
- .endif
diff --git a/ports-mgmt/pkg/files/patch-libpkg__backup.c b/ports-mgmt/pkg/files/patch-libpkg__backup.c
deleted file mode 100644
index 96369b46f5ff..000000000000
--- a/ports-mgmt/pkg/files/patch-libpkg__backup.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./libpkg/backup.c.orig 2012-12-21 05:57:15.000000000 -0600
-+++ ./libpkg/backup.c 2013-01-13 12:16:18.119457225 -0600
-@@ -88,6 +88,7 @@
- b = sqlite3_backup_init(dst, "main", src, "main");
-
- elapsed = -1;
-+ done = total = 0;
- start = time(NULL);
-
- do {
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c
deleted file mode 100644
index ade0e588df12..000000000000
--- a/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./libpkg/pkg_elf.c.orig 2012-12-21 05:57:15.000000000 -0600
-+++ ./libpkg/pkg_elf.c 2013-01-13 12:16:18.123459813 -0600
-@@ -195,8 +195,8 @@
- struct stat sb;
- int ret = EPKG_OK;
-
-- size_t numdyn;
-- size_t sh_link;
-+ size_t numdyn = 0;
-+ size_t sh_link = 0;
- size_t dynidx;
- const char *osname;
-
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c
deleted file mode 100644
index 62260e11357b..000000000000
--- a/ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libpkg/pkg_repo.c.orig 2012-12-21 05:57:15.000000000 -0600
-+++ ./libpkg/pkg_repo.c 2013-01-13 12:16:18.126457634 -0600
-@@ -520,7 +520,7 @@
- maybe_delete_conflicting(const char *origin, const char *version,
- const char *pkg_path)
- {
-- int ret;
-+ int ret = EPKG_FATAL;
- const char *oversion;
-
- if (run_prepared_statement(VERSION, origin) != SQLITE_ROW)
diff --git a/ports-mgmt/pkg/files/patch-newvers.sh b/ports-mgmt/pkg/files/patch-newvers.sh
deleted file mode 100644
index 805bc02f8110..000000000000
--- a/ports-mgmt/pkg/files/patch-newvers.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 323c0b7c6e55a8e3736f0621e4504aef61828814
-Author: Bryan Drewery <bryan@shatow.net>
-Date: Fri Dec 21 09:34:31 2012 -0600
-
- Bump to 1.0.4_1
-
-diff --git newvers.sh newvers.sh
-index 8926a8c..2222329 100755
---- newvers.sh
-+++ newvers.sh
-@@ -41,7 +41,7 @@
- : ${PKG_MINOR_VERSION="0"}
- : ${PKG_PATCH_LEVEL="4"}
-
--: ${PORTREVISION:=""}
-+: ${PORTREVISION:="1"}
- : ${PORTEPOCH:=}
-
- # Define this to a true value if creating a snapshot
diff --git a/ports-mgmt/pkg/files/patch-pkg__Makefile b/ports-mgmt/pkg/files/patch-pkg__Makefile
deleted file mode 100644
index 19246a6c9bcf..000000000000
--- a/ports-mgmt/pkg/files/patch-pkg__Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./pkg/Makefile.orig 2013-01-12 23:38:30.808841691 +0100
-+++ ./pkg/Makefile 2013-01-12 23:38:50.521899817 +0100
-@@ -38,7 +38,9 @@
- CFLAGS+= -DGITHASH="\" ${GITHASH}\""
- .endif
-
-+.if defined(DEBUG_FLAGS)
- DEBUG_FLAGS+= -g -O0
-+.endif
- .if defined(PROFILE_BUILD)
- DEBUG_FLAGS+= -pg
- .endif
diff --git a/ports-mgmt/pkg/files/patch-pkg__create.c b/ports-mgmt/pkg/files/patch-pkg__create.c
deleted file mode 100644
index 243c6652d235..000000000000
--- a/ports-mgmt/pkg/files/patch-pkg__create.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./pkg/create.c.orig 2012-12-21 05:57:15.000000000 -0600
-+++ ./pkg/create.c 2013-01-13 12:16:18.129456852 -0600
-@@ -73,7 +73,7 @@
- PKG_LOAD_CATEGORIES | PKG_LOAD_DIRS | PKG_LOAD_SCRIPTS |
- PKG_LOAD_OPTIONS | PKG_LOAD_MTREE | PKG_LOAD_LICENSES |
- PKG_LOAD_USERS | PKG_LOAD_GROUPS | PKG_LOAD_SHLIBS;
-- const char *format;
-+ const char *format = NULL;
- bool foundone;
-
- if (pkgdb_open(&db, PKGDB_DEFAULT) != EPKG_OK) {
diff --git a/ports-mgmt/pkg/files/patch-pkg__update.c b/ports-mgmt/pkg/files/patch-pkg__update.c
deleted file mode 100644
index 4e7644289b50..000000000000
--- a/ports-mgmt/pkg/files/patch-pkg__update.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./pkg/update.c.orig 2012-12-21 05:57:15.000000000 -0600
-+++ ./pkg/update.c 2013-01-13 12:16:18.132456977 -0600
-@@ -49,7 +49,7 @@
- const char *repo_name;
- bool multi_repos = false;
- struct pkg_config_kv *repokv = NULL;
-- int retcode;
-+ int retcode = EPKG_FATAL;
-
- if (!quiet)
- printf("Updating repository catalogue\n");