aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-04-25 09:08:55 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-04-25 09:08:55 +0000
commitaae8188e7e7fa6a1a2eb7dea2a09877329a20ffe (patch)
tree2ded6db4002a2256596dca17692eb2a5005e42f6
parent3d363d155eec78b2b4a39fd8ed05327314da9a45 (diff)
downloadports-aae8188e7e7fa6a1a2eb7dea2a09877329a20ffe.tar.gz
ports-aae8188e7e7fa6a1a2eb7dea2a09877329a20ffe.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Markdown/Makefile24
-rw-r--r--textproc/p5-Text-Markdown/distinfo3
-rw-r--r--textproc/p5-Text-Markdown/pkg-descr11
-rw-r--r--textproc/p5-Text-Markdown/pkg-plist2
5 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d4c592795b44..b08909469c17 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -450,6 +450,7 @@
SUBDIR += p5-Text-Glob
SUBDIR += p5-Text-Graphics
SUBDIR += p5-Text-MagicTemplate
+ SUBDIR += p5-Text-Markdown
SUBDIR += p5-Text-Metaphone
SUBDIR += p5-Text-NSP
SUBDIR += p5-Text-Netstring
diff --git a/textproc/p5-Text-Markdown/Makefile b/textproc/p5-Text-Markdown/Makefile
new file mode 100644
index 000000000000..f58550470bf2
--- /dev/null
+++ b/textproc/p5-Text-Markdown/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Text-Markdown
+# Date created: 20.Mar.2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Markdown
+PORTVERSION= 1.0.3
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Markdown Perl5 module
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+
+PERL_MODBUILD= YES
+
+MAN3= Text::Markdown.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Markdown/distinfo b/textproc/p5-Text-Markdown/distinfo
new file mode 100644
index 000000000000..d1b87d0e8a87
--- /dev/null
+++ b/textproc/p5-Text-Markdown/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Markdown-1.0.3.tar.gz) = cbef6151c4ec798754e4dd21164a4dac
+SHA256 (Text-Markdown-1.0.3.tar.gz) = 1191bb1a1ba0268a8d940dcc10c767ac68e18bc5fe4cc38f559210d4c62c35b3
+SIZE (Text-Markdown-1.0.3.tar.gz) = 17372
diff --git a/textproc/p5-Text-Markdown/pkg-descr b/textproc/p5-Text-Markdown/pkg-descr
new file mode 100644
index 000000000000..d6bc9eaeec39
--- /dev/null
+++ b/textproc/p5-Text-Markdown/pkg-descr
@@ -0,0 +1,11 @@
+Markdown is a text-to-HTML filter; it translates an easy-to-read and
+easy-to-write structured text format into HTML. Markdown's text format
+is most similar to that of plain text email, and supports features such
+as headers, *emphasis*, code blocks, blockquotes, and links.
+
+Markdown's syntax is designed not as a generic markup language, but
+specifically to serve as a front-end to (X)HTML. You can use span-level
+HTML tags anywhere in a Markdown document, and you can use block level
+HTML tags (like <div> and <table> as well).
+
+WWW: http://daringfireball.net/projects/markdown/
diff --git a/textproc/p5-Text-Markdown/pkg-plist b/textproc/p5-Text-Markdown/pkg-plist
new file mode 100644
index 000000000000..46d3a0b73b14
--- /dev/null
+++ b/textproc/p5-Text-Markdown/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Text/Markdown.pm
+@dirrmtry %%SITE_PERL%%/Text