aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-19 14:21:42 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-19 14:21:42 +0000
commitade02cfb85d0aa2f383bf48151b46b82c1abe975 (patch)
tree0caf5578e87267863ea53806b414c7ca170f787b
parent815711e2d48af6f530bffec6553496fcdb8f6d37 (diff)
downloadports-ade02cfb85d0aa2f383bf48151b46b82c1abe975.tar.gz
ports-ade02cfb85d0aa2f383bf48151b46b82c1abe975.zip
Notes
-rw-r--r--devel/tcl-mmap/Makefile2
-rw-r--r--devel/tcl-signal/Makefile2
-rw-r--r--devel/tcllib/Makefile3
-rw-r--r--devel/tclreadline/Makefile2
-rw-r--r--devel/tclthread/Makefile17
-rw-r--r--devel/yajl-tcl/Makefile2
-rw-r--r--irc/roxirc/Makefile2
-rw-r--r--sysutils/dirdiff/Makefile3
-rw-r--r--x11-toolkits/gnocl/Makefile3
9 files changed, 16 insertions, 20 deletions
diff --git a/devel/tcl-mmap/Makefile b/devel/tcl-mmap/Makefile
index 7b873d91b25a..7d02af33fa99 100644
--- a/devel/tcl-mmap/Makefile
+++ b/devel/tcl-mmap/Makefile
@@ -11,7 +11,7 @@ COMMENT= New TCL channel type using mmap-ed files
LICENSE= GPLv3
-USE_TCL= 84+
+USES+= tcl
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
--prefix=${PREFIX} \
diff --git a/devel/tcl-signal/Makefile b/devel/tcl-signal/Makefile
index 1e06fcd57244..82c2d1ef0a46 100644
--- a/devel/tcl-signal/Makefile
+++ b/devel/tcl-signal/Makefile
@@ -14,7 +14,7 @@ DISTNAME= signal_ext${PORTVERSION:R:R}
MAINTAINER= tcltk@FreeBSD.org
COMMENT= Dynamically loadable signal handling for Tcl/Tk scripts
-USE_TCL= yes
+USES+= tcl
GNU_CONFIGURE= yes
ALL_TARGET= signal.so
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR}
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index e6e46403c6c6..4974300caff1 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -12,8 +12,7 @@ COMMENT= A collection of utility modules for Tcl
OPTIONS_DEFINE= DOCS MANPAGES
-USE_TCL= 84+
-
+USES+= tcl
GNU_CONFIGURE= yes
CONFIGURE_ENV+= ac_cv_path_tclsh="${TCLSH}"
ALL_TARGET= all
diff --git a/devel/tclreadline/Makefile b/devel/tclreadline/Makefile
index e0d3c00fc400..df1e99a42406 100644
--- a/devel/tclreadline/Makefile
+++ b/devel/tclreadline/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= tcltk@FreeBSD.org
COMMENT= GNU readline for TCL
-USE_TCL= 84+
+USES+= tcl
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
MANN= tclreadline.n
diff --git a/devel/tclthread/Makefile b/devel/tclthread/Makefile
index 18fd2264e478..3f37fcd47354 100644
--- a/devel/tclthread/Makefile
+++ b/devel/tclthread/Makefile
@@ -14,11 +14,12 @@ COMMENT= Scripting level thread extension for Tcl
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/license.terms
-USE_TCL= 84+
+USES+= tcl
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--exec-prefix=${PREFIX}
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
+ --exec-prefix=${PREFIX}
USE_LDCONFIG= ${PREFIX}/lib/thread${PORTVERSION}
PLIST_SUB+= VERSION="${PORTVERSION}"
@@ -26,7 +27,7 @@ PLIST_SUB+= VERSION="${PORTVERSION}"
INSTALL_TARGET= install-binaries install-libraries
.if !defined(NO_INSTALL_MANPAGES)
MANN= thread.n tpool.n tsv.n ttrace.n
-INSTALL_TARGET+= install-doc
+INSTALL_TARGET+=install-doc
.endif
OPTIONS_DEFINE= GDBM DOCS
@@ -35,13 +36,11 @@ GDBM_DESC= Persistent shared variables using GDBM
PORTDOCS= *
-.include <bsd.port.pre.mk>
-
-CONFIGURE_ARGS+= --with-tcl="${TCL_LIBDIR}"
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
-CONFIGURE_ARGS+= --with-gdbm
+LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+CONFIGURE_ARGS+=--with-gdbm
.endif
post-patch:
@@ -59,4 +58,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/yajl-tcl/Makefile b/devel/yajl-tcl/Makefile
index 5e597ce23aed..807639fe14a4 100644
--- a/devel/yajl-tcl/Makefile
+++ b/devel/yajl-tcl/Makefile
@@ -16,7 +16,7 @@ USE_GITHUB= yes
GH_ACCOUNT= flightaware
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_TCL= 85+
+USES+= tcl:85+
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR}
diff --git a/irc/roxirc/Makefile b/irc/roxirc/Makefile
index 885a0a19a1ef..ee91946ac379 100644
--- a/irc/roxirc/Makefile
+++ b/irc/roxirc/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://roxirc.lighter.net/download/
MAINTAINER= tcltk@FreeBSD.org
COMMENT= A tcl/tk irc client
-USE_TK= yes
+USES+= tk:run
NO_BUILD= yes
post-patch:
diff --git a/sysutils/dirdiff/Makefile b/sysutils/dirdiff/Makefile
index cdbbae98f51a..1a93cbc2f088 100644
--- a/sysutils/dirdiff/Makefile
+++ b/sysutils/dirdiff/Makefile
@@ -13,9 +13,8 @@ COMMENT= Graphical diff tool
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_TCL_BUILD= yes
+USES+= tk
USE_LDCONFIG= yes
-USE_TK= yes
PLIST_FILES= bin/dirdiff lib/libfilecmp.so.0
diff --git a/x11-toolkits/gnocl/Makefile b/x11-toolkits/gnocl/Makefile
index 2684be70cedf..99d08e70689c 100644
--- a/x11-toolkits/gnocl/Makefile
+++ b/x11-toolkits/gnocl/Makefile
@@ -17,9 +17,8 @@ LIB_DEPENDS= canberra:${PORTSDIR}/audio/libcanberra \
gtkimageview:${PORTSDIR}/x11-toolkits/gtkimageview
USE_BZIP2= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig tcl
USE_GNOME= gtk20 libglade2
-USE_TCL= 84+
USE_LDCONFIG= yes
CFLAGS+= -I${TCL_INCLUDEDIR} -L${TCL_LIBDIR}