aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-30 18:20:39 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-30 18:20:39 +0000
commitb3eed35dfd0d13117210be455fda4a1aa3b97d28 (patch)
tree193a2fab9d9b2b6e38f26f0a6fdc35e41a240c03
parent94ff89415b7b464e671f87c029d3b4824a20fd6d (diff)
Notes
-rw-r--r--audio/hawkvoice/Makefile4
-rw-r--r--net/hawknl/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/audio/hawkvoice/Makefile b/audio/hawkvoice/Makefile
index 98f5ac4bf9d3..bc7323e68666 100644
--- a/audio/hawkvoice/Makefile
+++ b/audio/hawkvoice/Makefile
@@ -32,6 +32,10 @@ OPTIONS= OPTIMIZATION "Enable optimization" off
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC -DPIC
+.endif
+
.if defined(WITH_OPTIMIZATION)
CFLAGS+= -funroll-all-loops -ffast-math -fomit-frame-pointer -D_GNU_SOURCE -D_REENTRANT
.endif
diff --git a/net/hawknl/Makefile b/net/hawknl/Makefile
index dd286fceb1bb..b4719c064063 100644
--- a/net/hawknl/Makefile
+++ b/net/hawknl/Makefile
@@ -31,6 +31,10 @@ OPTIONS= OPTIMIZATION "Enable optimization" off
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC -DPIC
+.endif
+
.if ${OSVERSION} < 500000
BROKEN= Doesn't build on < 5.x
.endif