aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-02-17 23:48:34 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-02-17 23:48:34 +0000
commitbac7f218bfd52a3876036c5b504705b0b919c101 (patch)
treea43584fde85d26c9c0a3f06a19929a9fcadd8651
parentcde1c6b04104bfe4f6d4bc649648fefa97d4d174 (diff)
downloadports-bac7f218bfd52a3876036c5b504705b0b919c101.tar.gz
ports-bac7f218bfd52a3876036c5b504705b0b919c101.zip
Notes
-rw-r--r--www/phpvirtualbox/Makefile20
-rw-r--r--www/phpvirtualbox/distinfo4
-rw-r--r--www/phpvirtualbox/pkg-plist23
3 files changed, 16 insertions, 31 deletions
diff --git a/www/phpvirtualbox/Makefile b/www/phpvirtualbox/Makefile
index d327827ce64a..9086eb671a44 100644
--- a/www/phpvirtualbox/Makefile
+++ b/www/phpvirtualbox/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= phpvirtualbox
-DISTVERSION= 4.3-1
-PORTREVISION= 1
+DISTVERSION= 4.3-2
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME} \
LOCAL/decke
@@ -13,17 +12,18 @@ COMMENT= AJAX Web Interface for VirtualBox
LICENSE= GPLv3
-USES= dos2unix zip
-USE_PHP= json session soap simplexml xml
NO_BUILD= yes
+USE_PHP= json session soap simplexml xml
+USES= dos2unix zip
+
DOS2UNIX_REGEX= .*\.(php|txt|js|css|html)
+ETCDIR= ${WWWDIR}
do-install:
- @${MKDIR} ${STAGEDIR}${WWWDIR}
- (cd ${WRKSRC}/ && ${COPYTREE_SHARE} "*" ${STAGEDIR}${WWWDIR} "! -name *.orig")
-
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
- @${FIND} ${STAGEDIR}${WWWDIR} -type f -exec ${CHMOD} 0444 {} \;
- @${FIND} ${STAGEDIR}${WWWDIR} -type d -exec ${CHMOD} 0755 {} \;
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} "*" ${STAGEDIR}${WWWDIR} \
+ "-not -name *.orig -not -name config.php-example")
+ ${INSTALL_DATA} ${WRKSRC}/config.php-example \
+ ${STAGEDIR}${WWWDIR}/config.php.sample
.include <bsd.port.mk>
diff --git a/www/phpvirtualbox/distinfo b/www/phpvirtualbox/distinfo
index 9f4039c9841b..36ec8e4a66aa 100644
--- a/www/phpvirtualbox/distinfo
+++ b/www/phpvirtualbox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (phpvirtualbox-4.3-1.zip) = 013edbb4035b8afafdcba833fcccf58d48c702fae1ea9feeb2576d96e62a83a5
-SIZE (phpvirtualbox-4.3-1.zip) = 4248078
+SHA256 (phpvirtualbox-4.3-2.zip) = 8610a15e8f57ed05bca3bd6822df7b6e569189b5145d2c760d929b773d7ddfe0
+SIZE (phpvirtualbox-4.3-2.zip) = 4256463
diff --git a/www/phpvirtualbox/pkg-plist b/www/phpvirtualbox/pkg-plist
index 5a29bd55725c..4b58fd961e6a 100644
--- a/www/phpvirtualbox/pkg-plist
+++ b/www/phpvirtualbox/pkg-plist
@@ -1,10 +1,10 @@
-@unexec if cmp -s %D/%%WWWDIR%%/config.php-example %D/%%WWWDIR%%/config.php; then rm -f %D/%%WWWDIR%%/config.php; fi
-%%WWWDIR%%/config.php-example
-@exec if [ ! -f %D/%%WWWDIR%%/config.php ]; then cp -p %D/%%WWWDIR%%/config.php-example %D/%%WWWDIR%%/config.php; fi
+@group www
+@owner www
%%WWWDIR%%/CHANGELOG.txt
%%WWWDIR%%/GPLv3.txt
%%WWWDIR%%/LICENSE.txt
%%WWWDIR%%/README.txt
+@sample %%ETCDIR%%/config.php.sample
%%WWWDIR%%/css/jquery-ui.css
%%WWWDIR%%/css/jquery.projectPlugins.css
%%WWWDIR%%/css/layout.css
@@ -89,6 +89,7 @@
%%WWWDIR%%/images/vbox/cd_disabled_32px.png
%%WWWDIR%%/images/vbox/cd_unmount_16px.png
%%WWWDIR%%/images/vbox/cd_unmount_dis_16px.png
+%%WWWDIR%%/images/vbox/cd_unmount_disabled_16px.png
%%WWWDIR%%/images/vbox/chipset_16px.png
%%WWWDIR%%/images/vbox/chipset_disabled_16px.png
%%WWWDIR%%/images/vbox/close_16px.png
@@ -455,7 +456,6 @@
%%WWWDIR%%/js/jquery.scrollTo-min.js
%%WWWDIR%%/js/jquery.tipped-2.1b.min.js
%%WWWDIR%%/js/language.php
-%%WWWDIR%%/js/phptest.php
%%WWWDIR%%/js/phpvirtualbox.js
%%WWWDIR%%/js/utils.js
%%WWWDIR%%/languages/de.xml
@@ -554,18 +554,3 @@
%%WWWDIR%%/screen.php
%%WWWDIR%%/tightvnc/VncViewer.jar
%%WWWDIR%%/vboxinit
-@dirrm %%WWWDIR%%/tightvnc
-@dirrm %%WWWDIR%%/rdpweb
-@dirrm %%WWWDIR%%/panes
-@dirrm %%WWWDIR%%/lib/auth
-@dirrm %%WWWDIR%%/lib
-@dirrm %%WWWDIR%%/languages/source
-@dirrm %%WWWDIR%%/languages
-@dirrm %%WWWDIR%%/js
-@dirrm %%WWWDIR%%/images/vbox/OSE
-@dirrm %%WWWDIR%%/images/vbox
-@dirrm %%WWWDIR%%/images/jqueryFileTree
-@dirrm %%WWWDIR%%/images/jquery-ui
-@dirrm %%WWWDIR%%/images
-@dirrm %%WWWDIR%%/css
-@dirrmtry %%WWWDIR%%