aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-16 13:22:42 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-16 13:22:42 +0000
commitbe2e0213742d0bdbc10bd5aab7b9600196685dc1 (patch)
treef8311ca6d02f90e2d00b5e0446e0d694ab486862
parenta9fa35f71a5a5de3cc7a645c724e00b5dae3d800 (diff)
downloadports-be2e0213742d0bdbc10bd5aab7b9600196685dc1.tar.gz
ports-be2e0213742d0bdbc10bd5aab7b9600196685dc1.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/serveez/Makefile32
-rw-r--r--net/serveez/distinfo1
-rw-r--r--net/serveez/pkg-comment1
-rw-r--r--net/serveez/pkg-descr15
-rw-r--r--net/serveez/pkg-plist55
6 files changed, 105 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index dad8eaa18879..b01a5655363c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -448,6 +448,7 @@
SUBDIR += sdl_net
SUBDIR += sendfile
SUBDIR += sendip
+ SUBDIR += serveez
SUBDIR += sharity-light
SUBDIR += silc-client
SUBDIR += silc-doc
diff --git a/net/serveez/Makefile b/net/serveez/Makefile
new file mode 100644
index 000000000000..206684b67cf4
--- /dev/null
+++ b/net/serveez/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: serveez
+# Date created: May 16, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= serveez
+PORTVERSION= 0.1.3
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= guile:${PORTSDIR}/lang/guile \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ bz2:${PORTSDIR}/archivers/bzip2
+
+GUILE_CONFIG?= ${LOCALBASE}/bin/guile-config
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include `${GUILE_CONFIG} compile`" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt `${GUILE_CONFIG} link`"
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= serveez.1
+
+.include <bsd.port.mk>
diff --git a/net/serveez/distinfo b/net/serveez/distinfo
new file mode 100644
index 000000000000..b79087200b34
--- /dev/null
+++ b/net/serveez/distinfo
@@ -0,0 +1 @@
+MD5 (serveez-0.1.3.tar.gz) = 61d99e1812f2dd87c9e194b0677de131
diff --git a/net/serveez/pkg-comment b/net/serveez/pkg-comment
new file mode 100644
index 000000000000..8514ae5be446
--- /dev/null
+++ b/net/serveez/pkg-comment
@@ -0,0 +1 @@
+A server framework
diff --git a/net/serveez/pkg-descr b/net/serveez/pkg-descr
new file mode 100644
index 000000000000..3f058dc3b826
--- /dev/null
+++ b/net/serveez/pkg-descr
@@ -0,0 +1,15 @@
+Serveez is a server framework. It provides routines and help for implementing
+IP based servers (currently TCP, UDP and ICMP). It is also possible to use
+named pipes for all connection oriented protocols. We think it is worth the
+effort because many people need server functionality within their applications.
+However, many people experience problems with select()- or poll()-loops, and
+with non-blocking operations. This application demonstrates various aspects of
+advanced network programming in a portable manner. You can use it for
+implementing your own servers or for understanding how certain network
+services and operations work. The package includes a number of servers that
+work already: an HTTP server, an IRC server, a Gnutella spider and some others.
+One of the highlights is that you can run all protocols on the same port. The
+application itself is single threaded but it uses helper processes for
+concurrent name resolution and ident lookups.
+
+WWW: http://www.gnu.org/software/serveez/
diff --git a/net/serveez/pkg-plist b/net/serveez/pkg-plist
new file mode 100644
index 000000000000..1fbc5513079c
--- /dev/null
+++ b/net/serveez/pkg-plist
@@ -0,0 +1,55 @@
+bin/mkpassword
+bin/serveez
+bin/serveez-config
+include/libserveez.h
+include/libserveez/alloc.h
+include/libserveez/array.h
+include/libserveez/binding.h
+include/libserveez/boot.h
+include/libserveez/codec/codec.h
+include/libserveez/core.h
+include/libserveez/coserver/coserver.h
+include/libserveez/defines.h
+include/libserveez/dynload.h
+include/libserveez/hash.h
+include/libserveez/icmp-socket.h
+include/libserveez/interface.h
+include/libserveez/passthrough.h
+include/libserveez/pipe-socket.h
+include/libserveez/portcfg.h
+include/libserveez/raw-socket.h
+include/libserveez/server-core.h
+include/libserveez/server-loop.h
+include/libserveez/server-socket.h
+include/libserveez/server.h
+include/libserveez/snprintf.h
+include/libserveez/socket.h
+include/libserveez/sparsevec.h
+include/libserveez/tcp-socket.h
+include/libserveez/udp-socket.h
+include/libserveez/util.h
+include/libserveez/vector.h
+include/libserveez/windoze.h
+include/svzconfig.h
+@dirrm include/libserveez/codec
+@dirrm include/libserveez/coserver
+@dirrm include/libserveez
+lib/libserveez-0.1.3.so
+lib/libserveez.a
+lib/libserveez.la
+lib/libserveez.so
+@unexec install-info --delete %D/info/serveez-api.info %D/info/dir
+@unexec install-info --delete %D/info/serveez.info %D/info/dir
+info/serveez-api.info
+info/serveez.info
+@exec install-info %D/info/serveez-api.info %D/info/dir
+@exec install-info %D/info/serveez.info %D/info/dir
+share/aclocal/serveez.m4
+share/serveez/echo-server.scm
+share/serveez/eval-server.scm
+share/serveez/inetd.scm
+share/serveez/mandel-client.scm
+share/serveez/mandel-server.scm
+share/serveez/mandel-shared.scm
+share/serveez/serveez.scm
+@dirrm share/serveez