aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-31 18:54:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-31 18:54:27 +0000
commitbf738e6f761522c8038d741231bbe6585d5ae32b (patch)
treea3bba2abb7937c3688570500c842fda73c553fc6
parent6864fffc0b06f0d07d75a24fdc19ccc2d044c6e6 (diff)
downloadports-bf738e6f761522c8038d741231bbe6585d5ae32b.tar.gz
ports-bf738e6f761522c8038d741231bbe6585d5ae32b.zip
New port: devel/py-fypp: Python powered preprocessor
Notes
Notes: svn path=/head/; revision=483605
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-fypp/Makefile18
-rw-r--r--devel/py-fypp/distinfo3
-rw-r--r--devel/py-fypp/pkg-descr9
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c5fa68a1ed24..c98accec6c73 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4594,6 +4594,7 @@
SUBDIR += py-futures
SUBDIR += py-futurist
SUBDIR += py-fuzzywuzzy
+ SUBDIR += py-fypp
SUBDIR += py-game
SUBDIR += py-game_sdl2
SUBDIR += py-gamin
diff --git a/devel/py-fypp/Makefile b/devel/py-fypp/Makefile
new file mode 100644
index 000000000000..70ea917df4a7
--- /dev/null
+++ b/devel/py-fypp/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= fypp
+PORTVERSION= 2.1.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python powered preprocessor
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-fypp/distinfo b/devel/py-fypp/distinfo
new file mode 100644
index 000000000000..492c4e0ad98c
--- /dev/null
+++ b/devel/py-fypp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1541006395
+SHA256 (fypp-2.1.1.tar.gz) = a0dad193bce4420927953dbd2068cb9fbfdb0bc0a161bafca366b1ed87cb954c
+SIZE (fypp-2.1.1.tar.gz) = 65021
diff --git a/devel/py-fypp/pkg-descr b/devel/py-fypp/pkg-descr
new file mode 100644
index 000000000000..8238ba3702f1
--- /dev/null
+++ b/devel/py-fypp/pkg-descr
@@ -0,0 +1,9 @@
+Fypp is a Python powered preprocessor. It can be used for any programming
+languages but its primary aim is to offer a Fortran preprocessor, which helps
+to extend Fortran with condititional compiling and template metaprogramming
+capabilities. Instead of introducing its own expression syntax, it uses Python
+expressions in its preprocessor directives, offering the consistency and
+versatility of Python when formulating metaprogramming tasks. It puts strong
+emphasis on robustness and on neat integration into developing toolchains.
+
+WWW: https://github.com/aradi/fypp