aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-12-10 09:34:21 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-12-10 09:34:21 +0000
commitc26eeb027c03dca0fc2e5a077d29ffaf9ef9cd07 (patch)
treed599ce3cea82733a94795cfce2f913f04a50e6ef
parent1cb3330b66eb3ebadb651237a5c830075a9a4c91 (diff)
downloadports-c26eeb027c03dca0fc2e5a077d29ffaf9ef9cd07.tar.gz
ports-c26eeb027c03dca0fc2e5a077d29ffaf9ef9cd07.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Time-modules/Makefile23
-rw-r--r--devel/p5-Time-modules/distinfo1
-rw-r--r--devel/p5-Time-modules/pkg-comment1
-rw-r--r--devel/p5-Time-modules/pkg-descr16
-rw-r--r--devel/p5-Time-modules/pkg-plist9
6 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 02492c71abcc..9f7e754122d2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -614,6 +614,7 @@
SUBDIR += p5-Time-Object
SUBDIR += p5-Time-Period
SUBDIR += p5-Time-Piece
+ SUBDIR += p5-Time-modules
SUBDIR += p5-TimeDate
SUBDIR += p5-TraceFuncs
SUBDIR += p5-Tree-DAG_Node
diff --git a/devel/p5-Time-modules/Makefile b/devel/p5-Time-modules/Makefile
new file mode 100644
index 000000000000..462903d4f4e0
--- /dev/null
+++ b/devel/p5-Time-modules/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Time-modules
+# Date created: 09 December 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Time-modules
+PORTVERSION= 2002.1001
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Time
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Time::CTime.3 Time::DaysInMonth.3 Time::JulianDay.3 \
+ Time::ParseDate.3 Time::Timezone.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Time-modules/distinfo b/devel/p5-Time-modules/distinfo
new file mode 100644
index 000000000000..255d6bf9c957
--- /dev/null
+++ b/devel/p5-Time-modules/distinfo
@@ -0,0 +1 @@
+MD5 (Time-modules-2002.1001.tar.gz) = c905006e8c3c6e6ec52b26c93db9e570
diff --git a/devel/p5-Time-modules/pkg-comment b/devel/p5-Time-modules/pkg-comment
new file mode 100644
index 000000000000..2eb0edd87789
--- /dev/null
+++ b/devel/p5-Time-modules/pkg-comment
@@ -0,0 +1 @@
+Set of modules for time manipulation
diff --git a/devel/p5-Time-modules/pkg-descr b/devel/p5-Time-modules/pkg-descr
new file mode 100644
index 000000000000..3184bfc3d12a
--- /dev/null
+++ b/devel/p5-Time-modules/pkg-descr
@@ -0,0 +1,16 @@
+This package contains the following perl5 modules:
+
+* Time::CTime - ctime, strftime, and asctime
+
+* Time::JulianDay - Julian calendar manipulations
+
+* Time::ParseDate - reverses strftime and also understands relative times
+
+* Time::Timezone - miscellaneous timezone manipulations routines
+
+* Time::DaysInMonth - simply report the number of days in a month
+
+WWW: http://search.cpan.org/search?dist=Time-modules
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Time-modules/pkg-plist b/devel/p5-Time-modules/pkg-plist
new file mode 100644
index 000000000000..6edddaf242e8
--- /dev/null
+++ b/devel/p5-Time-modules/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Time-modules/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Time/CTime.pm
+lib/perl5/site_perl/%%PERL_VER%%/Time/DaysInMonth.pm
+lib/perl5/site_perl/%%PERL_VER%%/Time/JulianDay.pm
+lib/perl5/site_perl/%%PERL_VER%%/Time/ParseDate.pm
+lib/perl5/site_perl/%%PERL_VER%%/Time/Timezone.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Time-modules
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Time 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Time 2>/dev/null || true