aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-29 18:09:11 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-29 18:09:11 +0000
commitc9188eefd03f11376dd8486264a58a0f562b759b (patch)
tree3bf59e0a99a467465f202ae3d5a1d223910edf35
parent61540bed3672f08185969e7251e28a42ebc7c443 (diff)
Notes
-rw-r--r--x11-toolkits/fltk2/files/patch-images-fl_png.cxx11
-rw-r--r--x11-toolkits/irrlicht/Makefile2
2 files changed, 13 insertions, 0 deletions
diff --git a/x11-toolkits/fltk2/files/patch-images-fl_png.cxx b/x11-toolkits/fltk2/files/patch-images-fl_png.cxx
new file mode 100644
index 000000000000..0648912434b9
--- /dev/null
+++ b/x11-toolkits/fltk2/files/patch-images-fl_png.cxx
@@ -0,0 +1,11 @@
+--- images/fl_png.cxx.orig 2007-04-16 16:48:06.000000000 +0200
++++ images/fl_png.cxx 2010-03-29 19:55:26.000000000 +0200
+@@ -62,7 +62,7 @@
+ #if !HAVE_LIBPNG
+ return 0;
+ #else
+- return png_check_sig((png_byte*)datas, (int)size)!=0;
++ return !png_sig_cmp((png_byte*)datas, 0, (int)size)!=0;
+ #endif
+ }
+
diff --git a/x11-toolkits/irrlicht/Makefile b/x11-toolkits/irrlicht/Makefile
index 1cf8c2345f1a..16490331576b 100644
--- a/x11-toolkits/irrlicht/Makefile
+++ b/x11-toolkits/irrlicht/Makefile
@@ -63,6 +63,8 @@ MAKE_ENV+= NDEBUG=1
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ ${WRKSRC}/source/Irrlicht/CImageLoaderPNG.cpp
.if !defined(HAVE_JOYSTICK)
@${REINPLACE_CMD} -e '/define.*_IRR_COMPILE_WITH_JOYSTICK_EVENTS_/ d' \
${WRKSRC}/include/IrrCompileConfig.h