aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2005-07-13 13:42:26 +0000
committerMichael Landin <mich@FreeBSD.org>2005-07-13 13:42:26 +0000
commitd251df41e307f153cbadb301c72a5b60aa67bdec (patch)
tree4ef521c071c8d0491d9160530ce3d51269ee4f01
parentb46341740c149f21158eb563c14bae6f8c83c83d (diff)
downloadports-d251df41e307f153cbadb301c72a5b60aa67bdec.tar.gz
ports-d251df41e307f153cbadb301c72a5b60aa67bdec.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ogg2mp3/Makefile32
-rw-r--r--audio/ogg2mp3/distinfo2
-rw-r--r--audio/ogg2mp3/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index eee4cfb1b6a1..5e649dfc6ee2 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -328,6 +328,7 @@
SUBDIR += nosefart
SUBDIR += nspmod
SUBDIR += ocp
+ SUBDIR += ogg2mp3
SUBDIR += oggsplit
SUBDIR += openal
SUBDIR += opennap
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
new file mode 100644
index 000000000000..939d4abdddac
--- /dev/null
+++ b/audio/ogg2mp3/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ogg2mp3
+# Date created: 26 Jun 2005
+# Whom: Aleksander Fafula <alex@bsdguru.org>
+#
+# $FreeBSD$
+
+PORTNAME= ogg2mp3
+PORTVERSION= 0.5
+CATEGORIES= audio
+MASTER_SITES= http://amor.cms.hu-berlin.de/~h0444y2j/pub/
+
+MAINTAINER= alex@bsdguru.org
+COMMENT= Perl script that converts Ogg Vorbis files to MP3 format
+
+RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
+ ${SITE_PERL}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote \
+ ogginfo:${PORTSDIR}/audio/vorbis-tools
+
+NO_BUILD= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/ogg2mp3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin|/usr/local/bin|g' \
+ ${WRKSRC}/ogg2mp3
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ogg2mp3 ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/ogg2mp3/distinfo b/audio/ogg2mp3/distinfo
new file mode 100644
index 000000000000..3f3f7b7d1481
--- /dev/null
+++ b/audio/ogg2mp3/distinfo
@@ -0,0 +1,2 @@
+MD5 (ogg2mp3-0.5.tar.bz2) = 283e3d255c344d41b340391a19cd2e65
+SIZE (ogg2mp3-0.5.tar.bz2) = 12832
diff --git a/audio/ogg2mp3/pkg-descr b/audio/ogg2mp3/pkg-descr
new file mode 100644
index 000000000000..97b580dd6b1b
--- /dev/null
+++ b/audio/ogg2mp3/pkg-descr
@@ -0,0 +1,3 @@
+ogg2mp3 is a perl script that converts Ogg Vorbis files into MP3 format.
+
+WWW: http://amor.cms.hu-berlin.de/~h0444y2j/linux.html