aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2001-03-07 00:01:17 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2001-03-07 00:01:17 +0000
commitd63f8f6234fa134a815c78b2ef58f21ab7f0d36e (patch)
tree0f56129bf2194db55e894a5257f736c877b7ce81
parent59d8aee249bdf4d09571e630d41a1d95be9af6e2 (diff)
downloadports-d63f8f6234fa134a815c78b2ef58f21ab7f0d36e.tar.gz
ports-d63f8f6234fa134a815c78b2ef58f21ab7f0d36e.zip
Notes
-rw-r--r--news/inn-stable/Makefile25
-rw-r--r--news/inn-stable/distinfo2
-rw-r--r--news/inn-stable/pkg-plist9
3 files changed, 26 insertions, 10 deletions
diff --git a/news/inn-stable/Makefile b/news/inn-stable/Makefile
index a1833db0945a..a2ed79b47455 100644
--- a/news/inn-stable/Makefile
+++ b/news/inn-stable/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= inn
-SNAPSHOT= 20010107
+SNAPSHOT= 20010306
PORTVERSION= 2.3.${SNAPSHOT}
CATEGORIES= news
MASTER_SITES= ftp://ftp.isc.org/isc/inn/snapshots/
@@ -40,19 +40,20 @@ CONFIGURE_ARGS+= --with-largefiles
# is somewhat slower
#CONFIGURE_ARGS+= --enable-tagged-hash
-MAN1= ckpasswd.1 convdate.1 getlist.1 grephistory.1 inews.1 innconfval.1 \
- innfeed.1 nntpget.1 rnews.1 shlock.1 shrinkfile.1 simpleftp.1 \
- startinnfeed.1
+MAN1= ckpasswd.1 convdate.1 fastrm.1 getlist.1 grephistory.1 inews.1 \
+ innconfval.1 innfeed.1 innmail.1 nntpget.1 rnews.1 shlock.1 \
+ shrinkfile.1 simpleftp.1 startinnfeed.1
MAN3= clientlib.3 dbz.3 inndcomm.3 libinn.3 libstorage.3 parsedate.3 qio.3 \
wildmat.3
MAN5= active.5 buffindexed.conf.5 control.ctl.5 cycbuff.conf.5 \
distrib.pats.5 expire.ctl.5 history.5 incoming.conf.5 inn.conf.5 \
innfeed.conf.5 innwatch.ctl.5 moderators.5 motd.news.5 newsfeeds.5 \
newslog.5 nnrp.access.5 nnrpd.track.5 nntpsend.ctl.5 ovdb.5 \
- overview.fmt.5 passwd.nntp.5 readers.conf.5 sasl.conf.5 storage.conf.5
+ overview.fmt.5 passwd.nntp.5 readers.conf.5 sasl.conf.5 \
+ storage.conf.5 subscriptions.5
MAN8= actsync.8 actsyncd.8 archive.8 batcher.8 buffchan.8 cnfsheadconf.8 \
cnfsstat.8 controlchan.8 ctlinnd.8 cvtbatch.8 dbprocs.8 expire.8 \
- expireover.8 expirerm.8 fastrm.8 filechan.8 inncheck.8 innd.8 inndf.8 \
+ expireover.8 expirerm.8 filechan.8 inncheck.8 innd.8 inndf.8 \
inndstart.8 innreport.8 innstat.8 innwatch.8 innxbatch.8 innxmit.8 \
mailpost.8 makedbz.8 makehistory.8 mod-active.8 news.daily.8 \
news2mail.8 newsrequeue.8 nnrpd.8 nntpsend.8 ovdb_recover.8 \
@@ -61,25 +62,33 @@ MAN8= actsync.8 actsyncd.8 archive.8 batcher.8 buffchan.8 cnfsheadconf.8 \
EXTRA= ${WRKSRC}/HISTORY ${WRKSRC}/INSTALL ${WRKSRC}/LICENSE
+INN_INCLUDES= clibrary.h config.h libinn.h storage.h
+
pre-install:
${MKDIR} ${INN_NEWSSPOOL}
post-install:
+ @${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
+ @${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
cd ${PREFIX}/news/db ; \
${TOUCH} history ; \
${CHMOD} 644 history ; \
${CHOWN} news:news history ; \
- ../bin/makedbz -i ; \
+ su -fm news -c "../bin/makedbz -i" ; \
for s in dir hash index ; do \
- ${INSTALL} -o news -m 644 history.n.$${s} history.$${s} ; \
+ ${MV} history.n.$${s} history.$${s} ; \
done ; \
fi)
@${SED} <${FILESDIR}/innd.sh >${PREFIX}/etc/rc.d/innd.sh \
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${MKDIR} ${PREFIX}/share/doc/inn
@${INSTALL_DATA} ${EXTRA} ${PREFIX}/share/doc/inn
+ @${MKDIR} ${PREFIX}/news/include
+.for FILE in ${INN_INCLUDES}
+ @${INSTALL_DATA} ${WRKSRC}/include/${FILE} ${PREFIX}/news/include/
+.endfor
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>
diff --git a/news/inn-stable/distinfo b/news/inn-stable/distinfo
index 0f5c5570c254..f8236e88e871 100644
--- a/news/inn-stable/distinfo
+++ b/news/inn-stable/distinfo
@@ -1 +1 @@
-MD5 (inn-STABLE-20010107.tar.gz) = 7182bf6357c2ffd98fe00f30fc326ac8
+MD5 (inn-STABLE-20010306.tar.gz) = 2946f55e40642abf1180723c86dedee9
diff --git a/news/inn-stable/pkg-plist b/news/inn-stable/pkg-plist
index 94c33da99e15..ed5005f1ddd6 100644
--- a/news/inn-stable/pkg-plist
+++ b/news/inn-stable/pkg-plist
@@ -50,6 +50,7 @@ news/bin/filter/nnrpd_auth.py
news/bin/filter/startup.tcl
news/bin/filter/startup_innd.pl
news/bin/getlist
+news/bin/gpgverify
news/bin/grephistory
news/bin/inews
news/bin/inncheck
@@ -135,6 +136,11 @@ news/etc/radius.conf
news/etc/readers.conf
news/etc/sasl.conf
news/etc/storage.conf
+news/etc/subscriptions
+news/include/clibrary.h
+news/include/config.h
+news/include/libinn.h
+news/include/storage.h
news/lib/docheckgroups
news/lib/innreport_inn.pm
news/lib/innshellvars
@@ -157,6 +163,7 @@ share/doc/inn/LICENSE
@dirrm news/spool
@dirrm news/run
@dirrm news/lib
+@dirrm news/include
@dirrm news/etc
@dirrm news/db
@dirrm news/bin/rnews.libexec
@@ -166,4 +173,4 @@ share/doc/inn/LICENSE
@dirrm news/bin/auth/passwd
@dirrm news/bin/auth
@dirrm news/bin
-@dirrm news
+@dirrm news