aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2004-11-26 22:25:20 +0000
committerBrian Somers <brian@FreeBSD.org>2004-11-26 22:25:20 +0000
commitde83746d3ed7086bd1cc4fc7cfa1e06c91d2e525 (patch)
tree4afc2f7890f340615a737287295d4aef0334aab8
parentd13d09be06cfa91e95c8801ba56c9e658f0da470 (diff)
downloadports-de83746d3ed7086bd1cc4fc7cfa1e06c91d2e525.tar.gz
ports-de83746d3ed7086bd1cc4fc7cfa1e06c91d2e525.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-ldap-abook/Makefile43
-rw-r--r--www/p5-ldap-abook/distinfo1
-rw-r--r--www/p5-ldap-abook/files/abook.ldif4
-rw-r--r--www/p5-ldap-abook/files/patch-AddressBook.conf38
-rw-r--r--www/p5-ldap-abook/pkg-descr10
-rw-r--r--www/p5-ldap-abook/pkg-message22
-rw-r--r--www/p5-ldap-abook/pkg-plist33
8 files changed, 152 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e46e879cfe74..9a642fbfbce2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -552,6 +552,7 @@
SUBDIR += p5-WWW-Search-Google
SUBDIR += p5-WWW-Shorten
SUBDIR += p5-WWW-Wikipedia
+ SUBDIR += p5-ldap-abook
SUBDIR += p5-libapreq
SUBDIR += p5-libapreq-static
SUBDIR += p5-libapreq2
diff --git a/www/p5-ldap-abook/Makefile b/www/p5-ldap-abook/Makefile
new file mode 100644
index 000000000000..65f3d38f0b5d
--- /dev/null
+++ b/www/p5-ldap-abook/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-abook
+# Date created: November 22, 2004
+# Whom: Brian Somers <brian@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldap-abook
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl5 CGI script providing an LDAP addressbook web interface
+
+RUN_DEPENDS= ${SITE_PERL}/AddressBook.pm:${PORTSDIR}/net/p5-AddressBook \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+
+ABOOK= ${PREFIX}/www/ldap-abook
+CONFIG= ${PREFIX}/etc/AddressBook.conf
+USE_PERL5= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e 's|(/etc/AddressBook.conf)|${PREFIX}$$1|g' \
+ ${WRKSRC}/cgi-bin/abook.cgi
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/www/ldap-abook
+ ${TAR} -C ${WRKSRC} --exclude '*.orig' -cf - . | \
+ ${TAR} -C ${PREFIX}/www/ldap-abook -xf -
+ ${INSTALL_DATA} ${FILESDIR}/abook.ldif ${ABOOK}/examples/default
+ ${INSTALL_DATA} ${ABOOK}/examples/default/AddressBook.conf \
+ ${CONFIG}-dist
+ [ -f ${CONFIG} ] || \
+ install -o root -g www -m 640 ${CONFIG}-dist ${CONFIG}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/p5-ldap-abook/distinfo b/www/p5-ldap-abook/distinfo
new file mode 100644
index 000000000000..5aadf6e48f56
--- /dev/null
+++ b/www/p5-ldap-abook/distinfo
@@ -0,0 +1 @@
+MD5 (ldap-abook-1.00.tar.gz) = 456ba400d5f97b3757f0dc0a73093b2c
diff --git a/www/p5-ldap-abook/files/abook.ldif b/www/p5-ldap-abook/files/abook.ldif
new file mode 100644
index 000000000000..d4378b020a47
--- /dev/null
+++ b/www/p5-ldap-abook/files/abook.ldif
@@ -0,0 +1,4 @@
+dn: ou=abook, dc=your_domain
+objectClass: top
+objectClass: organizationalUnit
+ou: abook
diff --git a/www/p5-ldap-abook/files/patch-AddressBook.conf b/www/p5-ldap-abook/files/patch-AddressBook.conf
new file mode 100644
index 000000000000..a5fc4daa00a8
--- /dev/null
+++ b/www/p5-ldap-abook/files/patch-AddressBook.conf
@@ -0,0 +1,38 @@
+--- examples/default/AddressBook.conf.orig Sun Jan 28 15:44:27 2001
++++ examples/default/AddressBook.conf Tue Nov 23 18:42:47 2004
+@@ -128,7 +128,7 @@
+ <db type="old_ldap-abook" name="homePage" />
+ <db type="LDIF" name="homePage" />
+ </field>
+- <field name="address" order="10" type="textbox">
++ <field name="address" order="10" type="text">
+ <db type="abookentry" name="Street Address" />
+ <db type="Text" name="Street Address" />
+ <db type="LDAP" name="street" />
+@@ -137,7 +137,7 @@
+ <db type="PDB" name="Address" />
+ </field>
+ <field name="city" order="11" type="text">
+- <db type="abookentry" name="City" />
++ <db type="abookentry" name="City/Town" />
+ <db type="Text" name="City" />
+ <db type="LDAP" name="l" />
+ <db type="old_ldap-abook" name="locality" />
+@@ -145,7 +145,7 @@
+ <db type="PDB" name="City" />
+ </field>
+ <field name="state" order="12" type="text">
+- <db type="abookentry" name="State" />
++ <db type="abookentry" name="State/County" />
+ <db type="Text" name="State" />
+ <db type="LDAP" name="st" />
+ <db type="old_ldap-abook" name="st" />
+@@ -154,7 +154,7 @@
+ </field>
+ <field name="postalCode" order="13" type="text">
+ <db type="Text" name="Zip Code" />
+- <db type="abookentry" name="Zip Code" />
++ <db type="abookentry" name="Zip/Post Code" />
+ <db type="LDAP" name="postalCode" />
+ <db type="old_ldap-abook" name="postalCode" />
+ <db type="LDIF" name="postalCode" />
diff --git a/www/p5-ldap-abook/pkg-descr b/www/p5-ldap-abook/pkg-descr
new file mode 100644
index 000000000000..c154ae4e13cc
--- /dev/null
+++ b/www/p5-ldap-abook/pkg-descr
@@ -0,0 +1,10 @@
+ldap-abook provides a web interface for adding, removing and modifying
+LDAP addressbook records. These addressbook records can be used with
+mail clients such as Sylpheed, Microsoft Outlook and probably Netscape
+and Mozilla.
+
+Attributes such as address details, date of birth and phonelist membership
+are also possible, allowing other applications to feed off the same
+database.
+
+WWW: http://ldap-abook.sourceforge.net/
diff --git a/www/p5-ldap-abook/pkg-message b/www/p5-ldap-abook/pkg-message
new file mode 100644
index 000000000000..3a9c39fc6e99
--- /dev/null
+++ b/www/p5-ldap-abook/pkg-message
@@ -0,0 +1,22 @@
+========== Installing ldap-abook for the first time ==========
+Tell the openldap server about the abook schema with the
+following line in $PREFIX/etc/openldap/slapd.conf:
+
+include $PREFIX/www/ldap-abook/examples/default/abookperson.schema
+
+Create the initial ``abook'' ou using the following command:
+
+ cd $PREFIX/www/ldap-abook/examples/default
+ ldapadd -h host -W -D 'dc=your_domain' -f abook.ldif
+
+replacing host and your_domain as appropriate (abook.ldif must
+have "your_domain" changed too).
+
+Modify "your_domain" and "secret" (and possibly "Manager") in
+$PREFIX/etc/AddressBook.conf too.
+
+Link to abook.cgi from your web server's CGI directory:
+
+ cd /usr/local/www/cgi-bin
+ ln -s $PREFIX/www/ldap-abook/cgi-bin/abook.cgi
+==============================================================
diff --git a/www/p5-ldap-abook/pkg-plist b/www/p5-ldap-abook/pkg-plist
new file mode 100644
index 000000000000..45e190386168
--- /dev/null
+++ b/www/p5-ldap-abook/pkg-plist
@@ -0,0 +1,33 @@
+www/ldap-abook/html/ball.gray.gif
+www/ldap-abook/html/getting_started
+www/ldap-abook/html/index.html
+www/ldap-abook/examples/default/AddressBook.conf
+www/ldap-abook/examples/default/README
+www/ldap-abook/examples/default/abookperson.schema
+www/ldap-abook/examples/default/slapd.conf.v2
+www/ldap-abook/examples/default/abookPerson.oc.conf
+www/ldap-abook/examples/default/setup.pm
+www/ldap-abook/examples/default/slapd.conf.v1
+www/ldap-abook/examples/default/abook.ldif
+www/ldap-abook/cgi-bin/abook.cgi
+www/ldap-abook/t/01-ldap_bind.t
+www/ldap-abook/t/02-abookentry.t
+www/ldap-abook/t/03-abooksearch.t
+www/ldap-abook/t/04-abooknew.t
+www/ldap-abook/t/05-base_check.t
+www/ldap-abook/INSTALL
+www/ldap-abook/ChangeLog
+www/ldap-abook/COPYING
+www/ldap-abook/Artistic
+www/ldap-abook/README
+www/ldap-abook/Makefile.PL
+www/ldap-abook/MANIFEST
+@unexec if cmp -s %D/etc/AddressBook.conf %D/etc/AddressBook.conf-dist; then rm -f %D/etc/AddressBook.conf; fi
+etc/AddressBook.conf-dist
+@exec [ -f %B/AddressBook.conf ] || cp %B/%f %B/AddressBook.conf
+@dirrm www/ldap-abook/html
+@dirrm www/ldap-abook/examples/default
+@dirrm www/ldap-abook/examples
+@dirrm www/ldap-abook/cgi-bin
+@dirrm www/ldap-abook/t
+@dirrm www/ldap-abook