aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-08-27 03:04:09 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-08-27 03:04:09 +0000
commite2f9df4db8992200a8e65416c5467f49caa7ca15 (patch)
treec7a29cdc178aba1007cf71bc86aadb06adda4e87
parent01253d9c64fc3fc044405ad142c2cf2ff88507b2 (diff)
downloadports-e2f9df4db8992200a8e65416c5467f49caa7ca15.tar.gz
ports-e2f9df4db8992200a8e65416c5467f49caa7ca15.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Lingua-Treebank/Makefile25
-rw-r--r--textproc/p5-Lingua-Treebank/distinfo3
-rw-r--r--textproc/p5-Lingua-Treebank/pkg-descr10
-rw-r--r--textproc/p5-Lingua-Treebank/pkg-plist14
5 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 29c442d48ec5..da472152b078 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -444,6 +444,7 @@
SUBDIR += p5-Lingua-Stem-Snowball-No
SUBDIR += p5-Lingua-Stem-Snowball-Se
SUBDIR += p5-Lingua-StopWords
+ SUBDIR += p5-Lingua-Treebank
SUBDIR += p5-Lucene
SUBDIR += p5-MARC
SUBDIR += p5-MARC-Lint
diff --git a/textproc/p5-Lingua-Treebank/Makefile b/textproc/p5-Lingua-Treebank/Makefile
new file mode 100644
index 000000000000..981b744034b9
--- /dev/null
+++ b/textproc/p5-Lingua-Treebank/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: textproc/p5-Lingua-Treebank
+# Date created: 27 August 2008
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-Treebank
+PORTVERSION= 0.15
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl extension for manipulating the Penn Treebank format
+
+PERL_CONFIGURE= yes
+
+MAN1= get-words.1 list-edges.1 list-rewrites.1 \
+ tree-collapse.1 tree-inflate.1 vocabulary.1
+MAN3= Lingua::Treebank.3 \
+ Lingua::Treebank::Const.3 \
+ Lingua::Treebank::HeadFinder.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Lingua-Treebank/distinfo b/textproc/p5-Lingua-Treebank/distinfo
new file mode 100644
index 000000000000..9dbbfc6cc0d3
--- /dev/null
+++ b/textproc/p5-Lingua-Treebank/distinfo
@@ -0,0 +1,3 @@
+MD5 (Lingua-Treebank-0.15.tar.gz) = 50eebbf2aa707987be36e21725201bb8
+SHA256 (Lingua-Treebank-0.15.tar.gz) = d203fbd1a6c9fa7630a31214a31bf37dc0bba220f0c9a0470dcdf6b65a1afe59
+SIZE (Lingua-Treebank-0.15.tar.gz) = 37330
diff --git a/textproc/p5-Lingua-Treebank/pkg-descr b/textproc/p5-Lingua-Treebank/pkg-descr
new file mode 100644
index 000000000000..b0069c93182a
--- /dev/null
+++ b/textproc/p5-Lingua-Treebank/pkg-descr
@@ -0,0 +1,10 @@
+This class knows how to read two treebank formats, the Penn format
+and the Chomsky Normal Form (CNF) format. These formats differ in
+how they handle terminal nodes. The Penn format places pre-terminal
+part of speech tags in the left-hand position of a
+parenthesis-delimited pair, just like it does non-terminal nodes.
+
+The CNF format attaches pre-terminal tags to the word with an
+underscore.
+
+WWW: http://search.cpan.org/dist/Lingua-Treebank/
diff --git a/textproc/p5-Lingua-Treebank/pkg-plist b/textproc/p5-Lingua-Treebank/pkg-plist
new file mode 100644
index 000000000000..f76dc86d9fb2
--- /dev/null
+++ b/textproc/p5-Lingua-Treebank/pkg-plist
@@ -0,0 +1,14 @@
+bin/list-rewrites
+bin/list-edges
+bin/tree-collapse
+bin/get-words
+bin/tree-inflate
+bin/vocabulary
+%%SITE_PERL%%/Lingua/Treebank.pm
+%%SITE_PERL%%/Lingua/Treebank/Const.pm
+%%SITE_PERL%%/Lingua/Treebank/HeadFinder.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/Treebank/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/Treebank
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua
+@dirrmtry %%SITE_PERL%%/Lingua/Treebank
+@dirrmtry %%SITE_PERL%%/Lingua