aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-03-11 21:15:03 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-03-11 21:15:03 +0000
commite64b7a3817ffbae7b1a37b49b17a3fb8d3fc6686 (patch)
treeca0a0239e083f5fdd3a9d29c724b8f9a5d58f2ed
parent462c0cb7eeea1e18d63cff823d3be6044ac61a60 (diff)
Notes
-rw-r--r--www/webkit-gtk2/Makefile24
-rw-r--r--www/webkit-gtk2/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h4
-rw-r--r--www/webkit-gtk2/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp11
-rw-r--r--www/webkit-gtk2/files/patch-Source_WebCore_plugins_PluginDatabase.cpp6
4 files changed, 32 insertions, 13 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 71638d5f9c1d..b56c02b0ed9b 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= webkit
PORTVERSION= 2.4.11
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= -gtk2
@@ -20,21 +20,26 @@ LIB_DEPENDS= libenchant.so:textproc/enchant \
libsecret-1.so:security/libsecret \
libicutu.so:devel/icu \
libharfbuzz.so:print/harfbuzz \
+ libpng16.so:graphics/png \
libwebp.so:graphics/webp \
libcurl.so:ftp/curl \
- libsoup-2.4.so:devel/libsoup
+ libsoup-2.4.so:devel/libsoup \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgstbase-1.0.so:multimedia/gstreamer1 \
+ libgstreamer-1.0.so:multimedia/gstreamer1
RUN_DEPENDS= geoclue>=0:net/geoclue
PORTSCOUT= limit:^2\.4\.
USE_GSTREAMER1= yes
-USE_XORG= xt xdamage xcomposite
-USES= bison compiler:c++11-lib gettext gmake gperf libtool localbase \
- pathfix perl5 pkgconfig shebangfix sqlite tar:xz
+USE_XORG= x11 xcomposite xdamage xfixes xrender xt
+USES= bison compiler:c++11-lib gettext gmake gperf jpeg libtool \
+ localbase pathfix perl5 pkgconfig shebangfix sqlite tar:xz
PATHFIX_MAKEFILEIN= GNUmakefile.in
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS=yes
-USE_GNOME= cairo gtk20 introspection:build libxslt
+USE_GNOME= cairo gdkpixbuf2 gtk20 introspection:build libxslt
USE_GL= gl
USE_PERL5= build
USE_LDCONFIG= yes
@@ -51,8 +56,6 @@ CONFIGURE_ARGS= --with-gtk=2.0 \
MAKEFILE= GNUmakefile
MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
-BROKEN_sparc64= attempts to use x86 assembler
-
CONFIGURE_ARGS+=--disable-egl \
--disable-gles2
SHEBANG_FILES= \
@@ -80,6 +83,11 @@ DEBUG_CONFIGURE_OFF= --disable-debug-symbols
.include <bsd.port.options.mk>
+.if ${ARCH} == powerpc64 || ${ARCH} == powerpc || ${ARCH} == sparc64
+CONFIGURE_ARGS+= --disable-jit
+CFLAGS+= -DENABLE_YARR_JIT=0
+.endif
+
.if ${ARCH} == powerpc64
CFLAGS+= -mminimal-toc
.endif
diff --git a/www/webkit-gtk2/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h b/www/webkit-gtk2/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h
index 94579033ef52..6a8622cadf2d 100644
--- a/www/webkit-gtk2/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h
+++ b/www/webkit-gtk2/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h
@@ -1,5 +1,5 @@
---- Source/JavaScriptCore/assembler/ARMAssembler.h.orig 2015-01-19 21:25:28.000000000 +0000
-+++ Source/JavaScriptCore/assembler/ARMAssembler.h 2015-01-19 21:25:57.000000000 +0000
+--- Source/JavaScriptCore/assembler/ARMAssembler.h.orig 2016-04-10 06:48:36 UTC
++++ Source/JavaScriptCore/assembler/ARMAssembler.h
@@ -1121,6 +1121,8 @@ namespace JSC {
linuxPageFlush(current, end);
#elif OS(WINCE)
diff --git a/www/webkit-gtk2/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp b/www/webkit-gtk2/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp
new file mode 100644
index 000000000000..3ad37978314d
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp
@@ -0,0 +1,11 @@
+--- Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.cpp.orig 2016-04-10 06:48:37 UTC
++++ Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.cpp
+@@ -403,7 +403,7 @@ TOSTRING(neonDrawLighting) ":" NL
+ "vmin.f32 " TMP2_D0 ", " TMP2_D0 ", " CONST_ONE_HI_D NL
+ "vmul.f32 " TMP3_Q ", " COLOR_Q ", " TMP2_D0 "[1]" NL
+ "vcvt.u32.f32 " TMP3_Q ", " TMP3_Q NL
+- "vmov.u32 r2, r3, " TMP3_S0 ", " TMP3_S1 NL
++ "vmov r2, r3, " TMP3_S0 ", " TMP3_S1 NL
+ // The color values are stored in-place.
+ "strb r2, [" PIXELS_R ", #-11]" NL
+ "strb r3, [" PIXELS_R ", #-10]" NL
diff --git a/www/webkit-gtk2/files/patch-Source_WebCore_plugins_PluginDatabase.cpp b/www/webkit-gtk2/files/patch-Source_WebCore_plugins_PluginDatabase.cpp
index 26508336a4fe..421649231529 100644
--- a/www/webkit-gtk2/files/patch-Source_WebCore_plugins_PluginDatabase.cpp
+++ b/www/webkit-gtk2/files/patch-Source_WebCore_plugins_PluginDatabase.cpp
@@ -1,6 +1,6 @@
---- Source/WebCore/plugins/PluginDatabase.cpp.orig 2011-01-11 16:24:29.000000000 +0000
-+++ Source/WebCore/plugins/PluginDatabase.cpp 2011-01-11 16:24:54.000000000 +0000
-@@ -375,6 +375,7 @@ Vector<String> PluginDatabase::defaultPl
+--- Source/WebCore/plugins/PluginDatabase.cpp.orig 2016-04-10 06:48:37 UTC
++++ Source/WebCore/plugins/PluginDatabase.cpp
+@@ -394,6 +394,7 @@ Vector<String> PluginDatabase::defaultPl
userPluginPath.append(String("/.netscape/plugins"));
paths.append(userPluginPath);