aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2012-01-26 20:18:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2012-01-26 20:18:32 +0000
commit61d3e676552ca52efea03e6970cffafd985b83a7 (patch)
treee0c37c203ce240297429c4a376edf965c2dabc82
parent630374295fc90f69f554f8b94d819e543aff030a (diff)
downloadports-61d3e676552ca52efea03e6970cffafd985b83a7.tar.gz
ports-61d3e676552ca52efea03e6970cffafd985b83a7.zip
Notes
-rw-r--r--devel/Makefile3
-rw-r--r--devel/pure-readline/Makefile23
-rw-r--r--devel/pure-readline/distinfo2
-rw-r--r--devel/pure-readline/pkg-descr5
-rw-r--r--devel/pure-stldict/Makefile24
-rw-r--r--devel/pure-stldict/distinfo2
-rw-r--r--devel/pure-stldict/files/patch-Makefile27
-rw-r--r--devel/pure-stldict/pkg-descr6
-rw-r--r--devel/pure-stldict/pkg-plist7
-rw-r--r--devel/pure-stlvec/Makefile25
-rw-r--r--devel/pure-stlvec/distinfo2
-rw-r--r--devel/pure-stlvec/pkg-descr5
-rw-r--r--devel/pure-stlvec/pkg-plist13
-rw-r--r--math/Makefile1
-rw-r--r--math/pure-mpfr/Makefile24
-rw-r--r--math/pure-mpfr/distinfo2
-rw-r--r--math/pure-mpfr/pkg-descr5
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/pure-tk/Makefile34
-rw-r--r--x11-toolkits/pure-tk/distinfo2
-rw-r--r--x11-toolkits/pure-tk/pkg-descr6
21 files changed, 219 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2b221af22e0b..ec1af372d86f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2987,6 +2987,9 @@
SUBDIR += publib
SUBDIR += pure-ffi
SUBDIR += pure-gen
+ SUBDIR += pure-readline
+ SUBDIR += pure-stldict
+ SUBDIR += pure-stlvec
SUBDIR += pushmi
SUBDIR += pwlib
SUBDIR += py-Acquisition
diff --git a/devel/pure-readline/Makefile b/devel/pure-readline/Makefile
new file mode 100644
index 000000000000..69751b2e3f77
--- /dev/null
+++ b/devel/pure-readline/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pure-readline
+# Date created: 2011-10-21
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-readline
+PORTVERSION= 0.1
+CATEGORIES= devel
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A readline interface for the Pure language
+
+USE_PURE= yes
+NO_PURE_EXAMPLES= yes
+
+PLIST_FILES= lib/pure/readline.pure \
+ lib/pure/readline.so
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pure-readline/distinfo b/devel/pure-readline/distinfo
new file mode 100644
index 000000000000..de300509dc8e
--- /dev/null
+++ b/devel/pure-readline/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-readline-0.1.tar.gz) = a8721d58d2d34c803967923a2ebd1b8f612abfe8d4ad75d6796bee5bbc3c45a2
+SIZE (pure/pure-readline-0.1.tar.gz) = 16358
diff --git a/devel/pure-readline/pkg-descr b/devel/pure-readline/pkg-descr
new file mode 100644
index 000000000000..49de9c8ef223
--- /dev/null
+++ b/devel/pure-readline/pkg-descr
@@ -0,0 +1,5 @@
+Pure's interface to C++ vectors, specialized to hold pointers to arbitrary
+Pure expressions, and the C++ Standard Template Library algorithms that act
+on them.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-readline.html
diff --git a/devel/pure-stldict/Makefile b/devel/pure-stldict/Makefile
new file mode 100644
index 000000000000..58b1a6d1005a
--- /dev/null
+++ b/devel/pure-stldict/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pure-stldict
+# Date created: 2011-12-05
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-stldict
+PORTVERSION= 0.3
+CATEGORIES= devel
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure interface to C++ STL map/unordered_map
+
+USE_PURE= yes
+
+USE_GCC= 4.6+
+CXX= g++${GCC_DEFAULT_V}
+CXXFLAGS+= -std=c++0x -DHAVE_STD_IS_PERMUTATION
+CXXFLAGS+= -DHAVE_STD_IS_PERMUTATION
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pure-stldict/distinfo b/devel/pure-stldict/distinfo
new file mode 100644
index 000000000000..30c52bacfd58
--- /dev/null
+++ b/devel/pure-stldict/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-stldict-0.3.tar.gz) = 86e3c1402e86c7c637d3191b94800121fda2724b0a5641a9f39becde0462567e
+SIZE (pure/pure-stldict-0.3.tar.gz) = 64546
diff --git a/devel/pure-stldict/files/patch-Makefile b/devel/pure-stldict/files/patch-Makefile
new file mode 100644
index 000000000000..2c2a86f2906e
--- /dev/null
+++ b/devel/pure-stldict/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig 2011-11-15 20:34:11.000000000 -0600
++++ Makefile 2011-12-05 23:59:07.886393453 -0600
+@@ -4,11 +4,11 @@ version = 0.1
+
+ # platform-specific setup
+
+-DLL = $(shell pkg-config pure --variable DLL)
+-PIC = $(shell pkg-config pure --variable PIC)
+-shared = $(shell pkg-config pure --variable shared)
++DLL = .so
++PIC = -fPIC
++shared = -shared
+
+-libdir = $(shell pkg-config pure --variable libdir)
++libdir = $(prefix)/lib
+ installdir = $(addprefix $(DESTDIR), $(libdir)/pure)
+
+ MOD_CXXFLAGS = $(PIC) $(shell pkg-config pure --cflags) $(CXXFLAGS) $(CPPFLAGS)
+@@ -25,7 +25,7 @@ objects = $(patsubst %.cc, %$(DLL), $(cp
+ all: $(objects)
+
+ %$(DLL): %.cc
+- g++ $(shared) -o $@ $(MOD_CXXFLAGS) $< $(MOD_LDFLAGS) $(LIBS)
++ $(CXX) $(shared) $(CPPFLAGS) $(CXXFLAGS) $(PIC) $< -o $@ $(LDFLAGS) -lpure $(LIBS)
+
+ clean:
+ rm -f *.o *$(DLL) examples/life *~
diff --git a/devel/pure-stldict/pkg-descr b/devel/pure-stldict/pkg-descr
new file mode 100644
index 000000000000..d481d4eee1b3
--- /dev/null
+++ b/devel/pure-stldict/pkg-descr
@@ -0,0 +1,6 @@
+This package provides a light-weight, no frills interface to the C++
+dictionary containers map and unordered_map. The stldict module makes
+these data structures available in Pure land and equips them with a
+(more or less) idiomatic Pure container interface.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-stldict.html
diff --git a/devel/pure-stldict/pkg-plist b/devel/pure-stldict/pkg-plist
new file mode 100644
index 000000000000..e20934799952
--- /dev/null
+++ b/devel/pure-stldict/pkg-plist
@@ -0,0 +1,7 @@
+lib/pure/hashdict.pure
+lib/pure/hashdict.so
+lib/pure/orddict.pure
+lib/pure/orddict.so
+lib/pure/stldict.pure
+lib/pure/stldictbase.pure
+@dirrm lib/pure
diff --git a/devel/pure-stlvec/Makefile b/devel/pure-stlvec/Makefile
new file mode 100644
index 000000000000..3172d3c5c07a
--- /dev/null
+++ b/devel/pure-stlvec/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pure-stlvec
+# Date created: 2011-10-19
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-stlvec
+PORTVERSION= 0.2
+CATEGORIES= devel
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure interface to C++ STL vector
+
+USE_PURE= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^PROD_FLAGS =.*|PROD_FLAGS = $$(CPPFLAGS) $$(CFLAGS) $$(LDFLAGS)|' \
+ ${WRKSRC}/Makefile
+
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pure-stlvec/distinfo b/devel/pure-stlvec/distinfo
new file mode 100644
index 000000000000..8f6520feba7c
--- /dev/null
+++ b/devel/pure-stlvec/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-stlvec-0.2.tar.gz) = 503bbc04f014c073d27d0bf2de3b57a889b5ceb9e01c4afbd82e8e5b5a2e4178
+SIZE (pure/pure-stlvec-0.2.tar.gz) = 149369
diff --git a/devel/pure-stlvec/pkg-descr b/devel/pure-stlvec/pkg-descr
new file mode 100644
index 000000000000..ceb59943320d
--- /dev/null
+++ b/devel/pure-stlvec/pkg-descr
@@ -0,0 +1,5 @@
+Pure's interface to C++ vectors, specialized to hold pointers to arbitrary
+Pure expressions, and the C++ Standard Template Library algorithms that act
+on them.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-stlvec.html
diff --git a/devel/pure-stlvec/pkg-plist b/devel/pure-stlvec/pkg-plist
new file mode 100644
index 000000000000..81c3136d5516
--- /dev/null
+++ b/devel/pure-stlvec/pkg-plist
@@ -0,0 +1,13 @@
+lib/pure/stlalgorithm.so
+lib/pure/stlbase.pure
+lib/pure/stlcontainer.so
+lib/pure/stlvec.pure
+lib/pure/stlvec/algorithms.pure
+lib/pure/stlvec/heap.pure
+lib/pure/stlvec/merge.pure
+lib/pure/stlvec/minmax.pure
+lib/pure/stlvec/modifying.pure
+lib/pure/stlvec/nonmodifying.pure
+lib/pure/stlvec/numeric.pure
+lib/pure/stlvec/sort.pure
+@dirrm lib/pure/stlvec
diff --git a/math/Makefile b/math/Makefile
index 032f476826f6..c1f6b877a0d6 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -489,6 +489,7 @@
SUBDIR += prng
SUBDIR += proofgeneral
SUBDIR += pspp
+ SUBDIR += pure-mpfr
SUBDIR += pure-rational
SUBDIR += py-apgl
SUBDIR += py-basemap
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
new file mode 100644
index 000000000000..a2979b844843
--- /dev/null
+++ b/math/pure-mpfr/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pure-mpfr
+# Date created: 2011-10-19
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-mpfr
+PORTVERSION= 0.4
+CATEGORIES= math
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Multiprecision floats for Pure
+
+USE_PURE= yes
+
+PLIST_FILES= lib/pure/mpfr.pure \
+ lib/pure/mpfr.so
+
+MAKE_ARGS+= libdir="${PREFIX}/lib"
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>
diff --git a/math/pure-mpfr/distinfo b/math/pure-mpfr/distinfo
new file mode 100644
index 000000000000..cb3f0d1be592
--- /dev/null
+++ b/math/pure-mpfr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-mpfr-0.4.tar.gz) = 23797d9996d4395aa08eadcb6ce3313267a24e9bc3bf7faa6012dcce339b65d6
+SIZE (pure/pure-mpfr-0.4.tar.gz) = 24401
diff --git a/math/pure-mpfr/pkg-descr b/math/pure-mpfr/pkg-descr
new file mode 100644
index 000000000000..ba226da0803b
--- /dev/null
+++ b/math/pure-mpfr/pkg-descr
@@ -0,0 +1,5 @@
+pure-mpfr makes the MPFR multiprecision floats (henceforth referred to as
+mpfr numbers or values) available in Pure, so that they work with the other
+types of Pure numbers in an almost seamless fashion.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-mpfr.html
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index f0a6b6a029ab..76c669db5a6e 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -191,6 +191,7 @@
SUBDIR += phat
SUBDIR += plib
SUBDIR += pure-gtk
+ SUBDIR += pure-tk
SUBDIR += py-Pmw
SUBDIR += py-SciParam
SUBDIR += py-fltk
diff --git a/x11-toolkits/pure-tk/Makefile b/x11-toolkits/pure-tk/Makefile
new file mode 100644
index 000000000000..e4057772e76e
--- /dev/null
+++ b/x11-toolkits/pure-tk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pure-tk
+# Date created: 2011-11-09
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-tk
+PORTVERSION= 0.3
+CATEGORIES= x11-toolkits
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A basic interface between Pure and Tcl/Tk
+
+USE_PURE= yes
+USE_TK= 82+
+SHORT_TCL_VER= ${TCL_VER:S/8./8/}
+
+MAKE_ARGS+= tclvers=${TCL_VER}
+
+PLIST_FILES= lib/pure/gnocl.pure \
+ lib/pure/tk.so \
+ lib/pure/tk.pure
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "s|/usr/include|${LOCALBASE}/include|g" \
+ -e "s|-ltcl\$$(tclvers)|-ltcl${SHORT_TCL_VER}|" \
+ -e "s|-ltk\$$(tclvers)|-ltk${SHORT_TCL_VER}|" \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/pure-tk/distinfo b/x11-toolkits/pure-tk/distinfo
new file mode 100644
index 000000000000..01f91dd47678
--- /dev/null
+++ b/x11-toolkits/pure-tk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-tk-0.3.tar.gz) = a1807441b4784b590b1fcd287d7750b66dd68f9e91bcddf710ccb3a4e9506a32
+SIZE (pure/pure-tk-0.3.tar.gz) = 31547
diff --git a/x11-toolkits/pure-tk/pkg-descr b/x11-toolkits/pure-tk/pkg-descr
new file mode 100644
index 000000000000..5380da967a27
--- /dev/null
+++ b/x11-toolkits/pure-tk/pkg-descr
@@ -0,0 +1,6 @@
+pure-tk provides a basic interface between Pure and Tcl/Tk. The
+operations of this module allow you to execute arbitrary commands
+in the Tcl interpreter, set and retrieve variable values in the
+interpreter, and invoke Pure callbacks from Tcl/Tk.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-tk.html