aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-30 17:08:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-30 17:08:09 +0000
commit19f52c082821b172205ce2669ef8d3a3adb881ba (patch)
treed58a4e494ff1213fb32ca159ff4da29a80e528a3
parent31fb5adc1991259096cb730b183b4db581bde702 (diff)
downloadports-19f52c082821b172205ce2669ef8d3a3adb881ba.tar.gz
ports-19f52c082821b172205ce2669ef8d3a3adb881ba.zip
Revert "net/openmpi: Remove dependency"
This reverts commit 9f2583dd1a5db69e3291bf72cff7ec5e4e48fdb2. torque is required by openmpi. Reported by: thierry
-rw-r--r--net/openmpi/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index ac5aba976934..767f8d701dce 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -54,7 +54,7 @@ MANPREFIX= ${PREFIX}/${MPIDIR}
SHEBANG_FILES= ompi/mca/common/monitoring/profile2mat.pl \
ompi/mca/common/monitoring/aggregate_profile.pl
-OPTIONS_DEFINE= AVX DEBUG IPV6 SLURM
+OPTIONS_DEFINE= AVX DEBUG IPV6 SLURM TORQUE
OPTIONS_DEFAULT= SLURM
OPTIONS_EXCLUDE_aarch64= AVX
OPTIONS_EXCLUDE_armv6= AVX SLURM
@@ -70,6 +70,7 @@ OPTIONS_SUB= yes
AVX_DESC= Enable AVX instructions
SLURM_DESC= Enable SLURM support
+TORQUE_DESC= Enable Torque support
AVX_CONFIGURE_OFF= --enable-mca-no-build=op-avx
@@ -78,6 +79,17 @@ DEBUG_INSTALL_TARGET_OFF= install-strip
IPV6_CONFIGURE_ENABLE= ipv6
+TORQUE_CONFIGURE_WITH= tm
+TORQUE_LIB_DEPENDS= libtorque.so:sysutils/torque
+TORQUE_PLIST_FILES= ${MPIDIR}/lib/openmpi/mca_plm_tm.so \
+ ${MPIDIR}/lib/openmpi/mca_plm_tm.la \
+ ${MPIDIR}/lib/openmpi/mca_ras_tm.la \
+ ${MPIDIR}/lib/openmpi/mca_ras_tm.so \
+ ${MPIDIR}/lib/openmpi/mca_ess_tm.so \
+ ${MPIDIR}/lib/openmpi/mca_ess_tm.la \
+ ${MPIDIR}/share/openmpi/help-plm-tm.txt \
+ ${MPIDIR}/share/openmpi/help-ras-tm.txt
+
SLURM_CONFIGURE_WITH= slurm
SLURM_LIB_DEPENDS= libslurm.so:sysutils/slurm-wlm
SLURM_PLIST_FILES= ${MPIDIR}/lib/openmpi/mca_ess_slurm.la \