aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-12-30 15:20:33 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-12-30 15:22:37 +0000
commit2073b5313422a30cb3c294e113d375ee926da508 (patch)
tree4a3b2a36aa5adeb506e4ff3ec65ab8ec6ec8f98f
parentfbdd09cb63723ef7662c944f78b1ab9fe88d4f1c (diff)
downloadports-2073b5313422a30cb3c294e113d375ee926da508.tar.gz
ports-2073b5313422a30cb3c294e113d375ee926da508.zip
games/scummvm: Update to 2.8.0
* Add new default option MIKMOD, which adds support for Impulse Tracker audio files that are used by some games of the "ags" engine. * Introduce the non-default options SONIVOX and VPX as well. The latter one adds movie support for the "sludge" engine which is still considered as unstable and therefore not built by default. * Add a workaround make the "xeen" engine, which could be built by default since release 2.5.0, still available and remove a no longer required patch for the "hpl" engine. Changelog: https://downloads.scummvm.org/frs/scummvm/2.8.0/ReleaseNotes.html MFH: No (feature release)
-rw-r--r--games/scummvm/Makefile21
-rw-r--r--games/scummvm/distinfo6
-rw-r--r--games/scummvm/files/patch-engines_hpl1_engine_libraries_newton_core_dgPolyhedra.cpp40
-rw-r--r--games/scummvm/files/patch-engines_mm_configure.engine21
-rw-r--r--games/scummvm/pkg-plist23
5 files changed, 58 insertions, 53 deletions
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index 16c0de015e09..86895efa5db6 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -1,5 +1,5 @@
PORTNAME= scummvm
-PORTVERSION= 2.7.1
+PORTVERSION= 2.8.0
CATEGORIES= games emulators
MASTER_SITES= https://downloads.scummvm.org/frs/${PORTNAME}/${PORTVERSION}/
@@ -38,12 +38,13 @@ CONFIGURE_ARGS= --disable-alsa \
LDFLAGS+= -lpthread
-OPTIONS_DEFINE= CURL DOCS FLAC GIF FLUIDSYNTH MT32EMU SNDIO TTS XENGINES
-OPTIONS_DEFAULT= GIF MT32EMU
+OPTIONS_DEFINE= CURL DOCS FLAC GIF FLUIDSYNTH MIKMOD MT32EMU SNDIO SONIVOX TTS VPX XENGINES
+OPTIONS_DEFAULT= GIF MIKMOD MT32EMU
OPTIONS_SUB= yes
CURL_DESC= Enable ScummVM cloud storage backend
MT32EMU_DESC= MT-32 emulator
+SONIVOX_DESC= Sonivox EAS (Embedded Audio Synthesis) sound driver
TTS_DESC= Text-to-Speech support
XENGINES_DESC= Experimental/Unstable engine support
@@ -59,15 +60,27 @@ FLUIDSYNTH_CONFIGURE_OFF= --disable-fluidsynth
GIF_LIB_DEPENDS= libgif.so:graphics/giflib
GIF_CONFIGURE_OFF= --disable-gif
+MIKMOD_LIB_DEPENDS= libmikmod.so:audio/libmikmod
+MIKMOD_CONFIGURE_ON= --enable-mikmod
+MIKMOD_CONFIGURE_OFF= --disable-mikmod
+
MT32EMU_CONFIGURE_OFF= --disable-mt32emu
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
SNDIO_CONFIGURE_OFF= --disable-sndio
+SONIVOX_LIB_DEPENDS= libsonivox.so:audio/sonivox
+SONIVOX_CONFIGURE_ON= --enable-sonivox
+SONIVOX_CONFIGURE_OFF= --disable-sonivox
+
TTS_LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher
TTS_CONFIGURE_ON= --enable-tts
TTS_CONFIGURE_OFF= --disable-tts
+VPX_LIB_DEPENDS= libvpx.so:multimedia/libvpx
+VPX_CONFIGURE_ON= --enable-vpx
+VPX_CONFIGURE_OFF= --disable-vpx
+
XENGINES_CONFIGURE_ON= --enable-all-engines
XENGINES_CONFIGURE_OFF= --disable-all-unstable-engines
@@ -78,8 +91,6 @@ CONFIGURE_ENV+= ASFLAGS=-meabi=5
.endif
post-install:
- ${INSTALL_DATA} ${WRKSRC}/dists/${PORTNAME}.desktop \
- ${STAGEDIR}${DESKTOPDIR}
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.post.mk>
diff --git a/games/scummvm/distinfo b/games/scummvm/distinfo
index ac6b3357d625..57afb2f68261 100644
--- a/games/scummvm/distinfo
+++ b/games/scummvm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1690186365
-SHA256 (scummvm-2.7.1.tar.xz) = d6bbf62e33154759a609d59f3034d71652ecdb64ed5c800156718ab1f1d5d063
-SIZE (scummvm-2.7.1.tar.xz) = 148127416
+TIMESTAMP = 1702826565
+SHA256 (scummvm-2.8.0.tar.xz) = d6e9fbee06a924706635dea225dfd560ff6770f35aa99d59570a3eb883795a72
+SIZE (scummvm-2.8.0.tar.xz) = 207362400
diff --git a/games/scummvm/files/patch-engines_hpl1_engine_libraries_newton_core_dgPolyhedra.cpp b/games/scummvm/files/patch-engines_hpl1_engine_libraries_newton_core_dgPolyhedra.cpp
deleted file mode 100644
index c31a549376f6..000000000000
--- a/games/scummvm/files/patch-engines_hpl1_engine_libraries_newton_core_dgPolyhedra.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
-The HPL1 engine seems to be still under heavy development so this is
-rather a workaround to fix the build on x64 platforms with Clang which
-is very strict regarding pointer conversions to smaller types.
-
-Amend this issue after brief consultation with upstream by using
-`PointerToInt(NULL)` instead of `dgUnsigned32(NULL)`.
-
-Obtained from:
-
-https://github.com/scummvm/scummvm/commit/5304df12f1232ddcfa33fcffed1cd5fb4ad01275
-
---- engines/hpl1/engine/libraries/newton/core/dgPolyhedra.cpp.orig 2023-02-13 22:19:11 UTC
-+++ engines/hpl1/engine/libraries/newton/core/dgPolyhedra.cpp
-@@ -2714,7 +2714,7 @@ void dgPolyhedra::Optimize(const dgFloat64 *const arra
- if (handle) {
- handle->m_edge = NULL;
- }
-- ptr->m_userData = dgUnsigned32(NULL);
-+ ptr->m_userData = PointerToInt(NULL);
-
- }
-
-@@ -2753,7 +2753,7 @@ void dgPolyhedra::Optimize(const dgFloat64 *const arra
- if (handle) {
- handle->m_edge = NULL;
- }
-- ptr1->m_userData = dgUnsigned32(NULL);
-+ ptr1->m_userData = PointerToInt(NULL);
-
- }
- }
-@@ -2780,7 +2780,7 @@ void dgPolyhedra::Optimize(const dgFloat64 *const arra
- if (handle) {
- handle->m_edge = NULL;
- }
-- ptr1->m_twin->m_userData = dgUnsigned32(NULL);
-+ ptr1->m_twin->m_userData = PointerToInt(NULL);
-
- }
- }
diff --git a/games/scummvm/files/patch-engines_mm_configure.engine b/games/scummvm/files/patch-engines_mm_configure.engine
new file mode 100644
index 000000000000..207b407f5848
--- /dev/null
+++ b/games/scummvm/files/patch-engines_mm_configure.engine
@@ -0,0 +1,21 @@
+The "xeen" engine was originally created as a main engine and was built by
+default with the 2.5.0 release.
+
+The aforementioned engine has been moved as a sub-engine with the 2.8.0 release
+to the new main engine "mm", which is currently not being built by default for
+some reasons.
+
+Expose the "xeen" engine again, together with the new sub-engine "mm1", to
+avoid surprises, e.g. games that have already been configured can no longer be
+loaded with its savegames, for users that use the official FreeBSD
+pkg repositories.
+
+--- engines/mm/configure.engine.orig 2023-12-29 16:43:55 UTC
++++ engines/mm/configure.engine
+@@ -1,5 +1,5 @@
+ # This file is included from the main "configure" script
+ # add_engine [name] [desc] [build-by-default] [subengines] [base games] [deps]
+-add_engine mm "Might and Magic" no "mm1 xeen"
++add_engine mm "Might and Magic" yes "mm1 xeen"
+ add_engine mm1 "Might and Magic 1" yes
+ add_engine xeen "Might and Magic Xeen" yes
diff --git a/games/scummvm/pkg-plist b/games/scummvm/pkg-plist
index bfac4185c75c..0c5c535aa285 100644
--- a/games/scummvm/pkg-plist
+++ b/games/scummvm/pkg-plist
@@ -1,5 +1,5 @@
bin/scummvm
-share/applications/scummvm.desktop
+share/applications/org.scummvm.scummvm.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTING.md
%%PORTDOCS%%%%DOCSDIR%%/COPYING
@@ -10,15 +10,19 @@ share/applications/scummvm.desktop
%%PORTDOCS%%%%DOCSDIR%%/COPYING.LGPL
%%PORTDOCS%%%%DOCSDIR%%/COPYING.LUA
%%PORTDOCS%%%%DOCSDIR%%/COPYING.MIT
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.MKV
%%PORTDOCS%%%%DOCSDIR%%/COPYING.OFL
%%PORTDOCS%%%%DOCSDIR%%/COPYING.TINYGL
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%XENGINES%%%%DOCSDIR%%/COPYRIGHT.Roland_SC-55
+%%PORTDOCS%%%%DOCSDIR%%/CatharonLicense.txt
%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
%%PORTDOCS%%%%DOCSDIR%%/README.md
-share/icons/hicolor/scalable/apps/scummvm.svg
+share/icons/hicolor/scalable/apps/org.scummvm.scummvm.svg
share/man/man6/scummvm.6.gz
-share/metainfo/scummvm.appdata.xml
-share/pixmaps/scummvm.xpm
+share/metainfo/org.scummvm.scummvm.metainfo.xml
+share/pixmaps/org.scummvm.scummvm.xpm
+%%XENGINES%%%%DATADIR%%/Roland_SC-55.sf2
%%DATADIR%%/access.dat
%%DATADIR%%/achievements.dat
%%DATADIR%%/classicmacfonts.dat
@@ -26,21 +30,26 @@ share/pixmaps/scummvm.xpm
%%DATADIR%%/cryomni3d.dat
%%DATADIR%%/drascula.dat
%%DATADIR%%/encoding.dat
+%%DATADIR%%/fonts-cjk.dat
%%DATADIR%%/fonts.dat
%%DATADIR%%/freescape.dat
%%DATADIR%%/grim-patch.lab
%%DATADIR%%/gui-icons.dat
%%XENGINES%%%%DATADIR%%/hadesch_translations.dat
+%%DATADIR%%/helpdialog.zip
%%DATADIR%%/hugo.dat
%%DATADIR%%/kyra.dat
%%DATADIR%%/lure.dat
%%DATADIR%%/macgui.dat
%%XENGINES%%%%DATADIR%%/macventure.dat
+%%DATADIR%%/mm.dat
%%XENGINES%%%%DATADIR%%/monkey4-patch.m4b
%%DATADIR%%/mort.dat
%%DATADIR%%/myst3.dat
+%%DATADIR%%/nancy.dat
%%DATADIR%%/neverhood.dat
%%DATADIR%%/pred.dic
+%%DATADIR%%/prince_translation.dat
%%DATADIR%%/queen.tbl
%%DATADIR%%/residualvm.zip
%%DATADIR%%/scummclassic.zip
@@ -148,6 +157,8 @@ share/pixmaps/scummvm.xpm
%%XENGINES%%%%DATADIR%%/shaders/hpl1_Water_Diffuse.vertex
%%XENGINES%%%%DATADIR%%/shaders/hpl1_Water_Fog.fragment
%%XENGINES%%%%DATADIR%%/shaders/hpl1_Water_Fog.vertex
+%%XENGINES%%%%DATADIR%%/shaders/hpl1_gamma_correction.fragment
+%%XENGINES%%%%DATADIR%%/shaders/hpl1_gamma_correction.vertex
%%XENGINES%%%%DATADIR%%/shaders/hpl1_refract.fragment
%%XENGINES%%%%DATADIR%%/shaders/hpl1_refract.vertex
%%XENGINES%%%%DATADIR%%/shaders/hpl1_refract_special.fragment
@@ -175,6 +186,8 @@ share/pixmaps/scummvm.xpm
%%DATADIR%%/shaders/stark_shadow.vertex
%%DATADIR%%/shaders/stark_surface.fragment
%%DATADIR%%/shaders/stark_surface.vertex
+%%DATADIR%%/shaders/stark_surface_fill.fragment
+%%DATADIR%%/shaders/stark_surface_fill.vertex
%%DATADIR%%/shaders/wme_fade.fragment
%%DATADIR%%/shaders/wme_fade.vertex
%%DATADIR%%/shaders/wme_flat_shadow_mask.fragment
@@ -201,5 +214,5 @@ share/pixmaps/scummvm.xpm
%%DATADIR%%/toon.dat
%%DATADIR%%/translations.dat
%%DATADIR%%/ultima.dat
+%%DATADIR%%/ultima8.dat
%%DATADIR%%/wintermute.zip
-%%DATADIR%%/xeen.ccs