aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-03-12 07:06:57 +0000
committerRene Ladan <rene@FreeBSD.org>2014-03-12 07:06:57 +0000
commite396093a9b2f29d1b0355fd90339fd480f7d4200 (patch)
treede0cca12ddef6a4fa4a4dac8054b130ebab025df
parent2697948bef110a0c27212ce2e546be49c4b6b1b7 (diff)
downloadports-e396093a9b2f29d1b0355fd90339fd480f7d4200.tar.gz
ports-e396093a9b2f29d1b0355fd90339fd480f7d4200.zip
MFH: r347937
- Update to 33.0.1750.149 [1] - Add a patch to fix build on FreeBSD < 10 [2] Obtained from: http://crbug.com/347123 [2] Security: http://vuxml.org/freebsd/24cefa4b-a940-11e3-91f2-00262d5ed8ee.html [1] Approved by: portmgr (erwin)
Notes
Notes: svn path=/branches/2014Q1/; revision=347962
-rw-r--r--www/chromium/Makefile3
-rw-r--r--www/chromium/distinfo8
-rw-r--r--www/chromium/files/patch-base__strings__safe_sprintf.cc19
3 files changed, 24 insertions, 6 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index e092e986e356..1f826c6bafd6 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -4,8 +4,7 @@
#TODO eadler: s/python/python2/g on a number of files, chromium does not build with python3
PORTNAME= chromium
-PORTVERSION= 33.0.1750.146
-PORTREVISION= 1
+PORTVERSION= 33.0.1750.149
CATEGORIES= www
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index cfeda3cb6e50..789657759991 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,4 +1,4 @@
-SHA256 (chromium-33.0.1750.146.tar.xz) = d5b0e7a0f086aac200493fe4e5849ca84e9e21f7770c5d5830060da9fc2c4a74
-SIZE (chromium-33.0.1750.146.tar.xz) = 185394896
-SHA256 (chromium-33.0.1750.146-testdata.tar.xz) = 918ccc080788ea9b8eba2e479b521c22b37b14c62d4bc0906d7f15a88f12c84c
-SIZE (chromium-33.0.1750.146-testdata.tar.xz) = 112429020
+SHA256 (chromium-33.0.1750.149.tar.xz) = 165f6d3dd4cf936faf615f743baf2e668a259f970ceed654d2f73b390dad3084
+SIZE (chromium-33.0.1750.149.tar.xz) = 185397612
+SHA256 (chromium-33.0.1750.149-testdata.tar.xz) = f18a5f3199f2e370ffdc1e49b2860e3653341c64d30c7e42268835cde7458354
+SIZE (chromium-33.0.1750.149-testdata.tar.xz) = 112422500
diff --git a/www/chromium/files/patch-base__strings__safe_sprintf.cc b/www/chromium/files/patch-base__strings__safe_sprintf.cc
new file mode 100644
index 000000000000..023027f05962
--- /dev/null
+++ b/www/chromium/files/patch-base__strings__safe_sprintf.cc
@@ -0,0 +1,19 @@
+--- ./base/strings/safe_sprintf.cc.orig 2014-03-04 03:16:26.000000000 +0100
++++ ./base/strings/safe_sprintf.cc 2014-03-07 14:14:55.000000000 +0100
+@@ -107,11 +107,11 @@
+ : buffer_(buffer),
+ size_(size - 1), // Account for trailing NUL byte
+ count_(0) {
+-// The following assertion does not build on Mac and Android. This is because
+-// static_assert only works with compile-time constants, but mac uses
+-// libstdc++4.2 and android uses stlport, which both don't mark
+-// numeric_limits::max() as constexp.
+-#if __cplusplus >= 201103 && !defined(OS_ANDROID) && !defined(OS_MACOSX) && !defined(OS_IOS)
++// The following assertion does not build on Mac and Android and older FreeBSD.
++// This is because static_assert only works with compile-time constants, but
++// mac and FreeBSD < 10 use libstdc++4.2 and android uses stlport, which both
++// don't mark numeric_limits::max() as constexp.
++#if __cplusplus >= 201103 && !defined(OS_ANDROID) && !defined(OS_MACOSX) && !defined(OS_IOS) && !(defined(OS_FREEBSD) && __FreeBSD_version > 1000054)
+ COMPILE_ASSERT(kSSizeMaxConst == \
+ static_cast<size_t>(std::numeric_limits<ssize_t>::max()),
+ kSSizeMax_is_the_max_value_of_an_ssize_t);