aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-07 13:57:17 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-07 13:57:17 +0000
commit37d3ffbf6940adeff5412bdc93e908ef840e91f5 (patch)
tree2c1f43d84f302215257e328eba30d2d22a92cdac
parent404a096bf7c6c5b6b9dd96c89c2bcaebe5fcf38f (diff)
downloadports-37d3ffbf6940adeff5412bdc93e908ef840e91f5.tar.gz
ports-37d3ffbf6940adeff5412bdc93e908ef840e91f5.zip
MFH: r356888
Add explicit dependency on qt4-gui. For some reason, PyQt's configure.py adds a dependency on QtGui when figuring out if QtSql is installed. When the API option is on, this dependency is always installed indirectly, but things fail if it is turned off. From configure's build log: Checking to see if the QtSql module should be built... c++ -DQT_NO_DEBUG -DQT_SQL_LIB -I. -I/usr/local/share/qt4/mkspecs/default -I/usr/local/include/qt4/QtSql -I/usr/local/include/qt4/QtGui -I/usr/local/include/qt4 -I/usr/local/include -O2 -pipe -fno-strict-aliasing -O2 -w -pthread -D_THREAD_SAFE cfgtest_QtSql.cpp -o cfgtest_QtSql -L/usr/local/lib/qt4 -L/usr/local/lib -Wl,-O1 -Wl,-rpath,/usr/local/lib/qt4 -lQtSql -L/usr/local/lib/qt4 -L/usr/local/lib/qt4 -L/usr/local/lib -lQtCore -L/usr/local/lib/qt4 -L/usr/local/lib/qt4 -L/usr/local/lib -lQtGui -lXext -lX11 -lm /usr/bin/ld: cannot find -lQtGui c++: error: linker command failed with exit code 1 (use -v to see invocation) PR: 183706 Approved by: portmgr (miwi)
Notes
Notes: svn path=/branches/2014Q2/; revision=356902
-rw-r--r--databases/py-qt4-sql/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/py-qt4-sql/Makefile b/databases/py-qt4-sql/Makefile
index fb9eab92c406..ebd4d2b529af 100644
--- a/databases/py-qt4-sql/Makefile
+++ b/databases/py-qt4-sql/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sql
PORTVERSION= ${PYQT4_VERSION}
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases devel python
MASTER_SITES= ${MASTER_SITES_PYQT4}
@@ -18,7 +19,7 @@ RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-q
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
HAS_CONFIGURE= yes
USE_PYTHON= yes
-USE_QT4= moc_build sql qmake_build
+USE_QT4= moc_build gui sql qmake_build
OPTIONS_DEFINE= API
OPTIONS_DEFAULT=API