aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-08-11 20:32:56 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-08-11 20:32:56 +0000
commit513a31be862bd8e830c7958af4306779b31468ad (patch)
treebe0d9a4a94388b06d89d7592df27b4e6fe0c8f7f
parentc9d4f6c79cad87f1c4128d34247f9fdcfe802d3c (diff)
downloadports-513a31be862bd8e830c7958af4306779b31468ad.tar.gz
ports-513a31be862bd8e830c7958af4306779b31468ad.zip
MFH: r364481
- adjust default modules, changed during the last revisions + SESSION_DBD + SLOTMEM_SHM (e.g neeed for mod_ajp) - CERN_META - Use OPTION desc. from modules/config.m4 to match upstream - bump PORTREVISION with hat apache@ Approved by: portmgr (mat@)
Notes
Notes: svn path=/branches/2014Q3/; revision=364660
-rw-r--r--www/apache24/Makefile5
-rw-r--r--www/apache24/Makefile.options13
-rw-r--r--www/apache24/Makefile.options.desc28
3 files changed, 23 insertions, 23 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index 75df28cef55b..d169ca202df9 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -2,6 +2,7 @@
PORTNAME= apache24
PORTVERSION= 2.4.10
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -150,10 +151,10 @@ post-configure:
post-install:
@${MKDIR} ${ETC_SUBDIRS:S|^|${STAGEDIR}${ETCDIR}/|}
${INSTALL_DATA} ${FILESDIR}/no-accf.conf ${STAGEDIR}${ETCDIR}/Includes/
- ${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}/${ETCDIR}/modules.d/
+ ${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}${ETCDIR}/modules.d/
# place for module configuration samples
@${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}/modules.d
- ${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}/${EXAMPLESDIR}/modules.d
+ ${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}${EXAMPLESDIR}/modules.d
# suppress warning for non binary files
-@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/* \
diff --git a/www/apache24/Makefile.options b/www/apache24/Makefile.options
index dac2995e6959..95e9b5f029e6 100644
--- a/www/apache24/Makefile.options
+++ b/www/apache24/Makefile.options
@@ -18,10 +18,9 @@ PROXY_DISABLED_MODULES= \
# SESSION_CRYPTO need APR build with crypto (EVP support in APR)
SESSION_ENABLED_MODULES= \
- SESSION_COOKIE SESSION_CRYPTO
+ SESSION_COOKIE SESSION_CRYPTO SESSION_DBD
-SESSION_DISABLED_MODULES= \
- SESSION_DBD
+SESSION_DISABLED_MODULES=
HEARTBEAT_MODULES= \
HEARTBEAT HEARTMONITOR LBMETHOD_HEARTBEAT
@@ -40,7 +39,7 @@ MOST_ENABLED_MODULES= \
AUTHZ_OWNER AUTHZ_USER \
AUTH_BASIC AUTH_DIGEST AUTH_FORM AUTOINDEX \
BUFFER \
- CACHE CACHE_DISK CACHE_SOCACHE CERN_META CGI CGID \
+ CACHE CACHE_DISK CACHE_SOCACHE CGI CGID \
DAV DAV_FS DBD DEFLATE DIR DUMPIO \
ENV EXPIRES EXT_FILTER \
FILE_CACHE FILTER \
@@ -51,14 +50,14 @@ MOST_ENABLED_MODULES= \
MACRO MIME MIME_MAGIC \
NEGOTIATION \
RATELIMIT REMOTEIP REQTIMEOUT REQUEST REWRITE \
- SED SETENVIF SOCACHE_DBM SOCACHE_MEMCACHE SOCACHE_SHMCB SPELING \
+ SED SETENVIF SLOTMEM_SHM SOCACHE_DBM SOCACHE_MEMCACHE SOCACHE_SHMCB SPELING \
SSL STATUS SUBSTITUTE \
UNIQUE_ID USERDIR \
VERSION VHOST_ALIAS
MOST_DISABLED_MODULES:= \
- AUTHNZ_LDAP AUTHNZ_FCGI LDAP CHARSET_LITE DATA DAV_LOCK DIALUP IDENT LOG_FORENSIC \
- LUA REFLECTOR SLOTMEM_PLAIN SLOTMEM_SHM SOCACHE_DC SUEXEC USERTRACK \
+ AUTHNZ_LDAP AUTHNZ_FCGI LDAP CERN_META CHARSET_LITE DATA DAV_LOCK DIALUP IDENT \
+ LOG_FORENSIC LUA REFLECTOR SLOTMEM_PLAIN SOCACHE_DC SUEXEC USERTRACK \
XML2ENC WATCHDOG ${HEARTBEAT_MODULES} ${EXAMPLE_MODULES} ${DEV_MODULES}
#MULTI_MODULES:= ${OPTIONS_MULTI}
diff --git a/www/apache24/Makefile.options.desc b/www/apache24/Makefile.options.desc
index aa6cd17dc941..63e603be9ea1 100644
--- a/www/apache24/Makefile.options.desc
+++ b/www/apache24/Makefile.options.desc
@@ -36,13 +36,13 @@ STATIC_SUPPORT_DESC= static linked support binaries
# =====================================
# modules
-# deprecated: ACCESS_COMPAT
-ACCESS_COMPAT_DESC= Old group authorizations based on host (name or IP), deprecated by mod_authz_host
+# DESC from modules/*/config.m4 files
+ACCESS_COMPAT_DESC= mod_access compatibility
ACTIONS_DESC= Action triggering on requests
ALIAS_DESC= Mapping of requests to different filesystem parts
-ALLOWMETHODS_DESC= Easily restrict what HTTP methods can be used on the server
+ALLOWMETHODS_DESC= Restrict allowed HTTP methods
ASIS_DESC= Sends files that contain their own HTTP headers
-AUTHNZ_FCGI_DESC= Allows a FastCGI authorizer to handle the check_authn hook
+AUTHNZ_FCGI_DESC= FastCGI authorizer-based authentication and authorization
AUTHNZ_LDAP_DESC= LDAP based authentication
AUTHN_ANON_DESC= Anonymous user authentication control
AUTHN_CORE_DESC= Core authentication module
@@ -53,21 +53,21 @@ AUTHN_SOCACHE_DESC= Cached authentication control
AUTHZ_CORE_DESC= Core authorization provider vector module
AUTHZ_DBD_DESC= SQL based authorization and Login/Session support
AUTHZ_DBM_DESC= DBM-based authorization control
-AUTHZ_GROUPFILE_DESC= Group authorization using plaintext files
+AUTHZ_GROUPFILE_DESC= "require group" authorization control
AUTHZ_HOST_DESC= Host-based authorization control
-AUTHZ_OWNER_DESC= Authorization based on file ownership
-AUTHZ_USER_DESC= User Authorization
+AUTHZ_OWNER_DESC= "require file-owner" authorization control
+AUTHZ_USER_DESC= "require user" authorization control
AUTH_BASIC_DESC= Basic authentication
AUTH_DIGEST_DESC= RFC2617 Digest authentication
AUTH_FORM_DESC= Form authentication
AUTOINDEX_DESC= Directory listing
-BUCKETEER_DESC= (dev) buckets manipulation filter, useful only for developers and testing purposes
+BUCKETEER_DESC= (dev) buckets manipulation filter
BUFFER_DESC= Filter Buffering
CACHE_DESC= Dynamic file caching
CACHE_DISK_DESC= Disk caching module
-CACHE_SOCACHE_DESC= Shared object cache (socache) based storage module for the HTTP caching filter
+CACHE_SOCACHE_DESC= Shared object cacheing module
CASE_FILTER_DESC= (dev) example uppercase conversion filter
CASE_FILTER_IN_DESC= (dev) example uppercase conversion input filter
CERN_META_DESC= CERN-type meta files
@@ -86,9 +86,9 @@ DIR_DESC= Directory request handling
DUMPIO_DESC= I/O dump filter
ECHO_DESC= (dev) example echo server
-ENV_DESC= Modifies environment passed to CGI/SSI pages
-EXAMPLE_HOOKS_DESC= (dev) example hook module
-EXAMPLE_IPC_DESC= (dev) example IPC module
+ENV_DESC= Clearing/setting of ENV vars
+EXAMPLE_HOOKS_DESC= (dev) example hook callback handler module
+EXAMPLE_IPC_DESC= (dev) Example of shared memory and mutex usage
EXPIRES_DESC= Expires header control
EXT_FILTER_DESC= External filter module
@@ -115,7 +115,7 @@ LOG_DEBUG_DESC= Configurable debug logging
LOG_FORENSIC_DESC= Forensic logging
LUA_DESC= Apache Lua Framework
-MACRO_DESC= Provides usage of macros within apache runtime configuration files
+MACRO_DESC= Define and use macros in configuration files
MIME_DESC= Mapp file-ext. to MIME (recommended)
MIME_MAGIC_DESC= Automagically determining MIME type
@@ -137,7 +137,7 @@ PROXY_FTP_DESC= FTP support module for mod_proxy
PROXY_HTML_DESC= Fix HTML Links in a Reverse Proxy
PROXY_HTTP_DESC= HTTP support module for mod_proxy
PROXY_SCGI_DESC= SCGI gateway module for mod_proxy
-PROXY_WSTUNNEL_DESC= Websockets support module for mod_proxy
+PROXY_WSTUNNEL_DESC= Websockets Tunnel module for mod_proxy
RATELIMIT_DESC= Output Bandwidth Limiting
REFLECTOR_DESC= Reflect request through the output filter stack