aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-08-03 12:43:09 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-08-03 12:43:09 +0000
commit964d95de78355bfda4dbd582b50b45a3c6ea85fa (patch)
treee6fef13ff101ba905dff8dfb6e9848bf5ac2d306
parent88c9ca45bf72f84b9cf420b5e1f7d977d1f2164a (diff)
downloadports-964d95de78355bfda4dbd582b50b45a3c6ea85fa.tar.gz
ports-964d95de78355bfda4dbd582b50b45a3c6ea85fa.zip
MFH: r363882
- Fix build with clang (needs to link with libX11) - Port is stage safe and uses GNU Configure Approved by: portmgr (antoine)
Notes
Notes: svn path=/branches/2014Q3/; revision=363892
-rw-r--r--sysutils/usbhotkey/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/usbhotkey/Makefile b/sysutils/usbhotkey/Makefile
index a4b850e0cc4a..942b21593464 100644
--- a/sysutils/usbhotkey/Makefile
+++ b/sysutils/usbhotkey/Makefile
@@ -16,12 +16,13 @@ LIB_DEPENDS= libhid.so:${PORTSDIR}/devel/libhid \
USES= gmake
USE_RUBY= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/ruby-${RUBY_VER} \
-I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -lX11
OPTIONS_DEFINE= GUI
OPTIONS_DEFAULT= GUI
@@ -30,5 +31,4 @@ GUI_DESC= Enable GUI bits (via Imlib)
GUI_LIB_DEPENDS= libImlib.so:${PORTSDIR}/graphics/imlib
GUI_CONFIGURE_OFF= --without-Imlib
-NO_STAGE= yes
.include <bsd.port.mk>