aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-09-16 20:44:12 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-09-16 20:44:12 +0000
commita13f63e7bfaf70a02e36ccb9ed3b3dfb32c36902 (patch)
treecb7c3b6c8e73c8b5db234f287d887688eb9b3ef0
parent25641a3641b741477d49840b1cda5af2a04e462c (diff)
downloadports-a13f63e7bfaf70a02e36ccb9ed3b3dfb32c36902.tar.gz
ports-a13f63e7bfaf70a02e36ccb9ed3b3dfb32c36902.zip
MFH r368345:
- Fix off-by-one with 'make checksum' which caused it to not properly download files from the last site (distcache). With hat: portmgr
Notes
Notes: svn path=/branches/2014Q3/; revision=368346
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 3b04e6de44bd..907463f551bc 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3399,7 +3399,7 @@ do-fetch:
continue 2; \
else \
${ECHO_MSG} "=> Fetched file size mismatch (expected $${CKSIZE}, actual $${actual_size})"; \
- if [ $${sites_remaining} -gt 1 ]; then \
+ if [ $${sites_remaining} -gt 0 ]; then \
${ECHO_MSG} "=> Trying next site"; \
${RM} -f $${file}; \
fi; \