aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-01-28 23:45:30 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-01-28 23:45:30 +0000
commit03174d91effd822a4d92b4f1faa0fa18199f72c5 (patch)
tree3247f76b005686db0773ea6e5de61f58c635c9a9
parentc5f8b8a8b92d151a181f4429ffd6f2f00c2232d6 (diff)
downloadports-03174d91effd822a4d92b4f1faa0fa18199f72c5.tar.gz
ports-03174d91effd822a4d92b4f1faa0fa18199f72c5.zip
Notes
-rw-r--r--devel/p5-Data-Structure-Util/Makefile3
-rw-r--r--devel/p5-Devel-Leak-Object/Makefile3
-rw-r--r--devel/p5-Devel-LeakGuard-Object/Makefile4
-rw-r--r--devel/p5-Devel-Size-Report/Makefile6
-rw-r--r--devel/p5-Devel-Timer/Makefile4
-rw-r--r--devel/p5-Devel-ebug/Makefile2
-rw-r--r--devel/p5-File-Attributes/Makefile4
-rw-r--r--devel/p5-File-Dir-Dumper/Makefile2
-rw-r--r--devel/p5-File-Flat/Makefile12
-rw-r--r--devel/p5-File-pushd/Makefile5
-rw-r--r--devel/p5-Gravatar-URL/Makefile4
-rw-r--r--devel/p5-IO-CaptureOutput/Makefile4
-rw-r--r--devel/p5-IO-Interactive/Makefile4
-rw-r--r--devel/p5-IOC/Makefile2
-rw-r--r--devel/p5-IPC-PubSub/Makefile2
-rw-r--r--devel/p5-JIRA-Client/Makefile4
-rw-r--r--devel/p5-JQuery/Makefile2
-rw-r--r--devel/p5-JSON-RPC/Makefile4
-rw-r--r--devel/p5-Module-CPANTS-Analyse/Makefile2
-rw-r--r--devel/p5-Module-Install/Makefile3
20 files changed, 28 insertions, 48 deletions
diff --git a/devel/p5-Data-Structure-Util/Makefile b/devel/p5-Data-Structure-Util/Makefile
index 06ed208a36cd..e4f706748d28 100644
--- a/devel/p5-Data-Structure-Util/Makefile
+++ b/devel/p5-Data-Structure-Util/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Data-Structure-Util
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,9 +16,7 @@ MAINTAINER= nistor@snickers.org
COMMENT= Perl5 module to change the nature of data within a structure
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
PERL_CONFIGURE= yes
diff --git a/devel/p5-Devel-Leak-Object/Makefile b/devel/p5-Devel-Leak-Object/Makefile
index 5cb070e4d7e0..9b3732aa2bdd 100644
--- a/devel/p5-Devel-Leak-Object/Makefile
+++ b/devel/p5-Devel-Leak-Object/Makefile
@@ -14,9 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Detect leaks of objects
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-
PERL_CONFIGURE= yes
MAN3= Devel::Leak::Object.3
diff --git a/devel/p5-Devel-LeakGuard-Object/Makefile b/devel/p5-Devel-LeakGuard-Object/Makefile
index a4625c33851d..1a0774f78d82 100644
--- a/devel/p5-Devel-LeakGuard-Object/Makefile
+++ b/devel/p5-Devel-LeakGuard-Object/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Devel-LeakGuard-Object
PORTVERSION= 0.06
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= markun@onohara.to
COMMENT= Scoped checks for object leaks
-BUILD_DEPENDS= p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences
+BUILD_DEPENDS= p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Devel-Size-Report/Makefile b/devel/p5-Devel-Size-Report/Makefile
index b77d9ea2fb73..6fdf91bc0068 100644
--- a/devel/p5-Devel-Size-Report/Makefile
+++ b/devel/p5-Devel-Size-Report/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Devel-Size-Report
PORTVERSION= 0.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,9 +16,7 @@ MAINTAINER= alexey@renatasystems.org
COMMENT= Extension to generate a size report for all elements in a structure
BUILD_DEPENDS= p5-Array-RefElem>=1.00:${PORTSDIR}/misc/p5-Array-RefElem \
- p5-Devel-Size>=0.69:${PORTSDIR}/devel/p5-Devel-Size \
- p5-Scalar-List-Utils>=1.13:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-Time-HiRes>=1.86:${PORTSDIR}/devel/p5-Time-HiRes
+ p5-Devel-Size>=0.69:${PORTSDIR}/devel/p5-Devel-Size
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Devel-Timer/Makefile b/devel/p5-Devel-Timer/Makefile
index c946e0c42d22..81b54720a92e 100644
--- a/devel/p5-Devel-Timer/Makefile
+++ b/devel/p5-Devel-Timer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Devel-Timer
PORTVERSION= 0.04
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= coryking@mozimedia.com
COMMENT= Track and report execution time for parts of code
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-
PERL_CONFIGURE= yes
MAN3= Devel::Timer.3
diff --git a/devel/p5-Devel-ebug/Makefile b/devel/p5-Devel-ebug/Makefile
index 7bf61c70a72e..67adfa0e7d05 100644
--- a/devel/p5-Devel-ebug/Makefile
+++ b/devel/p5-Devel-ebug/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Devel-ebug
PORTVERSION= 0.49
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= Devel
@@ -19,7 +20,6 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PadWalker.pm:${PORTSDIR}/devel/p5-PadWalk
${SITE_PERL}/${PERL_ARCH}/YAML/Syck.pm:${PORTSDIR}/textproc/p5-YAML-Syck \
${SITE_PERL}/Class/Accessor/Chained/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
${SITE_PERL}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace \
- ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
${SITE_PERL}/Proc/Background.pm:${PORTSDIR}/devel/p5-Proc-Background \
${SITE_PERL}/String/Koremutake.pm:${PORTSDIR}/textproc/p5-String-Koremutake
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/devel/p5-File-Attributes/Makefile b/devel/p5-File-Attributes/Makefile
index 474f9493b578..fbe1b1310cd1 100644
--- a/devel/p5-File-Attributes/Makefile
+++ b/devel/p5-File-Attributes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= File-Attributes
PORTVERSION= 0.04
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= File::Attributes - Manipulate file metadata
-BUILD_DEPENDS= ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
- ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+BUILD_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
${SITE_PERL}/Directory/Scratch.pm:${PORTSDIR}/devel/p5-Directory-Scratch \
${SITE_PERL}/Best.pm:${PORTSDIR}/devel/p5-Best \
p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck
diff --git a/devel/p5-File-Dir-Dumper/Makefile b/devel/p5-File-Dir-Dumper/Makefile
index eee707938551..ec3550630373 100644
--- a/devel/p5-File-Dir-Dumper/Makefile
+++ b/devel/p5-File-Dir-Dumper/Makefile
@@ -7,6 +7,7 @@
PORTNAME= File-Dir-Dumper
PORTVERSION= 0.0.6
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,7 +16,6 @@ MAINTAINER= tolid@tolid.eu.org
COMMENT= Perl5 module to dump directory structures' meta-data
BUILD_DEPENDS= ${SITE_PERL}/File/Find/Object.pm:${PORTSDIR}/devel/p5-File-Find-Object \
- ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
${SITE_PERL}/JSON.pm:${PORTSDIR}/converters/p5-JSON
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-File-Flat/Makefile b/devel/p5-File-Flat/Makefile
index f6d3e3c02ae4..74abd1570e7a 100644
--- a/devel/p5-File-Flat/Makefile
+++ b/devel/p5-File-Flat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= File-Flat
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,26 +16,17 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Implements a flat filesystem
RUN_DEPENDS= ${SITE_PERL}/Test/ClassAPI.pm:${PORTSDIR}/devel/p5-Test-ClassAPI \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/File/NCopy.pm:${PORTSDIR}/devel/p5-File-NCopy \
${SITE_PERL}/File/Copy/Recursive.pm:${PORTSDIR}/devel/p5-File-Copy-Recursive \
${SITE_PERL}/File/Remove.pm:${PORTSDIR}/devel/p5-File-Remove \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
- ${SITE_PERL}/${PERL_ARCH}/IO/File.pm:${PORTSDIR}/devel/p5-IO \
${SITE_PERL}/Class/Autouse.pm:${PORTSDIR}/devel/p5-Class-Autouse \
${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork
BUILD_DEPENDS= ${SITE_PERL}/Test/ClassAPI.pm:${PORTSDIR}/devel/p5-Test-ClassAPI \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/File/NCopy.pm:${PORTSDIR}/devel/p5-File-NCopy \
${SITE_PERL}/File/Copy/Recursive.pm:${PORTSDIR}/devel/p5-File-Copy-Recursive \
${SITE_PERL}/File/Remove.pm:${PORTSDIR}/devel/p5-File-Remove \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
- ${SITE_PERL}/${PERL_ARCH}/IO/File.pm:${PORTSDIR}/devel/p5-IO \
${SITE_PERL}/Class/Autouse.pm:${PORTSDIR}/devel/p5-Class-Autouse \
- ${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork \
- ${SITE_PERL}/Test/ClassAPI.pm:${PORTSDIR}/devel/p5-Test-ClassAPI
+ ${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork
PERL_CONFIGURE= yes
diff --git a/devel/p5-File-pushd/Makefile b/devel/p5-File-pushd/Makefile
index 65aa4ea1dae3..eb234dc07674 100644
--- a/devel/p5-File-pushd/Makefile
+++ b/devel/p5-File-pushd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= File-pushd
PORTVERSION= 1.00
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= File::pushd - temporary chdir for a limited scope
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class
+BUILD_DEPENDS= ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Gravatar-URL/Makefile b/devel/p5-Gravatar-URL/Makefile
index 8917d693d0ed..dbef9c5a77f5 100644
--- a/devel/p5-Gravatar-URL/Makefile
+++ b/devel/p5-Gravatar-URL/Makefile
@@ -6,6 +6,7 @@
PORTNAME= Gravatar-URL
PORTVERSION= 1.01
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/M/MS/MSCHWERN
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= andrey@kostenko.name
COMMENT= Make URLs for Gravatars from an email address
-BUILD_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-IO-CaptureOutput/Makefile b/devel/p5-IO-CaptureOutput/Makefile
index 9d96a5e9ca2e..285c9f3041ca 100644
--- a/devel/p5-IO-CaptureOutput/Makefile
+++ b/devel/p5-IO-CaptureOutput/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IO-CaptureOutput
PORTVERSION= 1.11.01
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,9 +18,6 @@ COMMENT= Capture STDOUT/STDERR from subprocesses and XS/C modules
PERL_CONFIGURE= yes
-RUN_DEPENDS= p5-PathTools>=3.27:${PORTSDIR}/devel/p5-PathTools
-BUILD_DEPENDS= ${RUN_DEPENDS}
-
MAN3= IO::CaptureOutput.3
.include <bsd.port.mk>
diff --git a/devel/p5-IO-Interactive/Makefile b/devel/p5-IO-Interactive/Makefile
index 3750c2dd454d..303a304a6c79 100644
--- a/devel/p5-IO-Interactive/Makefile
+++ b/devel/p5-IO-Interactive/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IO-Interactive
PORTVERSION= 0.0.6
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= andrey@kostenko.name
COMMENT= Utilities for interactive I/O
-BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
- p5-version>=0:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS= p5-version>=0:${PORTSDIR}/devel/p5-version
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-IOC/Makefile b/devel/p5-IOC/Makefile
index 232b4d9038b8..ad54a83593e2 100644
--- a/devel/p5-IOC/Makefile
+++ b/devel/p5-IOC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IOC
PORTVERSION= 0.29
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/S/ST/STEVAN
@@ -18,7 +19,6 @@ COMMENT= Lightweight IOC (Inversion of Control) framework
BUILD_DEPENDS= ${SITE_PERL}/Class/Throwable.pm:${PORTSDIR}/devel/p5-Class-Throwable \
${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
${SITE_PERL}/Class/StrongSingleton.pm:${PORTSDIR}/devel/p5-Class-StrongSingleton \
${SITE_PERL}/Class/Interfaces.pm:${PORTSDIR}/devel/p5-Class-Interfaces
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-IPC-PubSub/Makefile b/devel/p5-IPC-PubSub/Makefile
index e14eb060d11d..2024f82ba341 100644
--- a/devel/p5-IPC-PubSub/Makefile
+++ b/devel/p5-IPC-PubSub/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IPC-PubSub
PORTVERSION= 0.29
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,7 +16,6 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= Interprocess Publish/Subscribe channels
BUILD_DEPENDS= p5-DBM-Deep>=1:${PORTSDIR}/databases/p5-DBM-Deep \
- p5-Time-HiRes>0:${PORTSDIR}/devel/p5-Time-HiRes \
p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Data-UUID>0:${PORTSDIR}/devel/p5-Data-UUID
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-JIRA-Client/Makefile b/devel/p5-JIRA-Client/Makefile
index cba8e797f12c..b6d00443cfe9 100644
--- a/devel/p5-JIRA-Client/Makefile
+++ b/devel/p5-JIRA-Client/Makefile
@@ -7,6 +7,7 @@
PORTNAME= JIRA-Client
PORTVERSION= 0.24
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= GOOGLE_CODE \
LOCAL/glarkin
@@ -15,8 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= An extended interface to JIRA's SOAP API
-RUN_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO \
- p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-JQuery/Makefile b/devel/p5-JQuery/Makefile
index 98b0d0fed3b5..c51df631a219 100644
--- a/devel/p5-JQuery/Makefile
+++ b/devel/p5-JQuery/Makefile
@@ -7,6 +7,7 @@
PORTNAME= JQuery
PORTVERSION= 1.06
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/P/PE/PETERG
@@ -16,7 +17,6 @@ MAINTAINER= gslin@gslin.org
COMMENT= Interface to Jquery, a language based on Javascript
RUN_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
- ${SITE_PERL}/CGI/Carp.pm:${PORTSDIR}/www/p5-CGI.pm \
${SITE_PERL}/CSS.pm:${PORTSDIR}/textproc/p5-CSS \
${SITE_PERL}/HTML/Table.pm:${PORTSDIR}/www/p5-HTML-Table \
${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
diff --git a/devel/p5-JSON-RPC/Makefile b/devel/p5-JSON-RPC/Makefile
index 7b2a7e311497..f63918a327b9 100644
--- a/devel/p5-JSON-RPC/Makefile
+++ b/devel/p5-JSON-RPC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= JSON-RPC
PORTVERSION= 0.96
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vvatlin@masterhost.ru
COMMENT= Perl implementation of JSON-RPC 1.1 protocol
-RUN_DEPENDS= p5-CGI.pm>=2.92:${PORTSDIR}/www/p5-CGI.pm \
- p5-JSON>=2.0:${PORTSDIR}/converters/p5-JSON \
+RUN_DEPENDS= p5-JSON>=2.0:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_CONFIGURE= YES
diff --git a/devel/p5-Module-CPANTS-Analyse/Makefile b/devel/p5-Module-CPANTS-Analyse/Makefile
index 6076baa1e36d..11f99df11468 100644
--- a/devel/p5-Module-CPANTS-Analyse/Makefile
+++ b/devel/p5-Module-CPANTS-Analyse/Makefile
@@ -6,6 +6,7 @@
PORTNAME= Module-CPANTS-Analyse
PORTVERSION= 0.85
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -22,7 +23,6 @@ RUN_DEPENDS= p5-Archive-Any>=0.06:${PORTSDIR}/archivers/p5-Archive-Any \
p5-IO-Capture>=0.05:${PORTSDIR}/devel/p5-IO-Capture \
p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Module-ExtractUse>=0.18:${PORTSDIR}/devel/p5-Module-ExtractUse \
- p5-Module-Pluggable>=2.96:${PORTSDIR}/devel/p5-Module-Pluggable \
p5-Pod-Simple>=2.02:${PORTSDIR}/textproc/p5-Pod-Simple \
p5-Readonly>=0:${PORTSDIR}/devel/p5-Readonly \
p5-Test-YAML-Meta>=0.06:${PORTSDIR}/devel/p5-Test-YAML-Meta \
diff --git a/devel/p5-Module-Install/Makefile b/devel/p5-Module-Install/Makefile
index 21e5694e28b6..88b9a6f43cd7 100644
--- a/devel/p5-Module-Install/Makefile
+++ b/devel/p5-Module-Install/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Module-Install
PORTVERSION= 0.91
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,7 +20,6 @@ RUN_DEPENDS= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
${SITE_PERL}/PAR/Dist.pm:${PORTSDIR}/devel/p5-PAR-Dist \
${SITE_PERL}/YAML/Tiny.pm:${PORTSDIR}/textproc/p5-YAML-Tiny \
- ${SITE_PERL}/ExtUtils/ParseXS.pm:${PORTSDIR}/devel/p5-ExtUtils-ParseXS \
${SITE_PERL}/${PERL_ARCH}/Devel/PPPort.pm:${PORTSDIR}/devel/p5-Devel-PPPort
BUILD_DEPENDS= ${RUN_DEPENDS}