aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-07 02:21:52 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-07 02:21:52 +0000
commit0467aae499c92d2291845dfda27e5622a727a993 (patch)
tree34ed02ae681900dda940f9ba00d20f84e185a83b
parent3842be24171bd26fb70d2551ccf75d9cddff3e53 (diff)
downloadports-0467aae499c92d2291845dfda27e5622a727a993.tar.gz
ports-0467aae499c92d2291845dfda27e5622a727a993.zip
Notes
-rw-r--r--audio/ac3dec/Makefile5
-rw-r--r--audio/aumix/files/patch-src::common.h25
-rw-r--r--audio/fmio/Makefile5
-rw-r--r--audio/gramofile/Makefile7
-rw-r--r--audio/maplay/Makefile6
-rw-r--r--audio/mpg123/Makefile5
-rw-r--r--audio/play/Makefile9
-rw-r--r--audio/radio/Makefile5
-rw-r--r--audio/rawrec/Makefile2
-rw-r--r--audio/speak_freely/Makefile5
-rw-r--r--audio/timidity/Makefile5
-rw-r--r--audio/tracker/Makefile5
-rw-r--r--audio/wavplay/files/patch-ab2
-rw-r--r--audio/wavplay/files/patch-ac2
-rw-r--r--audio/wavplay/files/patch-ae2
-rw-r--r--audio/wavplay/files/patch-af2
-rw-r--r--audio/wavplay/files/patch-ag2
-rw-r--r--japanese/typist/files/patch-ac2
-rw-r--r--mbone/speak_freely/Makefile5
19 files changed, 94 insertions, 7 deletions
diff --git a/audio/ac3dec/Makefile b/audio/ac3dec/Makefile
index 5936e03b4809..c39f96e8390c 100644
--- a/audio/ac3dec/Makefile
+++ b/audio/ac3dec/Makefile
@@ -15,6 +15,11 @@ MAINTAINER= 3d@FreeBSD.org
GNU_CONFIGURE= yes
USE_NEWGCC= yes
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' \
+ < ${WRKSRC}/output.c > ${WRKSRC}/output.c.new
+ @${MV} ${WRKSRC}/output.c.new ${WRKSRC}/output.c
+
pre-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ac3dec
diff --git a/audio/aumix/files/patch-src::common.h b/audio/aumix/files/patch-src::common.h
new file mode 100644
index 000000000000..bfba61c3dfcc
--- /dev/null
+++ b/audio/aumix/files/patch-src::common.h
@@ -0,0 +1,25 @@
+$FreeBSD$
+
+--- src/common.h.orig Thu Jun 6 19:50:10 2002
++++ src/common.h Thu Jun 6 19:51:01 2002
+@@ -24,18 +24,14 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
+-/* "The nice thing about standards..." */
+-#if defined (__FreeBSD__)
+-#include <machine/soundcard.h>
+-#else
++/* "The nice thing about standards..." */
+ #if defined (__NetBSD__) || defined (__OpenBSD__)
+ #include <soundcard.h> /* OSS emulation */
+ #undef ioctl
+ #else
+-/* BSDI, Linux, Solaris */
++/* FreeBSD, BSDI, Linux, Solaris */
+ #include <sys/soundcard.h>
+ #endif /* __NetBSD__ or __OpenBSD__ */
+-#endif /* __FreeBSD__ */
+ #ifdef HAVE_ALSA
+ #include <sys/asoundlib.h>
+ #endif /* HAVE_ALSA */
diff --git a/audio/fmio/Makefile b/audio/fmio/Makefile
index 581c469677e0..eab5d913a9fe 100644
--- a/audio/fmio/Makefile
+++ b/audio/fmio/Makefile
@@ -16,6 +16,11 @@ MAINTAINER= kunia@istc.kiev.ua
MAN1= fmio.1
MANCOMPRESSED= no
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/mixer.c > ${WRKSRC}/mixer.c.new
+ @${MV} ${WRKSRC}/mixer.c.new ${WRKSRC}/mixer.c
+
pre-build:
.if !defined(WITH_BKTR)
@${ECHO_MSG}
diff --git a/audio/gramofile/Makefile b/audio/gramofile/Makefile
index b83c007b20c2..f33de8293499 100644
--- a/audio/gramofile/Makefile
+++ b/audio/gramofile/Makefile
@@ -15,6 +15,13 @@ MAINTAINER= nox@jelal.kn-bremen.de
ALL_TARGET= gramofile
USE_GMAKE= yes
+post-patch:
+.for file in bplay.c sndfunc.c
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/bplaysrc/${file} > ${WRKSRC}/bplaysrc/${file}.new
+ @${MV} ${WRKSRC}/bplaysrc/${file}.new ${WRKSRC}/bplaysrc/${file}
+.endfor
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gramofile ${WRKSRC}/bplay_gramo ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/doc/gramofile
diff --git a/audio/maplay/Makefile b/audio/maplay/Makefile
index 044aea2a745c..ae0ea3193aa7 100644
--- a/audio/maplay/Makefile
+++ b/audio/maplay/Makefile
@@ -16,6 +16,12 @@ MAINTAINER= ports@FreeBSD.org
NO_WRKSUBDIR= yes
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/configuration.sh > ${WRKSRC}/configuration.sh.new
+ @${MV} ${WRKSRC}/configuration.sh.new ${WRKSRC}/configuration.sh
+ @${CHMOD} a+x ${WRKSRC}/configuration.sh
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/maplay ${PREFIX}/bin
.if !defined(NOPORTDOCS)
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index 268a0d5ef2d8..18017d9628c6 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -99,4 +99,9 @@ OPT_ARCH?= i586
MAKE_ARGS+= OPT_ARCH=${OPT_ARCH}
.endif
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/audio_oss.c > ${WRKSRC}/audio_oss.c.new
+ @${MV} ${WRKSRC}/audio_oss.c.new ${WRKSRC}/audio_oss.c
+
.include <bsd.port.post.mk>
diff --git a/audio/play/Makefile b/audio/play/Makefile
index 24e7bf0c6e9c..aab44d23cedc 100644
--- a/audio/play/Makefile
+++ b/audio/play/Makefile
@@ -15,4 +15,13 @@ MAINTAINER= seiken@ARGV.AC
MANLANG= ja
MAN1= play.1
MANCOMPRESSED = yes
+
+post-patch:
+.for file in play_audio.c mixer_ctl.c encode_sun.c encode_riff.c speed.c
+ @${CHMOD} u+w ${WRKSRC}/${file}
+ @${SED} 's,machine/soundcard.h,sys/soundcard.h,' < ${WRKSRC}/${file} \
+ > ${WRKSRC}/${file}.new
+ @${MV} ${WRKSRC}/${file}.new ${WRKSRC}/${file}
+.endfor
+
.include <bsd.port.mk>
diff --git a/audio/radio/Makefile b/audio/radio/Makefile
index 18c457fa625b..b1160de6ac64 100644
--- a/audio/radio/Makefile
+++ b/audio/radio/Makefile
@@ -17,4 +17,9 @@ NO_WRKSUBDIR= yes
MAKE_FLAGS= FreeBSD -f
MAN1= radio.1 broadcast.1
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/radio.c > ${WRKSRC}/radio.c.new
+ @${MV} ${WRKSRC}/radio.c.new ${WRKSRC}/radio.c
+
.include <bsd.port.mk>
diff --git a/audio/rawrec/Makefile b/audio/rawrec/Makefile
index d605ae6acb32..dccd85849b79 100644
--- a/audio/rawrec/Makefile
+++ b/audio/rawrec/Makefile
@@ -32,7 +32,7 @@ post-patch:
s,-lpthread,${PTHREAD_LIBS},g ; \
s,/usr/local,${PREFIX},g" ${WRKSRC}/Makefile
@${GREP} -lR "linux/" ${WRKSRC} | ${XARGS} \
- ${PERL} -pi -e "s,linux/,machine/,g"
+ ${PERL} -pi -e "s,linux/,sys/,g"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rawrec ${PREFIX}/bin
diff --git a/audio/speak_freely/Makefile b/audio/speak_freely/Makefile
index 36059ba7f46d..56ddd107a7af 100644
--- a/audio/speak_freely/Makefile
+++ b/audio/speak_freely/Makefile
@@ -22,6 +22,11 @@ MAN1= ${UTILS:S/$/.1/} ${DEMNS:S/$/.1/} ${DDEMNS:S/$/.1/}
MAKE_ENV= "OPTFLAGS=${CFLAGS}"
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/soundbyte.c > ${WRKSRC}/soundbyte.c.new
+ @${MV} ${WRKSRC}/soundbyte.c.new ${WRKSRC}/soundbyte.c
+
do-install:
if [ ! -d ${SFLIB} ]; then \
${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
diff --git a/audio/timidity/Makefile b/audio/timidity/Makefile
index 5cd39f70b439..7e73fd36e428 100644
--- a/audio/timidity/Makefile
+++ b/audio/timidity/Makefile
@@ -21,6 +21,11 @@ TIINS= goemon.tgz
INSTALL_TARGET= install.all
MAN1= timidity.1
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/linux_a.c > ${WRKSRC}/linux_a.c.new
+ @${MV} ${WRKSRC}/linux_a.c.new ${WRKSRC}/linux_a.c
+
post-install:
cd ${PREFIX}/lib/timidity && \
tar zxf ${DISTDIR}/${TIINS} && \
diff --git a/audio/tracker/Makefile b/audio/tracker/Makefile
index 85859cf167e0..1d5615dbef61 100644
--- a/audio/tracker/Makefile
+++ b/audio/tracker/Makefile
@@ -18,6 +18,11 @@ RESTRICTED= "Non-redistributable beta"
WRKSRC= ${WRKDIR}/tracker
INSTALL_TARGET= install install.info
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/Arch/PCux/audio.c > ${WRKSRC}/Arch/PCux/audio.c.new
+ @${MV} ${WRKSRC}/Arch/PCux/audio.c.new ${WRKSRC}/Arch/PCux/audio.c
+
post-install:
@install-info ${PREFIX}/info/tracker.info ${PREFIX}/info/dir
.if !defined(NOPORTDOCS)
diff --git a/audio/wavplay/files/patch-ab b/audio/wavplay/files/patch-ab
index b466b295b3d4..4985e3bdf967 100644
--- a/audio/wavplay/files/patch-ab
+++ b/audio/wavplay/files/patch-ab
@@ -21,7 +21,7 @@
+ #ifndef FREEBSD
#include <linux/soundcard.h>
+ #else
-+ #include <machine/soundcard.h>
++ #include <sys/soundcard.h>
+ #endif
#include "wavplay.h"
#include "client.h"
diff --git a/audio/wavplay/files/patch-ac b/audio/wavplay/files/patch-ac
index 8d5741e5a39b..97163c03f663 100644
--- a/audio/wavplay/files/patch-ac
+++ b/audio/wavplay/files/patch-ac
@@ -21,7 +21,7 @@
+ #ifndef FREEBSD
#include <linux/soundcard.h>
+ #else
-+ #include <machine/soundcard.h>
++ #include <sys/soundcard.h>
+ #endif
#include "wavplay.h"
diff --git a/audio/wavplay/files/patch-ae b/audio/wavplay/files/patch-ae
index 240078764022..22167b098d98 100644
--- a/audio/wavplay/files/patch-ae
+++ b/audio/wavplay/files/patch-ae
@@ -21,7 +21,7 @@
+ #ifndef FREEBSD
#include <linux/soundcard.h>
+ #else
-+ #include <machine/soundcard.h>
++ #include <sys/soundcard.h>
+ #endif
#include "wavplay.h"
diff --git a/audio/wavplay/files/patch-af b/audio/wavplay/files/patch-af
index e73ba52ac806..84ada821a3b6 100644
--- a/audio/wavplay/files/patch-af
+++ b/audio/wavplay/files/patch-af
@@ -16,7 +16,7 @@
+ #ifndef FREEBSD
#include <linux/soundcard.h>
+ #else
-+ #include <machine/soundcard.h>
++ #include <sys/soundcard.h>
+ #endif
#include "wavplay.h"
#include "server.h"
diff --git a/audio/wavplay/files/patch-ag b/audio/wavplay/files/patch-ag
index 5aa0306dc315..bb362f08f92e 100644
--- a/audio/wavplay/files/patch-ag
+++ b/audio/wavplay/files/patch-ag
@@ -21,7 +21,7 @@
+ #ifndef FREEBSD
#include <linux/soundcard.h>
+ #else
-+ #include <machine/soundcard.h>
++ #include <sys/soundcard.h>
+ #endif
#include "wavplay.h"
#include "server.h"
diff --git a/japanese/typist/files/patch-ac b/japanese/typist/files/patch-ac
index aa016c215a84..af2ab60f38da 100644
--- a/japanese/typist/files/patch-ac
+++ b/japanese/typist/files/patch-ac
@@ -13,7 +13,7 @@
+ #include <sys/types.h>
+ #include <sys/dir.h>
+ #include <sys/file.h>
-+ #include <machine/soundcard.h>
++ #include <sys/soundcard.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
diff --git a/mbone/speak_freely/Makefile b/mbone/speak_freely/Makefile
index 36059ba7f46d..56ddd107a7af 100644
--- a/mbone/speak_freely/Makefile
+++ b/mbone/speak_freely/Makefile
@@ -22,6 +22,11 @@ MAN1= ${UTILS:S/$/.1/} ${DEMNS:S/$/.1/} ${DDEMNS:S/$/.1/}
MAKE_ENV= "OPTFLAGS=${CFLAGS}"
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/soundbyte.c > ${WRKSRC}/soundbyte.c.new
+ @${MV} ${WRKSRC}/soundbyte.c.new ${WRKSRC}/soundbyte.c
+
do-install:
if [ ! -d ${SFLIB} ]; then \
${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \