aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-26 16:53:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-26 16:53:37 +0000
commit04d1da73af06a0333f71581b40092ee4c2b017a4 (patch)
treeca1fadd40c584d6fad15c373f22e9a1e5aceb1fa
parente8d954fdd67a2c343766eb92c37c0a9f2b40818b (diff)
downloadports-04d1da73af06a0333f71581b40092ee4c2b017a4.tar.gz
ports-04d1da73af06a0333f71581b40092ee4c2b017a4.zip
MFH: r373344
- Update to 4.0.1 - Update CONFLICTS_INSTALL - Update Makefile - Update PKGMESSAGE Changes: https://de.wordpress.org/2014/11/20/wordpress-4-0-1-sicherheits-update/ https://de.wordpress.org/2014/09/04/wordpress-4-0-benny/ Approved by: ports-secteam (delphij)
Notes
Notes: svn path=/branches/2014Q4/; revision=375633
-rw-r--r--german/wordpress/Makefile27
-rw-r--r--german/wordpress/distinfo4
-rw-r--r--german/wordpress/files/pkg-install.in12
-rw-r--r--german/wordpress/files/pkg-message.in4
4 files changed, 15 insertions, 32 deletions
diff --git a/german/wordpress/Makefile b/german/wordpress/Makefile
index 70688d3b93bd..625b78198386 100644
--- a/german/wordpress/Makefile
+++ b/german/wordpress/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= wordpress
-PORTVERSION= 3.9.1
-PORTREVISION= 1
+PORTVERSION= 4.0.1
CATEGORIES= german www
MASTER_SITES= http://de.wordpress.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-de_DE
@@ -13,11 +12,11 @@ COMMENT= State-of-the-art semantic personal publishing platform
LICENSE= GPLv2
-CONFLICTS_INSTALL= wordpress-3.* ja-wordpress-3.* ru-wordpress-3.*
+CONFLICTS_INSTALL= wordpress-[0-9].* ja-wordpress-[0-9].* ru-wordpress-[0-9].*
NO_BUILD= yes
USES= cpe
-USE_PHP= curl gd mysql pcre tokenizer xml zip zlib
+USE_PHP= curl gd hash mysql pcre tokenizer xml zip zlib
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -26,9 +25,7 @@ CPE_LANG= de
CPE_VERSION= ${PORTVERSION}.0
.endif
-SUB_FILES= pkg-message pkg-install
-SUB_LIST= CHGRP="${CHGRP}" CHOWN="${CHOWN}" CHMOD="${CHMOD}"\
- FIND="${FIND}" WWWGRP="${WWWGRP}" WWWOWN="${WWWOWN}"
+SUB_FILES= pkg-message
PLIST= ${WRKDIR}/pkg-plist
PORTDOCS= license.txt readme.html
@@ -40,21 +37,19 @@ pre-everything::
@sleep 1
pre-install:
- cd ${WRKSRC}/ && \
- (${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|'; \
- ${FIND} -d . -type d | ${SED} -e 's|^\.|@dirrm %%WWWDIR%%|') > ${PLIST}
+ ${ECHO_CMD} '@owner www' > ${PLIST}
+ ${ECHO_CMD} '@group www' >> ${PLIST}
+ cd ${WRKSRC}/ && ${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|' >> ${PLIST}
+ ${ECHO_CMD} '@owner' >> ${PLIST}
+ ${ECHO_CMD} '@group' >> ${PLIST}
if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL} -d -g ${WWWGRP} -m 755 -o ${WWWOWN} ${STAGEDIR}${WWWDIR}/
+ ${INSTALL} -d -m 755 ${STAGEDIR}${WWWDIR}/
${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}/
+ ${FIND} ${STAGEDIR}${WWWDIR}/ -type d -exec ${CHMOD} g+w '{}' \;
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
-post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.mk>
diff --git a/german/wordpress/distinfo b/german/wordpress/distinfo
index afc341b8bae6..51a97b0ddb76 100644
--- a/german/wordpress/distinfo
+++ b/german/wordpress/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wordpress-3.9.1-de_DE.tar.gz) = 5b6efc38effa0b0b0dd30ea4b9845628dc1808e0fdf476e3697045ae1b6720f5
-SIZE (wordpress-3.9.1-de_DE.tar.gz) = 6235569
+SHA256 (wordpress-4.0.1-de_DE.tar.gz) = 7f817f655db69f796158f969b171f242994d5883926d987cea6450928a9781b4
+SIZE (wordpress-4.0.1-de_DE.tar.gz) = 6475302
diff --git a/german/wordpress/files/pkg-install.in b/german/wordpress/files/pkg-install.in
deleted file mode 100644
index 93fe0df35ab8..000000000000
--- a/german/wordpress/files/pkg-install.in
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-case $2 in
- PRE-INSTALL)
- ;;
- POST-INSTALL)
- %%CHOWN%% -R %%WWWOWN%% %%WWWDIR%%/wp-content
- %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHGRP%% %%WWWGRP%%
- %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHMOD%% g+w
- ;;
- *)
- ;;
-esac
diff --git a/german/wordpress/files/pkg-message.in b/german/wordpress/files/pkg-message.in
index a3c01e1be0d6..11afe3fec699 100644
--- a/german/wordpress/files/pkg-message.in
+++ b/german/wordpress/files/pkg-message.in
@@ -2,5 +2,5 @@
Before the first use of WordPress, copy wp-config-sample.php to wp-config.php
in %%WWWDIR%% and modify it to fit your MySQL.
Maybe you need 'mysqladmin create wordpress' first.
-If you are upgrading from 1.x or 2.x to 3.x, please run
-http://your.site/wordpress/wp-admin/upgrade.php to upgrade to WordPress 3.x
+If you are upgrading from 1.x or 2.x or 3.x to 4.x, please run
+http://your.site/wordpress/wp-admin/upgrade.php to upgrade to WordPress 4.x