aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-29 15:34:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-29 15:34:58 +0000
commit0ca56e20183641796c9c6f6ef637c79fa0e2149c (patch)
tree47f611b6227430d604ad990ee734b94d76b04c79
parentf0387837262bcb2dda20867b1dedcf7fd06a2ae7 (diff)
downloadports-0ca56e20183641796c9c6f6ef637c79fa0e2149c.tar.gz
ports-0ca56e20183641796c9c6f6ef637c79fa0e2149c.zip
MFH: r373382
- Clarify LICENSE - Add LICENSE_FILE - Fix UB caused by absent return statements which leads to crashes on 10.0+ - Drop @dirrm* from plist Approved by: ports-secteam (rea)
Notes
Notes: svn path=/branches/2014Q4/; revision=373631
-rw-r--r--games/gillo/Makefile3
-rw-r--r--games/gillo/files/patch-src__context.cpp11
-rw-r--r--games/gillo/files/patch-src__game.cpp18
-rw-r--r--games/gillo/files/patch-src__menu.cpp10
-rw-r--r--games/gillo/pkg-plist1
5 files changed, 41 insertions, 2 deletions
diff --git a/games/gillo/Makefile b/games/gillo/Makefile
index bb859544072c..503149963331 100644
--- a/games/gillo/Makefile
+++ b/games/gillo/Makefile
@@ -11,7 +11,8 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Players are cars throwing a magnetic fuzzy ball into a goal
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${JAM}:${PORTSDIR}/devel/jam \
${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
diff --git a/games/gillo/files/patch-src__context.cpp b/games/gillo/files/patch-src__context.cpp
new file mode 100644
index 000000000000..26036177893b
--- /dev/null
+++ b/games/gillo/files/patch-src__context.cpp
@@ -0,0 +1,11 @@
+--- src/context.cpp.orig 2005-07-19 03:25:16.000000000 +0400
++++ src/context.cpp 2014-11-24 16:07:54.000000000 +0300
+@@ -247,7 +247,7 @@
+
+ ssgSimpleState* Context::getState(int stateid)
+ {
+- this->states.getStep(stateid);
++ return this->states.getStep(stateid);
+ }
+
+ void Context::addToPool(ssgEntity* obj)
diff --git a/games/gillo/files/patch-src__game.cpp b/games/gillo/files/patch-src__game.cpp
new file mode 100644
index 000000000000..56e17d079924
--- /dev/null
+++ b/games/gillo/files/patch-src__game.cpp
@@ -0,0 +1,18 @@
+--- src/game.cpp.orig 2005-07-19 03:25:16.000000000 +0400
++++ src/game.cpp 2014-11-24 16:13:27.000000000 +0300
+@@ -54,6 +54,8 @@
+ attractionStautsP2(0.00, 0, 0.18, 0.08, TEX_ATTRACT),
+ attractionStautsP1(0.82, 0, 1.00, 0.08, TEX_ATTRACT)
+ {
++ dInitODE();
++
+ this->context.setGravity(0,0,ODE_WORLD_GRAVITY);// @fixme remove this
+ /* ODE setup */
+ // dWorldSetERP (context.getWid(), 0.9);
+@@ -990,5 +992,6 @@
+ }else {
+ //@fixme throw something
+ }
++ return false;
+ }
+ };
diff --git a/games/gillo/files/patch-src__menu.cpp b/games/gillo/files/patch-src__menu.cpp
new file mode 100644
index 000000000000..f730fbe1aa7d
--- /dev/null
+++ b/games/gillo/files/patch-src__menu.cpp
@@ -0,0 +1,10 @@
+--- src/menu.cpp.orig 2005-07-19 03:25:16.000000000 +0400
++++ src/menu.cpp 2014-11-24 16:08:56.000000000 +0300
+@@ -341,6 +341,7 @@
+ } else {
+ //@fixme throw something
+ }
++ return false;
+ }
+
+ };
diff --git a/games/gillo/pkg-plist b/games/gillo/pkg-plist
index 77ca5814635c..8af696109190 100644
--- a/games/gillo/pkg-plist
+++ b/games/gillo/pkg-plist
@@ -75,4 +75,3 @@ bin/gillo3
%%DATADIR%%/training.mod
%%DATADIR%%/wheelstripes.rgb
%%DATADIR%%/zzap.wav
-@dirrm %%DATADIR%%