aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-03 12:24:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-03 12:24:26 +0000
commit17a043ebcdd6316843b85d6bccef676314db0b05 (patch)
tree8750231324508086cb75cdcadc02339d878c0c5d
parent41f553bf27d80a550bc4bd11a9b9d9b3c51520d1 (diff)
downloadports-17a043ebcdd6316843b85d6bccef676314db0b05.tar.gz
ports-17a043ebcdd6316843b85d6bccef676314db0b05.zip
Notes
-rw-r--r--devel/ecore-file/Makefile3
-rw-r--r--devel/ecore-ipc/Makefile3
-rw-r--r--graphics/evas-engine-x11/Makefile3
-rw-r--r--graphics/evas-loader-bmp/Makefile9
-rw-r--r--graphics/evas-loader-eet/Makefile9
-rw-r--r--graphics/evas-loader-generic/Makefile9
-rw-r--r--graphics/evas-loader-gif/Makefile9
-rw-r--r--graphics/evas-loader-ico/Makefile9
-rw-r--r--graphics/evas-loader-jpeg/Makefile6
-rw-r--r--graphics/evas-loader-pmaps/Makefile9
-rw-r--r--graphics/evas-loader-png/Makefile9
-rw-r--r--graphics/evas-loader-psd/Makefile9
-rw-r--r--graphics/evas-loader-svg/Makefile9
-rw-r--r--graphics/evas-loader-tga/Makefile9
-rw-r--r--graphics/evas-loader-tiff/Makefile9
-rw-r--r--graphics/evas-loader-wbmp/Makefile9
-rw-r--r--graphics/evas-loader-xpm/Makefile9
-rw-r--r--x11/ecore-imf_evas/Makefile3
-rw-r--r--x11/ecore-input/Makefile3
-rw-r--r--x11/ecore-input_evas/Makefile3
-rw-r--r--x11/ecore-x11/Makefile3
21 files changed, 116 insertions, 28 deletions
diff --git a/devel/ecore-file/Makefile b/devel/ecore-file/Makefile
index d548915481b9..e717d56506cb 100644
--- a/devel/ecore-file/Makefile
+++ b/devel/ecore-file/Makefile
@@ -19,6 +19,9 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_EFL= ecore libtool_hack
USES= pkgconfig
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_file
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/devel/ecore-ipc/Makefile b/devel/ecore-ipc/Makefile
index 02c5046890d4..51ee5ce0ba45 100644
--- a/devel/ecore-ipc/Makefile
+++ b/devel/ecore-ipc/Makefile
@@ -20,6 +20,9 @@ GNU_CONFIGURE= yes
USE_EFL= ecore libtool_hack
USE_EFL_ECORE= con
USES= pkgconfig
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_ipc
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/graphics/evas-engine-x11/Makefile b/graphics/evas-engine-x11/Makefile
index 508280cc59a9..ed6308e91dd9 100644
--- a/graphics/evas-engine-x11/Makefile
+++ b/graphics/evas-engine-x11/Makefile
@@ -19,6 +19,9 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_XORG= x11 xext
USE_LDCONFIG= yes
diff --git a/graphics/evas-loader-bmp/Makefile b/graphics/evas-loader-bmp/Makefile
index 13be8f989c9f..f3aa94eb842a 100644
--- a/graphics/evas-loader-bmp/Makefile
+++ b/graphics/evas-loader-bmp/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-eet/Makefile b/graphics/evas-loader-eet/Makefile
index ff958580bb6e..1fb9680b5af2 100644
--- a/graphics/evas-loader-eet/Makefile
+++ b/graphics/evas-loader-eet/Makefile
@@ -20,6 +20,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas eet librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -36,11 +41,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-generic/Makefile b/graphics/evas-loader-generic/Makefile
index 436c8ea7f29d..2e1d08bb21bb 100644
--- a/graphics/evas-loader-generic/Makefile
+++ b/graphics/evas-loader-generic/Makefile
@@ -24,6 +24,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -47,11 +52,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-gif/Makefile b/graphics/evas-loader-gif/Makefile
index b4bf73106c44..97dd26c1c8a5 100644
--- a/graphics/evas-loader-gif/Makefile
+++ b/graphics/evas-loader-gif/Makefile
@@ -20,6 +20,11 @@ LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -35,11 +40,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-ico/Makefile b/graphics/evas-loader-ico/Makefile
index 068739d6ea04..d074427cd52b 100644
--- a/graphics/evas-loader-ico/Makefile
+++ b/graphics/evas-loader-ico/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-jpeg/Makefile b/graphics/evas-loader-jpeg/Makefile
index f5de844cc34a..5a08159b7a67 100644
--- a/graphics/evas-loader-jpeg/Makefile
+++ b/graphics/evas-loader-jpeg/Makefile
@@ -21,8 +21,10 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
.if defined(.PARSEDIR)
USE_GMAKE= yes
+MYMAKE= ${GMAKE}
.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -40,11 +42,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-pmaps/Makefile b/graphics/evas-loader-pmaps/Makefile
index fe6441358eda..372663ad1c5e 100644
--- a/graphics/evas-loader-pmaps/Makefile
+++ b/graphics/evas-loader-pmaps/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-png/Makefile b/graphics/evas-loader-png/Makefile
index 02ae200937ce..c0af2d290f5c 100644
--- a/graphics/evas-loader-png/Makefile
+++ b/graphics/evas-loader-png/Makefile
@@ -21,6 +21,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -37,11 +42,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-psd/Makefile b/graphics/evas-loader-psd/Makefile
index 37bbc2fade3f..349c071528a7 100644
--- a/graphics/evas-loader-psd/Makefile
+++ b/graphics/evas-loader-psd/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-svg/Makefile b/graphics/evas-loader-svg/Makefile
index eabafa9344cf..92124d2feccd 100644
--- a/graphics/evas-loader-svg/Makefile
+++ b/graphics/evas-loader-svg/Makefile
@@ -19,6 +19,11 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas esvg librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -34,11 +39,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-tga/Makefile b/graphics/evas-loader-tga/Makefile
index ee44c86a0a4a..af29b0d58d3a 100644
--- a/graphics/evas-loader-tga/Makefile
+++ b/graphics/evas-loader-tga/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-tiff/Makefile b/graphics/evas-loader-tiff/Makefile
index 545ad598e497..3182153c0923 100644
--- a/graphics/evas-loader-tiff/Makefile
+++ b/graphics/evas-loader-tiff/Makefile
@@ -21,6 +21,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -37,11 +42,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-wbmp/Makefile b/graphics/evas-loader-wbmp/Makefile
index f19064449a02..dc65c707ab93 100644
--- a/graphics/evas-loader-wbmp/Makefile
+++ b/graphics/evas-loader-wbmp/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/graphics/evas-loader-xpm/Makefile b/graphics/evas-loader-xpm/Makefile
index fb1d5823bd3b..33a329c9f9db 100644
--- a/graphics/evas-loader-xpm/Makefile
+++ b/graphics/evas-loader-xpm/Makefile
@@ -19,6 +19,11 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_XORG= xpm
USE_LDCONFIG= yes
@@ -35,11 +40,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>
diff --git a/x11/ecore-imf_evas/Makefile b/x11/ecore-imf_evas/Makefile
index 029ba4584dfd..d8ee0b9a9c39 100644
--- a/x11/ecore-imf_evas/Makefile
+++ b/x11/ecore-imf_evas/Makefile
@@ -20,6 +20,9 @@ GNU_CONFIGURE= yes
USE_EFL= ecore evas libtool_hack
USE_EFL_ECORE= imf
USES= pkgconfig
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_imf_evas
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/x11/ecore-input/Makefile b/x11/ecore-input/Makefile
index 51d866c9b5e5..2cddc0806aac 100644
--- a/x11/ecore-input/Makefile
+++ b/x11/ecore-input/Makefile
@@ -23,6 +23,9 @@ USES= pkgconfig
USE_GMAKE= yes
.endif
USE_LDCONFIG= yes
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/x11/ecore-input_evas/Makefile b/x11/ecore-input_evas/Makefile
index b3b0dc78dcbe..125f7357892f 100644
--- a/x11/ecore-input_evas/Makefile
+++ b/x11/ecore-input_evas/Makefile
@@ -20,6 +20,9 @@ GNU_CONFIGURE= yes
USE_EFL= ecore evas libtool_hack
USE_EFL_ECORE= input
USES= pkgconfig
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input_evas
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/x11/ecore-x11/Makefile b/x11/ecore-x11/Makefile
index fae55a29cb50..5994642e2af0 100644
--- a/x11/ecore-x11/Makefile
+++ b/x11/ecore-x11/Makefile
@@ -17,6 +17,9 @@ LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_EFL= ecore libtool_hack
USE_EFL_ECORE= input
USE_LDCONFIG= yes