aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-08-14 16:02:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-08-14 16:02:17 +0000
commit18ce3352f06200857671a1783c1e19095d9354bf (patch)
treebaf85a03db3b78e5591c2c2436e664ac61015a45
parent750f08a625b4adc58efabbf12c4bfcfae2d2a26f (diff)
downloadports-18ce3352f06200857671a1783c1e19095d9354bf.tar.gz
ports-18ce3352f06200857671a1783c1e19095d9354bf.zip
Notes
-rw-r--r--german/steak/Makefile49
-rw-r--r--german/steak/files/patch-Poll__poll.c (renamed from german/steak/files/patch-Poll:poll.c)0
-rw-r--r--german/steak/pkg-plist2
3 files changed, 27 insertions, 24 deletions
diff --git a/german/steak/Makefile b/german/steak/Makefile
index d64eafe38903..2ad807e2bc39 100644
--- a/german/steak/Makefile
+++ b/german/steak/Makefile
@@ -3,7 +3,7 @@
PORTNAME= steak
PORTVERSION= 1.7.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= german
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Steak%20${PORTVERSION} \
http://www.tm.informatik.uni-frankfurt.de/%7Erazi/steak/program/
@@ -14,42 +14,45 @@ COMMENT= English <-> German dictionary under the GPL
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/aspell-ispell
-USE_XORG= xt
+USES= tar:bzip2
MAKE_JOBS_UNSAFE= yes
+WRKSRC= ${WRKDIR}/Steak
+OPTIONS_DEFINE= GTK1
+OPTIONS_DEFAULT= GTK1
-.if defined(WITHOUT_XSTEAK)
-USE_XORG= x11
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGTK1}
+USE_XORG= xt
USE_GNOME= gtk12
MAKE_ARGS= -D xsteak
-.endif
-WRKSRC= ${WRKDIR}/Steak
-USES= tar:bzip2
-
-.if defined(WITHOUT_XSTEAK)
-PLIST_SUB+= NOXSTEAK:="@comment "
+PLIST_SUB+= XSTEAK=""
.else
-PLIST_SUB+= NOXSTEAK:=""
+USE_XORG= x11
+PLIST_SUB+= XSTEAK="@comment "
.endif
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s,\$$HOME/bin/Steak/Datensatz,${PREFIX}/share/steak/Datensatz,; \
s,BINDIR=\$$HOME/bin/Steak,BINDIR=${DATADIR},; \
s,$$BINDIR/help.txt,${DATADIR}/help.txt,g" ${WRKSRC}/woerterbuch
- ${REINPLACE_CMD} -e "s,/usr/X11R6/,${LOCALBASE}/,g" ${WRKSRC}/Printbuffer/Makefile
+ ${REINPLACE_CMD} -e "s,/usr/X11R6/,${LOCALBASE}/,g; s,CC = gcc,CC ?= gcc," ${WRKSRC}/Printbuffer/Makefile
+ ${REINPLACE_CMD} -e "s,CC = gcc,CC ?= gcc," ${WRKSRC}/Poll/Makefile
+ ${REINPLACE_CMD} -e "s,CC = gcc,CC ?= gcc," ${WRKSRC}/SpaceFilter/Makefile
+ ${REINPLACE_CMD} -e "s,gcc,${CC}," ${WRKSRC}/Xsteak/Makefile_gtk_1.2
do-install:
-.if !defined(WITHOUT_XSTEAK)
- ${INSTALL_PROGRAM} ${WRKSRC}/Xsteak/xsteak ${PREFIX}/bin/
+.if ${PORT_OPTIONS:MGTK1}
+ ${INSTALL_PROGRAM} ${WRKSRC}/Xsteak/xsteak ${STAGEDIR}${PREFIX}/bin/
.endif
- ${INSTALL_SCRIPT} ${WRKSRC}/woerterbuch ${PREFIX}/bin/steak
- ${MKDIR} ${DATADIR}/Datensatz
- ${INSTALL_DATA} ${WRKSRC}/Datensatz/* ${DATADIR}/Datensatz
+ ${INSTALL_SCRIPT} ${WRKSRC}/woerterbuch ${STAGEDIR}${PREFIX}/bin/steak
+ @${MKDIR} ${STAGEDIR}${DATADIR}/Datensatz
+ ${INSTALL_DATA} ${WRKSRC}/Datensatz/* ${STAGEDIR}${DATADIR}/Datensatz
cd ${WRKSRC}; ${INSTALL_DATA} README README.eng help.txt \
mini_steak_icon.xpm pinguin_steak_icon.xpm \
- .Steakconfig ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/Xpm/* ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/iso2txt ${DATADIR}
- cd ${WRKSRC}; ${INSTALL_PROGRAM} poll printbuffer spacefilter ${DATADIR}
+ .Steakconfig ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Xpm/* ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/iso2txt ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} poll printbuffer spacefilter ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>
diff --git a/german/steak/files/patch-Poll:poll.c b/german/steak/files/patch-Poll__poll.c
index f244d7c574ca..f244d7c574ca 100644
--- a/german/steak/files/patch-Poll:poll.c
+++ b/german/steak/files/patch-Poll__poll.c
diff --git a/german/steak/pkg-plist b/german/steak/pkg-plist
index 0a8ce5f781e3..1637f9892617 100644
--- a/german/steak/pkg-plist
+++ b/german/steak/pkg-plist
@@ -1,5 +1,5 @@
bin/steak
-%%NOXSTEAK:%%bin/xsteak
+%%XSTEAK%%bin/xsteak
%%DATADIR%%/iso2txt
%%DATADIR%%/poll
%%DATADIR%%/printbuffer