aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-10-19 11:10:51 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-10-19 11:10:51 +0000
commit27a523cfee1e91faa4d4e30595e8f9020d49196a (patch)
tree02f99fd19f68d209a36a2c8ed40470995ab9e252
parentb4f206b397521e484803b388d2544fcc5c9aabca (diff)
downloadports-27a523cfee1e91faa4d4e30595e8f9020d49196a.tar.gz
ports-27a523cfee1e91faa4d4e30595e8f9020d49196a.zip
MFH: r399657
net/turnserver: Fix build with No-SSLv3 turnserver will not build if OpenSSL was built without SSLv3 (--no-ssl3). LibreSSL 2.3.0 has removed SSLv3 support completely. This change fixes the build when SSLv3 is not available While I'm here, add LICENSE_FILE PR: 203700 Submitted by: cpbsdmail gmail com Approved by: mom040267 gmail com (maintainer) Approved by: portmgr (erwin)
Notes
Notes: svn path=/branches/2014Q4/; revision=399658
-rw-r--r--net/turnserver/Makefile2
-rw-r--r--net/turnserver/files/patch-src_apps_common_apputils.c21
-rw-r--r--net/turnserver/files/patch-src_apps_uclient_mainuclient.c14
3 files changed, 37 insertions, 0 deletions
diff --git a/net/turnserver/Makefile b/net/turnserver/Makefile
index 37be19d7bf10..2473a287893b 100644
--- a/net/turnserver/Makefile
+++ b/net/turnserver/Makefile
@@ -2,6 +2,7 @@
PORTNAME= turnserver
PORTVERSION= 3.2.4.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://turnserver.open-sys.org/downloads/v${PORTVERSION}/:prog \
http://turnserver.open-sys.org/downloads/extradocs/:xdocs \
@@ -15,6 +16,7 @@ MAINTAINER= mom040267@gmail.com
COMMENT= STUN/TURN Server; IPv6, DTLS support; RFCs 5389, 5766, 6062, 6156
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
diff --git a/net/turnserver/files/patch-src_apps_common_apputils.c b/net/turnserver/files/patch-src_apps_common_apputils.c
new file mode 100644
index 000000000000..da72f8da02a5
--- /dev/null
+++ b/net/turnserver/files/patch-src_apps_common_apputils.c
@@ -0,0 +1,21 @@
+--- src/apps/common/apputils.c.orig 2015-09-30 07:05:14 UTC
++++ src/apps/common/apputils.c
+@@ -1037,13 +1037,15 @@ static const char* turn_get_method(const
+ if(!method)
+ return mdefault;
+ else {
+-
++#ifndef OPENSSL_NO_SSL3
+ if(method == SSLv3_server_method()) {
+ return "SSLv3";
+ } else if(method == SSLv3_client_method()) {
+ return "SSLv3";
+- } else if(method == SSLv23_server_method()) {
+- return "SSLv23";
++ } else
++#endif
++ if(method == SSLv23_server_method()) {
++ return "SSLv23";
+ } else if(method == SSLv23_client_method()) {
+ return "SSLv23";
+ } else if(method == TLSv1_server_method()) {
diff --git a/net/turnserver/files/patch-src_apps_uclient_mainuclient.c b/net/turnserver/files/patch-src_apps_uclient_mainuclient.c
new file mode 100644
index 000000000000..09b04d2e4c23
--- /dev/null
+++ b/net/turnserver/files/patch-src_apps_uclient_mainuclient.c
@@ -0,0 +1,14 @@
+--- src/apps/uclient/mainuclient.c.orig 2015-09-30 07:05:14 UTC
++++ src/apps/uclient/mainuclient.c
+@@ -483,9 +483,11 @@ int main(int argc, char **argv)
+ root_tls_ctx[root_tls_ctx_num] = SSL_CTX_new(SSLv23_client_method());
+ SSL_CTX_set_cipher_list(root_tls_ctx[root_tls_ctx_num], csuite);
+ root_tls_ctx_num++;
++#ifndef OPENSSL_NO_SSL3
+ root_tls_ctx[root_tls_ctx_num] = SSL_CTX_new(SSLv3_client_method());
+ SSL_CTX_set_cipher_list(root_tls_ctx[root_tls_ctx_num], csuite);
+ root_tls_ctx_num++;
++#endif
+ root_tls_ctx[root_tls_ctx_num] = SSL_CTX_new(TLSv1_client_method());
+ SSL_CTX_set_cipher_list(root_tls_ctx[root_tls_ctx_num], csuite);
+ root_tls_ctx_num++;