aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2013-02-05 21:56:19 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2013-02-05 21:56:19 +0000
commit32ca3ee61e3889801319024959589312eb652bfa (patch)
treee3cfda659132e3bcb297ded37cdf28c8ec3dc163
parentdfe07dd3351abc5a20356f31df11591ec81bfa34 (diff)
downloadports-32ca3ee61e3889801319024959589312eb652bfa.tar.gz
ports-32ca3ee61e3889801319024959589312eb652bfa.zip
Notes
-rw-r--r--multimedia/mplayer2/Makefile12
-rw-r--r--multimedia/mplayer2/distinfo4
-rw-r--r--multimedia/mplayer2/files/extra-patch-base_system_log2f21
-rw-r--r--multimedia/mplayer2/files/patch-stream-tvi_v4l.c17
4 files changed, 6 insertions, 48 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index d9526520e21c..6cd973865d45 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS= --cc=${CC} \
MAKE_ARGS+= BINDIR=${PREFIX}/bin \
CONFDIR=${PREFIX}/etc/mplayer
-MPLAYER2_SNAPSHOT_DATE= 2012-11-03
+MPLAYER2_SNAPSHOT_DATE= 2013-01-26
MPLAYER2_PORT_VERSION= 2.0.${MPLAYER2_SNAPSHOT_DATE:S/-//g}
MAKE_JOBS_SAFE= yes
@@ -85,10 +85,6 @@ CONFLICTS= mplayer-1.*
BROKEN= Does not compile on sparc64
.endif
-.if ${OSVERSION} < 802502
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-base_system_log2f
-.endif
-
.if ${OSVERSION} < 803000
CONFIGURE_ARGS+= --disable-ssse3
.endif
@@ -216,10 +212,10 @@ CONFIGURE_ARGS+= --disable-real
.if ${PORT_OPTIONS:MV4L}
BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
LIB_DEPENDS+= v4l2:${PORTSDIR}/multimedia/libv4l
-CONFIGURE_ARGS+= --enable-tv-v4l1 --enable-tv-v4l2
-EXTRA_LIBS+= -lv4l1 -lv4l2
+CONFIGURE_ARGS+= --enable-tv-v4l2
+EXTRA_LIBS+= -lv4l2
.else
-CONFIGURE_ARGS+= --disable-tv-v4l1 --disable-tv-v4l2
+CONFIGURE_ARGS+= --disable-tv-v4l2
.endif
.if defined(EXTRA_LIBS)
diff --git a/multimedia/mplayer2/distinfo b/multimedia/mplayer2/distinfo
index 3b641190599e..cfeafbf8d9fa 100644
--- a/multimedia/mplayer2/distinfo
+++ b/multimedia/mplayer2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mplayer2-2.0.20121103.tar.xz) = 5d938f8068595977c6198adf21cd1b1ba924f33aa05488df1fb637ce9f8999cd
-SIZE (mplayer2-2.0.20121103.tar.xz) = 1565152
+SHA256 (mplayer2-2.0.20130126.tar.xz) = 2dc6f852d8fe09e90cc4d816fe91537b571132b91582b291bdaa072a67470f73
+SIZE (mplayer2-2.0.20130126.tar.xz) = 1918172
diff --git a/multimedia/mplayer2/files/extra-patch-base_system_log2f b/multimedia/mplayer2/files/extra-patch-base_system_log2f
deleted file mode 100644
index b149c29ce690..000000000000
--- a/multimedia/mplayer2/files/extra-patch-base_system_log2f
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure~ 2012-05-12 01:10:33.294799627 -0500
-+++ configure 2012-05-12 01:13:51.714477505 -0500
-@@ -2819,7 +2819,7 @@ if test "$_posix4" = yes ; then
- fi
- echores "$_posix4"
-
--for func in exp2 exp2f llrint log2 log2f lrint lrintf round roundf truncf; do
-+for func in exp2 exp2f llrint lrint lrintf round roundf truncf; do
- echocheck $func
- eval _$func=no
- statement_check math.h "${func}(2.0)" -D_ISOC99_SOURCE $_ld_lm && eval _$func=yes
-@@ -2831,6 +2831,9 @@ else
- echores no
- fi
- done
-+for func in log2 log2f; do
-+ eval def_$func="\"#define HAVE_$(echo $func | tr '[a-z]' '[A-Z]') 0\""
-+done
-
-
- echocheck "mkstemp"
diff --git a/multimedia/mplayer2/files/patch-stream-tvi_v4l.c b/multimedia/mplayer2/files/patch-stream-tvi_v4l.c
deleted file mode 100644
index f2ed47905057..000000000000
--- a/multimedia/mplayer2/files/patch-stream-tvi_v4l.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- stream/tvi_v4l.c 2007-10-07 23:49:26.000000000 +0400
-+++ stream/tvi_v4l.c 2010-01-27 13:42:17.781746063 +0300
-@@ -48,6 +48,14 @@
-
- #include "audio_in.h"
-
-+#include <libv4l1.h>
-+#define open v4l1_open
-+#define close v4l1_close
-+#define dup v4l1_dup
-+#define ioctl v4l1_ioctl
-+#define mmap v4l1_mmap
-+#define munmap v4l1_munmap
-+
- static tvi_handle_t *tvi_init_v4l(tv_param_t* tv_param);
-
- tvi_info_t tvi_info_v4l = {