aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-09-30 21:10:03 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-09-30 21:10:03 +0000
commit355a8611494910c7e316c0c49da5184d11d2dc74 (patch)
treecf2ce7c67750a2aa717115582d0aa2a614af726b
parent6fef015ef21f38b183c7018719ac1dc9ac9f849d (diff)
downloadports-355a8611494910c7e316c0c49da5184d11d2dc74.tar.gz
ports-355a8611494910c7e316c0c49da5184d11d2dc74.zip
Notes
-rw-r--r--sysutils/acpica-tools/Makefile2
-rw-r--r--sysutils/acpica-tools/distinfo4
-rw-r--r--sysutils/acpica-tools/files/patch-source__compiler__aslmapenter.c39
-rw-r--r--sysutils/acpica-tools/files/patch-source__compiler__dtcompile.c20
-rw-r--r--sysutils/acpica-tools/files/patch-source__compiler__dtsubtable.c19
5 files changed, 42 insertions, 42 deletions
diff --git a/sysutils/acpica-tools/Makefile b/sysutils/acpica-tools/Makefile
index 7bb2f3c66473..98501ae0d1db 100644
--- a/sysutils/acpica-tools/Makefile
+++ b/sysutils/acpica-tools/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= acpica
-PORTVERSION= 20140828
+PORTVERSION= 20140926
CATEGORIES= sysutils devel
MASTER_SITES= https://acpica.org/sites/acpica/files/ \
LOCAL
diff --git a/sysutils/acpica-tools/distinfo b/sysutils/acpica-tools/distinfo
index 9c6d3a38bfce..b19c691b5bfc 100644
--- a/sysutils/acpica-tools/distinfo
+++ b/sysutils/acpica-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (acpica-unix2-20140828.tar.gz) = 01d8867656c5ba41dec307c4383ce676196ad4281ac2c9dec9f5be5fac6d888e
-SIZE (acpica-unix2-20140828.tar.gz) = 1306353
+SHA256 (acpica-unix2-20140926.tar.gz) = 51008174690dad2e9cdd8aebf2a958fd1c7dc8c322dcedd9ad932eb9c75abaed
+SIZE (acpica-unix2-20140926.tar.gz) = 1314910
diff --git a/sysutils/acpica-tools/files/patch-source__compiler__aslmapenter.c b/sysutils/acpica-tools/files/patch-source__compiler__aslmapenter.c
new file mode 100644
index 000000000000..0edac4aa405b
--- /dev/null
+++ b/sysutils/acpica-tools/files/patch-source__compiler__aslmapenter.c
@@ -0,0 +1,39 @@
+--- ../../source/compiler/aslmapenter.c.orig 2014-09-26 14:02:30.000000000 -0400
++++ ../../source/compiler/aslmapenter.c 2014-09-30 16:57:24.000000000 -0400
+@@ -216,6 +216,7 @@
+ ACPI_GPIO_INFO *Info;
+ ACPI_GPIO_INFO *NextGpio;
+ ACPI_GPIO_INFO *PrevGpio;
++ char *Buffer;
+
+
+ /*
+@@ -223,8 +224,8 @@
+ * sorted by both source device name and then the pin number. There is
+ * one block per pin.
+ */
+- Info = ACPI_CAST_PTR (ACPI_GPIO_INFO,
+- UtStringCacheCalloc (sizeof (ACPI_GPIO_INFO)));
++ Buffer = UtStringCacheCalloc (sizeof (ACPI_GPIO_INFO));
++ Info = ACPI_CAST_PTR (ACPI_GPIO_INFO, Buffer);
+
+ NextGpio = Gbl_GpioList;
+ PrevGpio = NULL;
+@@ -293,14 +294,15 @@
+ ACPI_SERIAL_INFO *Info;
+ ACPI_SERIAL_INFO *NextSerial;
+ ACPI_SERIAL_INFO *PrevSerial;
++ char *Buffer;
+
+
+ /*
+ * Allocate a new info block and insert it into the global Serial list
+ * sorted by both source device name and then the address.
+ */
+- Info = ACPI_CAST_PTR (ACPI_SERIAL_INFO,
+- UtStringCacheCalloc (sizeof (ACPI_SERIAL_INFO)));
++ Buffer = UtStringCacheCalloc (sizeof (ACPI_SERIAL_INFO));
++ Info = ACPI_CAST_PTR (ACPI_SERIAL_INFO, Buffer);
+
+ NextSerial = Gbl_SerialList;
+ PrevSerial = NULL;
diff --git a/sysutils/acpica-tools/files/patch-source__compiler__dtcompile.c b/sysutils/acpica-tools/files/patch-source__compiler__dtcompile.c
deleted file mode 100644
index e960f79f2e22..000000000000
--- a/sysutils/acpica-tools/files/patch-source__compiler__dtcompile.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ../../source/compiler/dtcompile.c 2014-08-28 13:10:01.000000000 -0400
-+++ ../../source/compiler/dtcompile.c 2014-09-19 16:32:31.000000000 -0400
-@@ -438,6 +438,7 @@
- UINT8 *Buffer;
- UINT8 *FlagBuffer = NULL;
- UINT32 CurrentFlagByteOffset = 0;
-+ char *String;
- ACPI_STATUS Status;
-
-
-@@ -465,7 +466,8 @@
-
- if (Length > 0)
- {
-- Subtable->Buffer = ACPI_CAST_PTR (UINT8, UtStringCacheCalloc (Length));
-+ String = UtStringCacheCalloc (Length);
-+ Subtable->Buffer = ACPI_CAST_PTR (UINT8, String);
- }
- Subtable->Length = Length;
- Subtable->TotalLength = Length;
diff --git a/sysutils/acpica-tools/files/patch-source__compiler__dtsubtable.c b/sysutils/acpica-tools/files/patch-source__compiler__dtsubtable.c
deleted file mode 100644
index 31e2bfa6bf60..000000000000
--- a/sysutils/acpica-tools/files/patch-source__compiler__dtsubtable.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- ../../source/compiler/dtsubtable.c 2014-08-28 13:10:01.000000000 -0400
-+++ ../../source/compiler/dtsubtable.c 2014-09-19 16:47:23.000000000 -0400
-@@ -73,13 +73,15 @@
- DT_SUBTABLE **RetSubtable)
- {
- DT_SUBTABLE *Subtable;
-+ char *String;
-
-
- Subtable = UtSubtableCacheCalloc ();
-
- /* Create a new buffer for the subtable data */
-
-- Subtable->Buffer = ACPI_CAST_PTR (UINT8, UtStringCacheCalloc (Length));
-+ String = UtStringCacheCalloc (Length);
-+ Subtable->Buffer = ACPI_CAST_PTR (UINT8, String);
- ACPI_MEMCPY (Subtable->Buffer, Buffer, Length);
-
- Subtable->Length = Length;