aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-05 17:59:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-05 17:59:11 +0000
commit38863df1807e786422abac0f06a0e799e3982df8 (patch)
treedd8c9697321568d14b0fa5c6baa406eb3c017f03
parentd2a224c6a9a595c4a14c8a8789edc869f7ffce57 (diff)
downloadports-38863df1807e786422abac0f06a0e799e3982df8.tar.gz
ports-38863df1807e786422abac0f06a0e799e3982df8.zip
MFH: r370894
Add missing dependencies and CPE data. Approved by: maintainer silence Approved by: ports-secteam (delphij)
Notes
Notes: svn path=/branches/2014Q4/; revision=374067
-rw-r--r--german/wordpress/Makefile9
-rw-r--r--japanese/wordpress/Makefile9
-rw-r--r--russian/wordpress/Makefile9
-rw-r--r--www/wordpress/Makefile8
4 files changed, 31 insertions, 4 deletions
diff --git a/german/wordpress/Makefile b/german/wordpress/Makefile
index 37072ee7d9ce..70688d3b93bd 100644
--- a/german/wordpress/Makefile
+++ b/german/wordpress/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wordpress
PORTVERSION= 3.9.1
+PORTREVISION= 1
CATEGORIES= german www
MASTER_SITES= http://de.wordpress.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-de_DE
@@ -15,10 +16,16 @@ LICENSE= GPLv2
CONFLICTS_INSTALL= wordpress-3.* ja-wordpress-3.* ru-wordpress-3.*
NO_BUILD= yes
-USE_PHP= curl gd mysql pcre tokenizer xml zip
+USES= cpe
+USE_PHP= curl gd mysql pcre tokenizer xml zip zlib
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+CPE_LANG= de
+.if ${PORTVERSION:N*.*.*}
+CPE_VERSION= ${PORTVERSION}.0
+.endif
+
SUB_FILES= pkg-message pkg-install
SUB_LIST= CHGRP="${CHGRP}" CHOWN="${CHOWN}" CHMOD="${CHMOD}"\
FIND="${FIND}" WWWGRP="${WWWGRP}" WWWOWN="${WWWOWN}"
diff --git a/japanese/wordpress/Makefile b/japanese/wordpress/Makefile
index b77561e10f73..8b0922874887 100644
--- a/japanese/wordpress/Makefile
+++ b/japanese/wordpress/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wordpress
PORTVERSION= 3.9.1
+PORTREVISION= 1
CATEGORIES= japanese www
MASTER_SITES= http://ja.wordpress.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-ja
@@ -15,10 +16,16 @@ LICENSE= GPLv2
CONFLICTS_INSTALL= wordpress-3.* de-wordpress-3.* ru-wordpress-3.*
NO_BUILD= yes
-USE_PHP= curl gd mysql pcre tokenizer xml zip
+USES= cpe
+USE_PHP= curl gd mysql pcre tokenizer xml zip zlib
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+CPE_LANG= ja
+.if ${PORTVERSION:N*.*.*}
+CPE_VERSION= ${PORTVERSION}.0
+.endif
+
SUB_FILES= pkg-message
PLIST= ${WRKDIR}/pkg-plist
PORTDOCS= license.txt readme.html
diff --git a/russian/wordpress/Makefile b/russian/wordpress/Makefile
index 590ac32b1c80..b42bab5fa85d 100644
--- a/russian/wordpress/Makefile
+++ b/russian/wordpress/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wordpress
PORTVERSION= 4.0
+PORTREVISION= 1
CATEGORIES= russian www
MASTER_SITES= http://ru.wordpress.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-ru_RU
@@ -15,10 +16,16 @@ LICENSE= GPLv2
CONFLICTS_INSTALL= wordpress-3.* de-wordpress-3.* ja-wordpress-3.*
NO_BUILD= yes
-USE_PHP= curl gd mysql pcre tokenizer xml zip
+USES= cpe
+USE_PHP= curl gd hash mysql pcre tokenizer xml zip zlib
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+CPE_LANG= ru
+.if ${PORTVERSION:N*.*.*}
+CPE_VERSION= ${PORTVERSION}.0
+.endif
+
SUB_FILES= pkg-message
PLIST= ${WRKDIR}/pkg-plist
PORTDOCS= license.txt readme.html
diff --git a/www/wordpress/Makefile b/www/wordpress/Makefile
index 740b16e47eac..2ca619668d34 100644
--- a/www/wordpress/Makefile
+++ b/www/wordpress/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wordpress
PORTVERSION= 4.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://wordpress.org/
@@ -15,10 +16,15 @@ LICENSE= GPLv2
CONFLICTS_INSTALL= de-wordpress-3.* ja-wordpress-3.* ru-wordpress-3.*
NO_BUILD= yes
-USE_PHP= curl gd mysql pcre tokenizer xml zip
+USES= cpe
+USE_PHP= curl gd hash mysql pcre tokenizer xml zip zlib
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+.if ${PORTVERSION:N*.*.*}
+CPE_VERSION= ${PORTVERSION}.0
+.endif
+
SUB_FILES= pkg-message
PLIST= ${WRKDIR}/pkg-plist
PORTDOCS= license.txt readme.html