aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-12-13 20:12:07 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-12-13 20:12:07 +0000
commit4601c6e9b8a2beabc5cf98fda691f9e7e36f04f2 (patch)
tree637091439cdcc8147be4ac75c154c4bd9a76c67a
parentbc0dc7b18ea8b9b323390451b225b6f524963a12 (diff)
downloadports-4601c6e9b8a2beabc5cf98fda691f9e7e36f04f2.tar.gz
ports-4601c6e9b8a2beabc5cf98fda691f9e7e36f04f2.zip
MFH r374144, r374594, r374674, and r374681.
r374144: Rename bs and fish to avoid conflicts with games/bs and shells/fish. While here, get on board with @dir. r374594: Fix a bounds-checking typo in trek. The number of sectors was being used to check input for the quadrant, and NSECTS > NQUADS. r374674: Since r367027, the setgid games have been installed as setgid root instead of setgid root. The port redefines BINGRP when necessary, but since BINGRP was being passed in MAKE_ARGS, it overrode those redefinitions. Passing BINGRP in MAKE_ENV instead should allow uidfix to still work, while making sure that the games are installed with the correct group. r374681: Revert the contents of r374674, as it broke packaging as a regular user. Instead, set the group and mode manually in the plist. Approved by: portmgr (antoine)
Notes
Notes: svn path=/branches/2014Q4/; revision=374683
-rw-r--r--games/bsdgames/Makefile7
-rw-r--r--games/bsdgames/files/patch-trek_computer.c15
-rw-r--r--games/bsdgames/pkg-plist99
3 files changed, 66 insertions, 55 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 6358135fa2f3..32cff10bf870 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bsdgames
PORTVERSION= 3.8.2
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= games
# Fetched from git://git.dragonflybsd.org/dragonfly.git, v${PORTVERSION}, /games
@@ -75,6 +76,12 @@ pre-install:
.endfor
post-install:
+# avoid conflict with games/bs and shells/fish
+.for prog in bs fish
+ ${MV} ${STAGEDIR}${PREFIX}/bin/${prog} ${STAGEDIR}${PREFIX}/bin/${prog}-game
+ ${MV} ${STAGEDIR}${MAN6PREFIX}/man/man6/${prog}.6.gz ${STAGEDIR}${MAN6PREFIX}/man/man6/${prog}-game.6.gz
+.endfor
+
@${TOUCH} ${STAGEDIR}/var/games/atc_score
@${FIND} ${STAGEDIR}/var/games -type f -exec ${MV} {} {}.sample \;
diff --git a/games/bsdgames/files/patch-trek_computer.c b/games/bsdgames/files/patch-trek_computer.c
new file mode 100644
index 000000000000..58a062a4d35d
--- /dev/null
+++ b/games/bsdgames/files/patch-trek_computer.c
@@ -0,0 +1,15 @@
+--- trek/computer.c.orig 2014-12-12 15:10:37 UTC
++++ trek/computer.c
+@@ -175,10 +175,10 @@ computer(int v __unused)
+ tqy = Ship.quady;
+ } else {
+ ix = getintpar("Quadrant");
+- if (ix < 0 || ix >= NSECTS)
++ if (ix < 0 || ix >= NQUADS)
+ break;
+ iy = getintpar("q-y");
+- if (iy < 0 || iy >= NSECTS)
++ if (iy < 0 || iy >= NQUADS)
+ break;
+ tqx = ix;
+ tqy = iy;
diff --git a/games/bsdgames/pkg-plist b/games/bsdgames/pkg-plist
index e8b366fc19ff..62bc9a3db5a1 100644
--- a/games/bsdgames/pkg-plist
+++ b/games/bsdgames/pkg-plist
@@ -1,28 +1,28 @@
bin/adventure
bin/arithmetic
-bin/atc
+@(,games,2555) bin/atc
bin/backgammon
-bin/battlestar
-bin/bs
-bin/canfield
+@(,games,2555) bin/battlestar
+bin/bs-game
+@(,games,2555) bin/canfield
bin/cfscores
-bin/cribbage
-bin/fish
-bin/hack
+@(,games,2555) bin/cribbage
+bin/fish-game
+@(,games,2555) bin/hack
bin/hangman
bin/hunt
bin/huntd
bin/larn
bin/mille
-bin/phantasia
+@(,games,2555) bin/phantasia
bin/piano
bin/pig
bin/quiz
bin/rain
-bin/robots
+@(,games,2555) bin/robots
bin/rogue
-bin/sail
-bin/snake
+@(,games,2555) bin/sail
+@(,games,2555) bin/snake
bin/snscore
bin/teachgammon
bin/trek
@@ -35,11 +35,11 @@ man/man6/arithmetic.6.gz
man/man6/atc.6.gz
man/man6/backgammon.6.gz
man/man6/battlestar.6.gz
-man/man6/bs.6.gz
+man/man6/bs-game.6.gz
man/man6/canfield.6.gz
man/man6/cfscores.6.gz
man/man6/cribbage.6.gz
-man/man6/fish.6.gz
+man/man6/fish-game.6.gz
man/man6/hack.6.gz
man/man6/hangman.6.gz
man/man6/hunt.6.gz
@@ -106,45 +106,34 @@ share/games/quiz.db/ucc
share/games/cribbage.instr
share/games/fish.instr
share/games/wump.info
-@dirrm share/games/atc
-@dirrm share/games/larn
-@dirrm share/games/quiz.db
-@dirrm share/games
-@group games
-@mode 664
-@sample /var/games/atc_score.sample
-@sample /var/games/battlestar.log.sample
-@sample /var/games/cfscores.sample
-@sample /var/games/criblog.sample
-@sample /var/games/hackdir/help.sample
-@sample /var/games/hackdir/hh.sample
-@sample /var/games/hackdir/data.sample
-@sample /var/games/hackdir/perm.sample
-@sample /var/games/hackdir/record.sample
-@sample /var/games/hackdir/rumors.sample
-@sample /var/games/larn/lscore12.0.sample
-@sample /var/games/larn/llog12.0.sample
-@sample /var/games/phantasia/monsters.sample
-@sample /var/games/phantasia/void.sample
-@sample /var/games/phantasia/characs.sample
-@sample /var/games/phantasia/gold.sample
-@sample /var/games/phantasia/lastdead.sample
-@sample /var/games/phantasia/mess.sample
-@sample /var/games/phantasia/motd.sample
-@sample /var/games/phantasia/scoreboard.sample
-@sample /var/games/robots_roll.sample
-@sample /var/games/rogue.scores.sample
-@sample /var/games/saillog.sample
-@sample /var/games/snakerawscores.sample
-@sample /var/games/snake.log.sample
-@mode 0775
-@dirrmtry /var/games/phantasia
-@dirrmtry /var/games/larn
-@mode 0770
-@dirrmtry /var/games/hackdir/save
-@mode 0775
-@dirrmtry /var/games/hackdir
-@dirrmtry /var/games/battlestar
-@dirrmtry /var/games/atc
-@group wheel
-@mode
+@sample(,games,0664) /var/games/atc_score.sample
+@sample(,games,0664) /var/games/battlestar.log.sample
+@sample(,games,0664) /var/games/cfscores.sample
+@sample(,games,0664) /var/games/criblog.sample
+@sample(,games,0664) /var/games/hackdir/help.sample
+@sample(,games,0664) /var/games/hackdir/hh.sample
+@sample(,games,0664) /var/games/hackdir/data.sample
+@sample(,games,0664) /var/games/hackdir/perm.sample
+@sample(,games,0664) /var/games/hackdir/record.sample
+@sample(,games,0664) /var/games/hackdir/rumors.sample
+@sample(,games,0664) /var/games/larn/lscore12.0.sample
+@sample(,games,0664) /var/games/larn/llog12.0.sample
+@sample(,games,0664) /var/games/phantasia/monsters.sample
+@sample(,games,0664) /var/games/phantasia/void.sample
+@sample(,games,0664) /var/games/phantasia/characs.sample
+@sample(,games,0664) /var/games/phantasia/gold.sample
+@sample(,games,0664) /var/games/phantasia/lastdead.sample
+@sample(,games,0664) /var/games/phantasia/mess.sample
+@sample(,games,0664) /var/games/phantasia/motd.sample
+@sample(,games,0664) /var/games/phantasia/scoreboard.sample
+@sample(,games,0664) /var/games/robots_roll.sample
+@sample(,games,0664) /var/games/rogue.scores.sample
+@sample(,games,0664) /var/games/saillog.sample
+@sample(,games,0664) /var/games/snakerawscores.sample
+@sample(,games,0664) /var/games/snake.log.sample
+@dir(,games,0775) /var/games/phantasia
+@dir(,games,0775) /var/games/larn
+@dir(,games,0770) /var/games/hackdir/save
+@dir(,games,0775) /var/games/hackdir
+@dir(,games,0775) /var/games/battlestar
+@dir(,games,0775) /var/games/atc