aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick S. Gardella <patrick@FreeBSD.org>2000-10-30 02:31:15 +0000
committerPatrick S. Gardella <patrick@FreeBSD.org>2000-10-30 02:31:15 +0000
commit496862dd97cfb6104f3e2ad96a91aaa6a5d9796a (patch)
treecbccd068e127b95469fcd98ecbe73108dd493eb5
parente36a2ec841928b56eb3bc16583dece65648e7ed1 (diff)
downloadports-496862dd97cfb6104f3e2ad96a91aaa6a5d9796a.tar.gz
ports-496862dd97cfb6104f3e2ad96a91aaa6a5d9796a.zip
Notes
-rw-r--r--lang/Makefile1
-rw-r--r--lang/pfe-devel/Makefile22
-rw-r--r--lang/pfe-devel/distinfo1
-rw-r--r--lang/pfe-devel/pkg-comment1
-rw-r--r--lang/pfe-devel/pkg-descr14
-rw-r--r--lang/pfe-devel/pkg-plist55
-rw-r--r--lang/pfe/Makefile22
-rw-r--r--lang/pfe/distinfo1
-rw-r--r--lang/pfe/pkg-comment1
-rw-r--r--lang/pfe/pkg-descr14
-rw-r--r--lang/pfe/pkg-plist55
11 files changed, 187 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 5933713fa568..44de58bf7313 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -77,6 +77,7 @@
SUBDIR += p5-ePerl
SUBDIR += pbasic
SUBDIR += perl5
+ SUBDIR += pfe-devel
SUBDIR += pgcc
SUBDIR += pike
SUBDIR += pm3-base
diff --git a/lang/pfe-devel/Makefile b/lang/pfe-devel/Makefile
new file mode 100644
index 000000000000..9ccfe76e4369
--- /dev/null
+++ b/lang/pfe-devel/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: pfe-devel
+# Date created: 29 October 2000
+# Whom: patrick
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfe
+PORTVERSION= 0.30.16
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= patrick@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+ALL_TARGET= #
+
+.include <bsd.port.mk>
diff --git a/lang/pfe-devel/distinfo b/lang/pfe-devel/distinfo
new file mode 100644
index 000000000000..b0ea71368604
--- /dev/null
+++ b/lang/pfe-devel/distinfo
@@ -0,0 +1 @@
+MD5 (pfe-0.30.16.tar.bz2) = 6bfc38c2969f91a7547fa40f2ae5239a
diff --git a/lang/pfe-devel/pkg-comment b/lang/pfe-devel/pkg-comment
new file mode 100644
index 000000000000..b944377cd2cf
--- /dev/null
+++ b/lang/pfe-devel/pkg-comment
@@ -0,0 +1 @@
+Implementation of ANSI Forth
diff --git a/lang/pfe-devel/pkg-descr b/lang/pfe-devel/pkg-descr
new file mode 100644
index 000000000000..f6d5b1d87bf8
--- /dev/null
+++ b/lang/pfe-devel/pkg-descr
@@ -0,0 +1,14 @@
+This package contains all neccessary ANSI-C source files to build a
+running Forth-environment on most UNIX machines, on DOS and on OS/2.
+
+The Forth-system is closely modeled along the new American National
+Standard for the programming language Forth. Every word of every
+word set mentioned in the dpANS-6 document of June 1993 has been
+implemented. Additionally it is compatible to Forth-83.
+
+This is a new development version of pfe 0.29.1 under a new
+developer.
+
+WWW: http://pfe.sourceforge.net/
+
+- patrick
diff --git a/lang/pfe-devel/pkg-plist b/lang/pfe-devel/pkg-plist
new file mode 100644
index 000000000000..290845bd871b
--- /dev/null
+++ b/lang/pfe-devel/pkg-plist
@@ -0,0 +1,55 @@
+bin/pfe
+lib/libpfe-0.30.16.so
+lib/libpfe.so
+lib/libpfe.la
+lib/libpfe.a
+lib/pfe/edit.la
+lib/pfe/edit.a
+lib/pfe/edit.so
+include/pfe-target.h
+include/pfe-config.h
+include/pfe/block-ext.h
+include/pfe/forth-83-l-p-ext.h
+include/pfe/config.h
+include/pfe/incl-ext.h
+include/pfe/core-ext.h
+include/pfe/incl-sub.h
+include/pfe/debug-ext.h
+include/pfe/incl-sup.h
+include/pfe/def-comp.h
+include/pfe/lined.h
+include/pfe/def-config.h
+include/pfe/locals-ext.h
+include/pfe/def-const.h
+include/pfe/logging.h
+include/pfe/def-macro.h
+include/pfe/main-sub.h
+include/pfe/def-paths.h
+include/pfe/memory-alloc-ext.h
+include/pfe/def-regs.h
+include/pfe/misc-fig-ext.h
+include/pfe/def-types.h
+include/pfe/pfe.h
+include/pfe/def-words.h
+include/pfe/posix-ext.h
+include/pfe/dlfcn-sub.h
+include/pfe/search-order-ext.h
+include/pfe/double-ext.h
+include/pfe/shell-os-ext.h
+include/pfe/double-sub.h
+include/pfe/signals-ext.h
+include/pfe/edit-ext.h
+include/pfe/string-ext.h
+include/pfe/exception-ext.h
+include/pfe/term-ext.h
+include/pfe/facility-ext.h
+include/pfe/term-sub.h
+include/pfe/file-ext.h
+include/pfe/tools-ext.h
+include/pfe/floating-ext.h
+include/pfe/useful-ext.h
+include/pfe/forth-83-ext.h
+include/pfe/your-ext.h
+@dirrm lib/pfe
+@dirrm include/pfe
+
diff --git a/lang/pfe/Makefile b/lang/pfe/Makefile
new file mode 100644
index 000000000000..9ccfe76e4369
--- /dev/null
+++ b/lang/pfe/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: pfe-devel
+# Date created: 29 October 2000
+# Whom: patrick
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfe
+PORTVERSION= 0.30.16
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= patrick@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+ALL_TARGET= #
+
+.include <bsd.port.mk>
diff --git a/lang/pfe/distinfo b/lang/pfe/distinfo
new file mode 100644
index 000000000000..b0ea71368604
--- /dev/null
+++ b/lang/pfe/distinfo
@@ -0,0 +1 @@
+MD5 (pfe-0.30.16.tar.bz2) = 6bfc38c2969f91a7547fa40f2ae5239a
diff --git a/lang/pfe/pkg-comment b/lang/pfe/pkg-comment
new file mode 100644
index 000000000000..b944377cd2cf
--- /dev/null
+++ b/lang/pfe/pkg-comment
@@ -0,0 +1 @@
+Implementation of ANSI Forth
diff --git a/lang/pfe/pkg-descr b/lang/pfe/pkg-descr
new file mode 100644
index 000000000000..f6d5b1d87bf8
--- /dev/null
+++ b/lang/pfe/pkg-descr
@@ -0,0 +1,14 @@
+This package contains all neccessary ANSI-C source files to build a
+running Forth-environment on most UNIX machines, on DOS and on OS/2.
+
+The Forth-system is closely modeled along the new American National
+Standard for the programming language Forth. Every word of every
+word set mentioned in the dpANS-6 document of June 1993 has been
+implemented. Additionally it is compatible to Forth-83.
+
+This is a new development version of pfe 0.29.1 under a new
+developer.
+
+WWW: http://pfe.sourceforge.net/
+
+- patrick
diff --git a/lang/pfe/pkg-plist b/lang/pfe/pkg-plist
new file mode 100644
index 000000000000..290845bd871b
--- /dev/null
+++ b/lang/pfe/pkg-plist
@@ -0,0 +1,55 @@
+bin/pfe
+lib/libpfe-0.30.16.so
+lib/libpfe.so
+lib/libpfe.la
+lib/libpfe.a
+lib/pfe/edit.la
+lib/pfe/edit.a
+lib/pfe/edit.so
+include/pfe-target.h
+include/pfe-config.h
+include/pfe/block-ext.h
+include/pfe/forth-83-l-p-ext.h
+include/pfe/config.h
+include/pfe/incl-ext.h
+include/pfe/core-ext.h
+include/pfe/incl-sub.h
+include/pfe/debug-ext.h
+include/pfe/incl-sup.h
+include/pfe/def-comp.h
+include/pfe/lined.h
+include/pfe/def-config.h
+include/pfe/locals-ext.h
+include/pfe/def-const.h
+include/pfe/logging.h
+include/pfe/def-macro.h
+include/pfe/main-sub.h
+include/pfe/def-paths.h
+include/pfe/memory-alloc-ext.h
+include/pfe/def-regs.h
+include/pfe/misc-fig-ext.h
+include/pfe/def-types.h
+include/pfe/pfe.h
+include/pfe/def-words.h
+include/pfe/posix-ext.h
+include/pfe/dlfcn-sub.h
+include/pfe/search-order-ext.h
+include/pfe/double-ext.h
+include/pfe/shell-os-ext.h
+include/pfe/double-sub.h
+include/pfe/signals-ext.h
+include/pfe/edit-ext.h
+include/pfe/string-ext.h
+include/pfe/exception-ext.h
+include/pfe/term-ext.h
+include/pfe/facility-ext.h
+include/pfe/term-sub.h
+include/pfe/file-ext.h
+include/pfe/tools-ext.h
+include/pfe/floating-ext.h
+include/pfe/useful-ext.h
+include/pfe/forth-83-ext.h
+include/pfe/your-ext.h
+@dirrm lib/pfe
+@dirrm include/pfe
+