aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-12-12 08:58:35 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-12-12 08:58:35 +0000
commit55411519b53b40dd381b47e2223fa026fc4d1974 (patch)
treea8bab37853fc9a26538b7c44f2b09802bde5ea28
parent2f671cc1fa19387cbd8a3e2afa28cd9795639f4c (diff)
downloadports-55411519b53b40dd381b47e2223fa026fc4d1974.tar.gz
ports-55411519b53b40dd381b47e2223fa026fc4d1974.zip
MFH r369846, r372450, r374406:
- Re-add PKGNAMEPREFIX for www/linux-f10-flashplugin11 - Honor LINUXBASE in pkg-plist - Reduce diff between linux-c6-flashplugin11 and linux-f10-flashplugin11 - Update to 11.2r202.418 - Update to 11.2r202.425 Approved by: ports-secteam (delphij)
Notes
Notes: svn path=/branches/2014Q4/; revision=374576
-rw-r--r--www/linux-c6-flashplugin11/Makefile9
-rw-r--r--www/linux-c6-flashplugin11/distinfo8
-rw-r--r--www/linux-c6-flashplugin11/pkg-plist2
-rw-r--r--www/linux-f10-flashplugin11/Makefile11
-rw-r--r--www/linux-f10-flashplugin11/distinfo8
-rw-r--r--www/linux-f10-flashplugin11/pkg-plist2
6 files changed, 21 insertions, 19 deletions
diff --git a/www/linux-c6-flashplugin11/Makefile b/www/linux-c6-flashplugin11/Makefile
index 9fff3b5b3224..53337b8a5991 100644
--- a/www/linux-c6-flashplugin11/Makefile
+++ b/www/linux-c6-flashplugin11/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= flashplugin
-PORTVERSION= 11.2r202.406
+PORTVERSION= 11.2r202.425
CATEGORIES= www multimedia linux
MASTER_SITES= http://fpdownload.macromedia.com/get/flashplayer/pdc/${PORTVERSION:C/r/\./}/:plugin \
LOCAL/nox:suplib
@@ -16,7 +16,7 @@ COMMENT= Adobe Flash Player NPAPI Plugin
ONLY_FOR_ARCHS= amd64 i386
USE_LINUX= c6
-USE_LINUX_APPS= openssl-compat curl cyrus-sasl2 nspr nss gtk2 #-alsalib libssh2 openldap
+USE_LINUX_APPS= curl cyrus-sasl2 gtk2 nspr nss openssl-compat #-alsalib libssh2 openldap
WANT_GNOME= yes
RESTRICTED= Redistribution not allowed
@@ -31,10 +31,11 @@ WEBPLUGIN_FILES= libflashplayer.so
OPTIONS_DEFINE= GNOME
GNOME_DESC= include gnome support for .desktop file
-CPE_VENDOR= adobe
-CPE_PRODUCT= flash_player
+CPE_VENDOR= adobe
+CPE_PRODUCT= flash_player
OPTIONS_SUB= yes
+PLIST_SUB= LINUXBASE="${LINUXBASE}"
.include <bsd.port.options.mk>
diff --git a/www/linux-c6-flashplugin11/distinfo b/www/linux-c6-flashplugin11/distinfo
index 47b395a7f200..8ffafd7b0f6a 100644
--- a/www/linux-c6-flashplugin11/distinfo
+++ b/www/linux-c6-flashplugin11/distinfo
@@ -1,4 +1,4 @@
-SHA256 (flashplugin/11.2r202.406/install_flash_player_11_linux.i386.tar.gz) = 8b44f49b85ed7dba310306cd62a3de35d37bb8468c3841e4d713a0b80541c381
-SIZE (flashplugin/11.2r202.406/install_flash_player_11_linux.i386.tar.gz) = 6925631
-SHA256 (flashplugin/11.2r202.406/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 4a309b1a326bd2212cc72480628659e5a7fd61d9e0572cb7350c206f030955bf
-SIZE (flashplugin/11.2r202.406/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
+SHA256 (flashplugin/11.2r202.425/install_flash_player_11_linux.i386.tar.gz) = 0be4858e345e078fbb34a6eeefef53ed1bc09dff75134fc0508c37f080b99149
+SIZE (flashplugin/11.2r202.425/install_flash_player_11_linux.i386.tar.gz) = 6926590
+SHA256 (flashplugin/11.2r202.425/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 4a309b1a326bd2212cc72480628659e5a7fd61d9e0572cb7350c206f030955bf
+SIZE (flashplugin/11.2r202.425/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
diff --git a/www/linux-c6-flashplugin11/pkg-plist b/www/linux-c6-flashplugin11/pkg-plist
index 7b99be71f494..2c7522a89d75 100644
--- a/www/linux-c6-flashplugin11/pkg-plist
+++ b/www/linux-c6-flashplugin11/pkg-plist
@@ -6,4 +6,4 @@ share/icons/hicolor/22x22/apps/flash-player-properties.png
share/icons/hicolor/24x24/apps/flash-player-properties.png
share/icons/hicolor/32x32/apps/flash-player-properties.png
share/icons/hicolor/48x48/apps/flash-player-properties.png
-/compat/linux/usr/lib/libflashsupport.so
+%%LINUXBASE%%/usr/lib/libflashsupport.so
diff --git a/www/linux-f10-flashplugin11/Makefile b/www/linux-f10-flashplugin11/Makefile
index 41a60c7bb1b6..1f6a129a0633 100644
--- a/www/linux-f10-flashplugin11/Makefile
+++ b/www/linux-f10-flashplugin11/Makefile
@@ -2,21 +2,21 @@
# $FreeBSD$
PORTNAME= flashplugin
-PORTVERSION= 11.2r202.406
+PORTVERSION= 11.2r202.425
CATEGORIES= www multimedia linux
MASTER_SITES= http://fpdownload.macromedia.com/get/flashplayer/pdc/${PORTVERSION:C/r/\./}/:plugin \
LOCAL/nox:suplib
+PKGNAMEPREFIX= linux-${USE_LINUX}-
DISTFILES= install_flash_player_11_linux.i386.tar.gz:plugin \
linux-f10-flashsupport-9.0.1.i386.tar.gz:suplib
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Adobe Flash Player NPAPI Plugin
-DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
-
ONLY_FOR_ARCHS= amd64 i386
-USE_LINUX= yes
-USE_LINUX_APPS= openssl curl cyrus-sasl2 libssh2 nspr nss openldap gtk2
+USE_LINUX= f10
+USE_LINUX_APPS= curl cyrus-sasl2 gtk2 libssh2 nspr nss openldap openssl
WANT_GNOME= yes
RESTRICTED= Redistribution not allowed
@@ -35,6 +35,7 @@ CPE_VENDOR= adobe
CPE_PRODUCT= flash_player
OPTIONS_SUB= yes
+PLIST_SUB= LINUXBASE="${LINUXBASE}"
.include <bsd.port.options.mk>
diff --git a/www/linux-f10-flashplugin11/distinfo b/www/linux-f10-flashplugin11/distinfo
index 47b395a7f200..8ffafd7b0f6a 100644
--- a/www/linux-f10-flashplugin11/distinfo
+++ b/www/linux-f10-flashplugin11/distinfo
@@ -1,4 +1,4 @@
-SHA256 (flashplugin/11.2r202.406/install_flash_player_11_linux.i386.tar.gz) = 8b44f49b85ed7dba310306cd62a3de35d37bb8468c3841e4d713a0b80541c381
-SIZE (flashplugin/11.2r202.406/install_flash_player_11_linux.i386.tar.gz) = 6925631
-SHA256 (flashplugin/11.2r202.406/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 4a309b1a326bd2212cc72480628659e5a7fd61d9e0572cb7350c206f030955bf
-SIZE (flashplugin/11.2r202.406/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
+SHA256 (flashplugin/11.2r202.425/install_flash_player_11_linux.i386.tar.gz) = 0be4858e345e078fbb34a6eeefef53ed1bc09dff75134fc0508c37f080b99149
+SIZE (flashplugin/11.2r202.425/install_flash_player_11_linux.i386.tar.gz) = 6926590
+SHA256 (flashplugin/11.2r202.425/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 4a309b1a326bd2212cc72480628659e5a7fd61d9e0572cb7350c206f030955bf
+SIZE (flashplugin/11.2r202.425/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
diff --git a/www/linux-f10-flashplugin11/pkg-plist b/www/linux-f10-flashplugin11/pkg-plist
index 7b99be71f494..2c7522a89d75 100644
--- a/www/linux-f10-flashplugin11/pkg-plist
+++ b/www/linux-f10-flashplugin11/pkg-plist
@@ -6,4 +6,4 @@ share/icons/hicolor/22x22/apps/flash-player-properties.png
share/icons/hicolor/24x24/apps/flash-player-properties.png
share/icons/hicolor/32x32/apps/flash-player-properties.png
share/icons/hicolor/48x48/apps/flash-player-properties.png
-/compat/linux/usr/lib/libflashsupport.so
+%%LINUXBASE%%/usr/lib/libflashsupport.so