aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-03-31 01:15:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-03-31 01:15:00 +0000
commit591eabe82e1756af4e164101163ac48bc539f446 (patch)
tree24fc9ab0f0162d2e169a30e26c499e4db77b2bda
parent375c1889b2c1ad267a8bcf2adc264d6314f68d61 (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Role-Tiny/Makefile40
-rw-r--r--devel/p5-Role-Tiny/distinfo2
-rw-r--r--devel/p5-Role-Tiny/pkg-descr13
-rw-r--r--devel/p5-Role-Tiny/pkg-plist6
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d59043b58e2a..2878da3c9cfb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2351,6 +2351,7 @@
SUBDIR += p5-Return-Value
SUBDIR += p5-Role-HasMessage
SUBDIR += p5-Role-Identifiable
+ SUBDIR += p5-Role-Tiny
SUBDIR += p5-Rose-DateTime
SUBDIR += p5-Rose-Object
SUBDIR += p5-RunApp
diff --git a/devel/p5-Role-Tiny/Makefile b/devel/p5-Role-Tiny/Makefile
new file mode 100644
index 000000000000..b9af32ea1957
--- /dev/null
+++ b/devel/p5-Role-Tiny/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-Role-Tiny
+# Date created: 2012-03-31
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Role-Tiny
+PORTVERSION= 1.000.000
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MSTROUT
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Roles, like a nouvelle cusine portion size slice of Moose
+
+BUILD_DEPENDS= p5-Class-Method-Modifiers>=0:${PORTSDIR}/devel/p5-Class-Method-Modifiers
+RUN_DEPENDS= p5-Class-Method-Modifiers>=0:${PORTSDIR}/devel/p5-Class-Method-Modifiers
+
+TEST_DEPENDS= p5-Test-Fatal>=0.003:${PORTSDIR}/devel/p5-Test-Fatal
+
+PERL_CONFIGURE= yes
+
+MAN3= Role::Tiny.3 \
+ Role::Tiny::With.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
+RUN_DEPENDS+= p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
+.endif
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Role-Tiny/distinfo b/devel/p5-Role-Tiny/distinfo
new file mode 100644
index 000000000000..6f2b03489e40
--- /dev/null
+++ b/devel/p5-Role-Tiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Role-Tiny-1.000000.tar.gz) = 68864357cdec72a4094b38986d642f28eccaafafc1b8184bf82c282ff5d1e2f8
+SIZE (Role-Tiny-1.000000.tar.gz) = 8622
diff --git a/devel/p5-Role-Tiny/pkg-descr b/devel/p5-Role-Tiny/pkg-descr
new file mode 100644
index 000000000000..c0ca63349cf4
--- /dev/null
+++ b/devel/p5-Role-Tiny/pkg-descr
@@ -0,0 +1,13 @@
+Role composition can be thought of as much more clever and meaningful multiple
+inheritance. The basics of this implementation of roles is:
+- If a method is already defined on a class, that method will not be composed in
+ from the role.
+- If a method that the role "requires" to be implemented is not implemented,
+ role application will fail loudly.
+
+Unlike Class::C3, where the last class inherited from "wins," role composition
+is the other way around, where first wins. In a more complete system (see Moose)
+roles are checked to see if they clash. The goal of this is to be much simpler,
+hence disallowing composition of multiple roles at once.
+
+WWW: http://search.cpan.org/dist/Role-Tiny/
diff --git a/devel/p5-Role-Tiny/pkg-plist b/devel/p5-Role-Tiny/pkg-plist
new file mode 100644
index 000000000000..f9dc6581e136
--- /dev/null
+++ b/devel/p5-Role-Tiny/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Role/Tiny.pm
+%%SITE_PERL%%/Role/Tiny/With.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Role-Tiny/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Role-Tiny
+@dirrmtry %%SITE_PERL%%/Role/Tiny
+@dirrmtry %%SITE_PERL%%/Role